"Collabora online could not be loaded" after update

Good evening all,

when trying to open a document (in this case, Libreoffice ods files) I’m getting the message
“Collabora Online konnte nicht geladen werden - Bitte versuche es später noch einmal.”
(Collabora Online could not be loaded - Please try again later.)

Logfile snippet below.

Nextcloud 19.0.1
Collabora Online 3.7.3
Built-In CODE Server 4.2.602

Debian Buster (10)
Apache2
PHP 7.3.19

Logfile snippet:
{"reqId":"KyHZAKkCt8ZRc5aWLZcj","level":3,"time":"2020-08-15T17:03:31+00:00","remoteAddr":"MYIUP","user":"MYUSER","app":"richdocuments","method":"GET","url":"/index.php/apps/richdocuments/index?fileId=32717&requesttoken=2ZD%2FrgScY34B%2BnbvE5fPRR4a5FZ3ioH4b9ESzQj8Nt4%3D%3Ak8i4%2F3PMM09zzAG7Q%2FW%2FPFVR1AxC7OOxHb57qWSkc4s%3D","message":{"Exception":"Exception","Message":"Could not find urlsrc in WOPI","Code":0,"Trace":[{"file":"/var/www/html/nextcloud/apps/richdocuments/lib/TokenManager.php","line":210,"function":"getUrlSrc","class":"OCA\\Richdocuments\\WOPI\\Parser","type":"->","args":["application/vnd.oasis.opendocument.spreadsheet"]},{"file":"/var/www/html/nextcloud/apps/richdocuments/lib/Controller/DocumentController.php","line":245,"function":"getToken","class":"OCA\\Richdocuments\\TokenManager","type":"->","args":["*** sensitive parameters replaced ***"]},{"file":"/var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php","line":170,"function":"index","class":"OCA\\Richdocuments\\Controller\\DocumentController","type":"->","args":["*** sensitive parameter replaced ***",null]},{"file":"/var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php","line":100,"function":"executeController","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[{"__class__":"OCA\\Richdocuments\\Controller\\DocumentController"},"index"]},{"file":"/var/www/html/nextcloud/lib/private/AppFramework/App.php","line":137,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[{"__class__":"OCA\\Richdocuments\\Controller\\DocumentController"},"index"]},{"file":"/var/www/html/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php","line":47,"function":"main","class":"OC\\AppFramework\\App","type":"::","args":["OCA\\Richdocuments\\Controller\\DocumentController","index",{"__class__":"OC\\AppFramework\\DependencyInjection\\DIContainer"},{"_route":"richdocuments.document.index"}]},{"function":"__invoke","class":"OC\\AppFramework\\Routing\\RouteActionHandler","type":"->","args":[{"_route":"richdocuments.document.index"}]},{"file":"/var/www/html/nextcloud/lib/private/Route/Router.php","line":297,"function":"call_user_func","args":[{"__class__":"OC\\AppFramework\\Routing\\RouteActionHandler"},{"_route":"richdocuments.document.index"}]},{"file":"/var/www/html/nextcloud/lib/base.php","line":1007,"function":"match","class":"OC\\Route\\Router","type":"->","args":["/apps/richdocuments/index"]},{"file":"/var/www/html/nextcloud/index.php","line":37,"function":"handleRequest","class":"OC","type":"::","args":[]}],"File":"/var/www/html/nextcloud/apps/richdocuments/lib/WOPI/Parser.php","Line":54,"CustomMessage":"--"},"userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0","version":"19.0.1.1"}

I should note it used to work before a system update and reboot. Presumably a PHP update (all minor updates, though) causes problems. Complete list of recently updated files follows:

Upgrade: libpython3.7-minimal:amd64 (3.7.3-2+deb10u1, 3.7.3-2+deb10u2), php7.3-xml:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), perl-base:amd64 (5.28.1-6, 5.28.1-6+deb10u1), mutt:amd64 (1.10.1-2.1, 1.10.1-2.1+deb10u3), php7.3-zip:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), libdbus-1-3:amd64 (1.12.16-1, 1.12.20-0+deb10u1), php7.3-mbstring:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), php7.3-readline:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), ruby2.5:amd64 (2.5.5-3+deb10u1, 2.5.5-3+deb10u2), grub-common:amd64 (2.02+dfsg1-20, 2.02+dfsg1-20+deb10u2), dbus:amd64 (1.12.16-1, 1.12.20-0+deb10u1), mariadb-common:amd64 (1:10.3.22-0+deb10u1, 1:10.3.23-0+deb10u1), libmagickwand-6.q16-6:amd64 (8:6.9.10.23+dfsg-2.1, 8:6.9.10.23+dfsg-2.1+deb10u1), php7.3:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), php7.3-json:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), perl-modules-5.28:amd64 (5.28.1-6, 5.28.1-6+deb10u1), php7.3-mysql:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), mariadb-server-core-10.3:amd64 (1:10.3.22-0+deb10u1, 1:10.3.23-0+deb10u1), python3.7:amd64 (3.7.3-2+deb10u1, 3.7.3-2+deb10u2), php7.3-gd:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), grub2-common:amd64 (2.02+dfsg1-20, 2.02+dfsg1-20+deb10u2), php7.3-curl:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), grub-pc:amd64 (2.02+dfsg1-20, 2.02+dfsg1-20+deb10u2), libpython3.7-stdlib:amd64 (3.7.3-2+deb10u1, 3.7.3-2+deb10u2), python3.7-minimal:amd64 (3.7.3-2+deb10u1, 3.7.3-2+deb10u2), webmin:amd64 (1.941, 1.954), mariadb-server-10.3:amd64 (1:10.3.22-0+deb10u1, 1:10.3.23-0+deb10u1), php7.3-common:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), php7.3-intl:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), libperl5.28:amd64 (5.28.1-6, 5.28.1-6+deb10u1), grub-pc-bin:amd64 (2.02+dfsg1-20, 2.02+dfsg1-20+deb10u2), php7.3-opcache:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), mailutils-common:amd64 (1:3.5-3, 1:3.5-4), nmap:amd64 (7.70+dfsg1-6, 7.70+dfsg1-6+deb10u1), libruby2.5:amd64 (2.5.5-3+deb10u1, 2.5.5-3+deb10u2), php7.3-cli:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), libntlm0:amd64 (1.5-1, 1.5-1+deb10u1), mailutils:amd64 (1:3.5-3, 1:3.5-4), php7.3-fpm:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), mariadb-client-10.3:amd64 (1:10.3.22-0+deb10u1, 1:10.3.23-0+deb10u1), libmagickcore-6.q16-6:amd64 (8:6.9.10.23+dfsg-2.1, 8:6.9.10.23+dfsg-2.1+deb10u1), mariadb-client-core-10.3:amd64 (1:10.3.22-0+deb10u1, 1:10.3.23-0+deb10u1), libmailutils5:amd64 (1:3.5-3, 1:3.5-4), libmariadb3:amd64 (1:10.3.22-0+deb10u1, 1:10.3.23-0+deb10u1), libgnutls30:amd64 (3.6.7-4+deb10u4, 3.6.7-4+deb10u5), perl:amd64 (5.28.1-6, 5.28.1-6+deb10u1), libjson-c3:amd64 (0.12.1+ds-2, 0.12.1+ds-2+deb10u1), libgnutls-dane0:amd64 (3.6.7-4+deb10u4, 3.6.7-4+deb10u5), nmap-common:amd64 (7.70+dfsg1-6, 7.70+dfsg1-6+deb10u1), libapache2-mod-php7.3:amd64 (7.3.14-1~deb10u1, 7.3.19-1~deb10u1), base-files:amd64 (10.3+deb10u4, 10.3+deb10u5), imagemagick-6-common:amd64 (8:6.9.10.23+dfsg-2.1, 8:6.9.10.23+dfsg-2.1+deb10u1

Hello,
The built in code server for collabora is nightly. So maybe you should just wait an upgrade of the collabora server. You can try to remove collabora app and server app and then install again…

I have already removed and reinstalled both - they are still the same version numbers, though.

It appears to be working again. Here’s what I have done:

  1. Logged into NC as administrator
  2. Navigated to “Settings”-“Administration”-“Collabora Online Development Edition”
  3. On this page I found an “X” warning (“Server not available”); “use built-in CODE” was selelcted. I selected “use your own server” and confirmed the path that was already there, in thise case “https://MYDOMAIN/apps/richdocumentscode/proxy.php?req=”, then clickes “save”
  4. The selector remained on “use built-in CODE”, but the red “X” warning changed to green - “Collabora Online server is reachable.”

It appears to be working again now, with no further actions from my side.

Hi Fjalar…good work around. But unfortunately it did not work for me…
Any further help is much appreciated.
THX

Had the same problem again after NO system update, it simply stopped working. This time the workaround didn’t work around. System remains unuseable.

{“reqId”:“l03NUsF9whHMHsyve0TF”,“level”:3,“time”:“2020-08-22T17:47:04+00:00”,“remoteAddr”:“IP_REDACTED_FOR_PRIVACY”,“user”:“REDACTED_FOR_PRIVACY”,“app”:“richdocuments”,“method”:“GET”,“url”:"/index.php/apps/richdocuments/index?fileId=33786&requesttoken=%2Fn1ymbiAQ8ePT9NN%2BT05EdRM6oY9kjzIUhSpZy8oeq8%3D%3Aiww31fHyGqzlNpEFixYMYuN4vtVtom38OkzRMUcZIMo%3D",“message”:{“Exception”:“GuzzleHttp\Exception\ConnectException”,“Message”:“cURL error 28: Operation timed out after 45000 milliseconds with 0 bytes received (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)”,“Code”:0,“Trace”:[{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php",“line”:155,“function”:“createRejection”,“class”:“GuzzleHttp\Handler\CurlFactory”,“type”:"::",“args”:[{“sink”:{“class”:“GuzzleHttp\Psr7\Stream”},“headers”:[],“response”:null,“request”:{“class”:“GuzzleHttp\Psr7\Request”},“options”:{“verify”:"/var/www/html/nextcloud/data/files_external/rootcerts.crt",“timeout”:45,“nextcloud”:{“allow_local_address”:true},“synchronous”:true,“handler”:{“class”:“GuzzleHttp\HandlerStack”},“allow_redirects”:{“max”:5,“protocols”:[“http”,“https”],“strict”:false,“referer”:false,“track_redirects”:false},“http_errors”:true,“decode_content”:true,“cookies”:false,“idn_conversion”:true},“errno”:28,“onHeadersException”:null,“class”:“GuzzleHttp\Handler\EasyHandle”},{“errno”:28,“error”:“Operation timed out after 45000 milliseconds with 0 bytes received”,“appconnect_time”:0.024405,“url”:“https://next.REDACTED_FOR_PRIVACY.de/apps/richdocumentscode/proxy.php?req=/hosting/discovery”,“content_type”:null,“http_code”:0,“header_size”:0,“request_size”:133,“filetime”:-1,“ssl_verify_result”:0,“redirect_count”:0,“total_time”:45.000598,“namelookup_time”:0.001454,“connect_time”:0.001696,“pretransfer_time”:0.025422,“size_upload”:0,“size_download”:0,“speed_download”:0,“speed_upload”:0,“download_content_length”:-1,“upload_content_length”:-1,“starttransfer_time”:0,“redirect_time”:0,“redirect_url”:"",“primary_ip”:“REDACTED_FOR_PRIVACY”,“certinfo”:[],“primary_port”:443,“local_ip”:“REDACTED_FOR_PRIVACY”,“local_port”:38928,“http_version”:0,“protocol”:2,“ssl_verifyresult”:0,“scheme”:“HTTPS”,“appconnect_time_us”:24405,“connect_time_us”:1696,“namelookup_time_us”:1454,“pretransfer_time_us”:25422,“redirect_time_us”:0,“starttransfer_time_us”:0,“total_time_us”:45000598,“curl_version”:“7.64.0”}]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php",“line”:105,“function”:“finishError”,“class”:“GuzzleHttp\Handler\CurlFactory”,“type”:"::",“args”:[{“class”:“GuzzleHttp\Handler\CurlHandler”},{“sink”:{“class”:“GuzzleHttp\Psr7\Stream”},“headers”:[],“response”:null,“request”:{“class”:“GuzzleHttp\Psr7\Request”},“options”:{“verify”:"/var/www/html/nextcloud/data/files_external/rootcerts.crt",“timeout”:45,“nextcloud”:{“allow_local_address”:true},“synchronous”:true,“handler”:{“class”:“GuzzleHttp\HandlerStack”},“allow_redirects”:{“max”:5,“protocols”:[“http”,“https”],“strict”:false,“referer”:false,“track_redirects”:false},“http_errors”:true,“decode_content”:true,“cookies”:false,“idn_conversion”:true},“errno”:28,“onHeadersException”:null,“class”:“GuzzleHttp\Handler\EasyHandle”},{“class”:“GuzzleHttp\Handler\CurlFactory”}]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlHandler.php",“line”:43,“function”:“finish”,“class”:“GuzzleHttp\Handler\CurlFactory”,“type”:"::",“args”:[{“class”:“GuzzleHttp\Handler\CurlHandler”},{“sink”:{“class”:“GuzzleHttp\Psr7\Stream”},“headers”:[],“response”:null,“request”:{“class”:“GuzzleHttp\Psr7\Request”},“options”:{“verify”:"/var/www/html/nextcloud/data/files_external/rootcerts.crt",“timeout”:45,“nextcloud”:{“allow_local_address”:true},“synchronous”:true,“handler”:{“class”:“GuzzleHttp\HandlerStack”},“allow_redirects”:{“max”:5,“protocols”:[“http”,“https”],“strict”:false,“referer”:false,“track_redirects”:false},“http_errors”:true,“decode_content”:true,“cookies”:false,“idn_conversion”:true},“errno”:28,“onHeadersException”:null,“class”:“GuzzleHttp\Handler\EasyHandle”},{“class”:“GuzzleHttp\Handler\CurlFactory”}]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/Proxy.php",“line”:28,“function”:"__invoke",“class”:“GuzzleHttp\Handler\CurlHandler”,“type”:"->",“args”:["*** sensitive parameter replaced "," sensitive parameter replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/Proxy.php",“line”:51,“function”:“GuzzleHttp\Handler\{closure}”,“class”:“GuzzleHttp\Handler\Proxy”,“type”:"::",“args”:[" sensitive parameters replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/PrepareBodyMiddleware.php",“line”:37,“function”:“GuzzleHttp\Handler\{closure}”,“class”:“GuzzleHttp\Handler\Proxy”,“type”:"::",“args”:[" sensitive parameters replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php",“line”:29,“function”:"__invoke",“class”:“GuzzleHttp\PrepareBodyMiddleware”,“type”:"->",“args”:[" sensitive parameter replaced "," sensitive parameter replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/RedirectMiddleware.php",“line”:70,“function”:“GuzzleHttp\{closure}”,“class”:“GuzzleHttp\Middleware”,“type”:"::",“args”:[" sensitive parameters replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php",“line”:59,“function”:"__invoke",“class”:“GuzzleHttp\RedirectMiddleware”,“type”:"->",“args”:[" sensitive parameter replaced "," sensitive parameter replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/HandlerStack.php",“line”:71,“function”:“GuzzleHttp\{closure}”,“class”:“GuzzleHttp\Middleware”,“type”:"::",“args”:[" sensitive parameters replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php",“line”:361,“function”:"__invoke",“class”:“GuzzleHttp\HandlerStack”,“type”:"->",“args”:[" sensitive parameter replaced "," sensitive parameter replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php",“line”:163,“function”:“transfer”,“class”:“GuzzleHttp\Client”,“type”:"->",“args”:[" sensitive parameter replaced "," sensitive parameter replaced "]},{“file”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php",“line”:183,“function”:“requestAsync”,“class”:“GuzzleHttp\Client”,“type”:"->",“args”:[“get”,{“class”:“GuzzleHttp\Psr7\Uri”},{“verify”:"/var/www/html/nextcloud/data/files_external/rootcerts.crt",“timeout”:45,“nextcloud”:{“allow_local_address”:true},“synchronous”:true,“handler”:{“class”:“GuzzleHttp\HandlerStack”},“allow_redirects”:{“max”:5,“protocols”:[“http”,“https”],“strict”:false,“referer”:false,“track_redirects”:false},“http_errors”:true,“decode_content”:true,“cookies”:false,“idn_conversion”:true,"_conditional":{“User-Agent”:“GuzzleHttp/6.5.1 curl/7.64.0 PHP/7.3.19-1~deb10u1”}}]},{“file”:"/var/www/html/nextcloud/lib/private/Http/Client/Client.php",“line”:228,“function”:“request”,“class”:“GuzzleHttp\Client”,“type”:"->",“args”:[“get”,“https://next.REDACTED_FOR_PRIVACY.de/apps/richdocumentscode/proxy.php?req=/hosting/discovery”,{“verify”:"/var/www/html/nextcloud/data/files_external/rootcerts.crt",“timeout”:45,“nextcloud”:{“allow_local_address”:true},“headers”:{“User-Agent”:“Nextcloud Server Crawler”},“synchronous”:true}]},{“file”:"/var/www/html/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php",“line”:106,“function”:“get”,“class”:“OC\Http\Client\Client”,“type”:"->",“args”:[“https://next.REDACTED_FOR_PRIVACY.de/apps/richdocumentscode/proxy.php?req=/hosting/discovery”,{“timeout”:45,“nextcloud”:{“allow_local_address”:true}}]},{“file”:"/var/www/html/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php",“line”:78,“function”:“fetchFromRemote”,“class”:“OCA\Richdocuments\WOPI\DiscoveryManager”,“type”:"->",“args”:[]},{“file”:"/var/www/html/nextcloud/apps/richdocuments/lib/WOPI/Parser.php",“line”:41,“function”:“get”,“class”:“OCA\Richdocuments\WOPI\DiscoveryManager”,“type”:"->",“args”:[]},{“file”:"/var/www/html/nextcloud/apps/richdocuments/lib/TokenManager.php",“line”:210,“function”:“getUrlSrc”,“class”:“OCA\Richdocuments\WOPI\Parser”,“type”:"->",“args”:[“application/vnd.oasis.opendocument.spreadsheet”]},{“file”:"/var/www/html/nextcloud/apps/richdocuments/lib/Controller/DocumentController.php",“line”:245,“function”:“getToken”,“class”:“OCA\Richdocuments\TokenManager”,“type”:"->",“args”:[" sensitive parameters replaced "]},{“file”:"/var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php",“line”:170,“function”:“index”,“class”:“OCA\Richdocuments\Controller\DocumentController”,“type”:"->",“args”:[" sensitive parameter replaced ***",null]},{“file”:"/var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php",“line”:100,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Richdocuments\Controller\DocumentController”},“index”]},{“file”:"/var/www/html/nextcloud/lib/private/AppFramework/App.php",“line”:137,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Richdocuments\Controller\DocumentController”},“index”]},{“file”:"/var/www/html/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php",“line”:47,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:"::",“args”:[“OCA\Richdocuments\Controller\DocumentController”,“index”,{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{"_route":“richdocuments.document.index”}]},{“function”:"__invoke",“class”:“OC\AppFramework\Routing\RouteActionHandler”,“type”:"->",“args”:[{"_route":“richdocuments.document.index”}]},{“file”:"/var/www/html/nextcloud/lib/private/Route/Router.php",“line”:297,“function”:“call_user_func”,“args”:[{“class”:“OC\AppFramework\Routing\RouteActionHandler”},{"_route":“richdocuments.document.index”}]},{“file”:"/var/www/html/nextcloud/lib/base.php",“line”:1007,“function”:“match”,“class”:“OC\Route\Router”,“type”:"->",“args”:["/apps/richdocuments/index"]},{“file”:"/var/www/html/nextcloud/index.php",“line”:37,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php",“Line”:200,“CustomMessage”:"–"},“userAgent”:“Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0”,“version”:“19.0.1.1”}

Update: I re-tried the workaround again:

  1. Issued “apache2ctl graceful”
  2. Logged in as administrator, selected “use own server” with the provided path (see above)

On this, the selector jumped back to “use built-in CODE”, and the service was reachable again.