App Store not working anymore

Hey guys,

I had a great instance of nextcloud running like a charm until I deleted it by accident. Well, a build script deleted the nc-files, which needed a config-parameter I forgot.

So I reuploaded everything and reinstalled nc with the newest upate (11.0.1), which was already in use before. That’s why I thought the database should be fine after all. And yes everything is working again except of the app store. It is just showing the “Activated” and “Deactivated” categories.

I tried to find solutions here, but nothing worked for me. For example this:

I tried to repair, “to clean up the database” with: php occ maintenance:repair (don’t need sudo on my hoster)
Found here:
Didn’t work as well…

Any ideas what I could do/check?


ps: keep on rocking! it’s a great piece of software! using it since oc 9.0 (so, not too long…)

Hmm, the issue in your first link should be fixed, It just occurred due to some problems short time after the first nc 11 beta upgrade.

Be sure that all app store related settings inside your config.php are removed, so standard settings are used. But as you already used nc 11 that should not be the problem.

Please provide all nextcloud, webserver and browser log you can find, related to the failure.

I found this line conspicuous:
fopen(/var/www/virtual/ user /html/cloudData/appdata_oc8i5nd6yyyh/appstore/apps.json): failed to open stream: No such file or directory at /var/www/virtual/baasto/html/nextcloud/lib/private/Files/Storage/Local.php#216

When I checked the file(Local.php), it did exist. Might it be a rights-problem?

I can’t upload a log file here, because I’m a new user… Don’t know when this might change… or what other way do you suggest?

missing file is actually /var/www/virtual/ user /html/cloudData/appdata_oc8i5nd6yyyh/appstore/apps.json which looks like the local cache. So probably somewhere in your database its stored that you already have a local copy which should last X hours while its gone. Investigate into that area :wink:

1 Like

finally everything seems to work again!

@BernhardPosselt: thanks I must have been blind yesterday… was way too late…
I found the entry “apps.json” in the oc_filecache table and removed it as well as two other entries with the values “appstore” and “categories” in their path.

One more info for the app-devs of the app “Video calls” (, when I tried to reactivate it, an exception came up saying: that the tables (oc_spreedme_messages, oc_spreedme_rooms, oc_spreedme_room_participants) the app is using, already exists.
Well normally they shouldn’t already exist, but I think if they would check in this case if the table exists they can jump to the next config-step. Because if they don’t need to be rebuild, no valuable data in theses three tables is getting lost. I had nothing special in there, but might be different for bigger instances…

@nickvergessen @ivan

Probably better to start a new thread since this goes off topic and makes it hard for people to find

Hi all, I’m having a similar issue so I’m not opening a new thread. I’ve tried removing from the database (postgres) from oc_filecache the apps.json, appstore and categories.json references but I still see this

{“reqId”:“ZED9A5MSJtZ3SBKNKHEj”,“level”:3,“time”:“2017-09-21T23:31:49+00:00”,“remoteAddr”:“”,“user”:“admin”,“app”:“PHP”,“method”:“GET”,“url”:"/index.php/settings/apps/categories",“message”:“file_get_contents(/opt/nextcloud/data/appdata_oce6snk0zpug/appstore/categories.json): failed to open stream: No such file or directory at /mnt/wdblue/www/sites/nextcloud/lib/private/Files/Storage/Local.php#209”,“userAgent”:“Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0”,“version”:“”}

{“reqId”:“lJLxoR0zsrWNBkiq1NDt”,“level”:3,“time”:“2017-09-21T23:31:49+00:00”,“remoteAddr”:“”,“user”:“admin”,“app”:“PHP”,“method”:“GET”,“url”:"/index.php/settings/apps/list?category=installed",“message”:“file_get_contents(/opt/nextcloud/data/appdata_oce6snk0zpug/appstore/apps.json): failed to open stream: No such file or directory at /mnt/wdblue/www/sites/nextcloud/lib/private/Files/Storage/Local.php#209”,“userAgent”:“Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0”,“version”:“”}

Files are there and permissions are fine, Selinux is not enabled.

Hope you got some hints,
Thanks in advance

How to do the remove of the “apps.json” from the oc_filecache table using the terminal?

I connected via the adminer web access of my hosting-provider and removed the entries with a simple sql-statement.

I don’t know if there exist a possibility to change/remove database values with the terminal.

OK thanks. I have to do it in the terminal since I have raspian light

If anyone knows how to do it in the terminal please let me know.