Zimbra Drive on NextCloud 18

Nextcloud version (eg, 18.0.3):
Operating system and version Debian 9:
Apache or nginx version 2.4.25:
PHP version tested with 7.3 and 7.4:

Hello,
The issue you are facing is with with Zimbra Drive plugin after upgraded from NextCloud 17 to NextCloud 18.
Now I am receiving Internal Server Error 500.

Can’t find any info in the log file … it stays empty .

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  
  'trusted_domains' => 
  array (
    0 => 'cloud.intersoftpro.com',
    1 => 'office.intersoftpro.com',
  ),
  'datadirectory' => '/home/cloud/public_html/data',
  'dbtype' => 'mysql',
  'version' => '18.0.3.0',
  'overwrite.cli.url' => 'https://cloud.intersoftpro.com',
  'dbname' => 'cloud',

  'dbport' => '',
  'dbtableprefix' => 'oc_',


  'installed' => true,
  'mail_from_address' => 'cloud',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'intersoftpro.com',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,

  'mail_smtpport' => '25',
  'mail_smtpsecure' => 'tls',


  'onlyoffice' => 
  array (
    'verify_peer_off' => true,
  ),
  'theme' => '',
  'loglevel' => 5,
  'maintenance' => false,
  'app_install_overwrite' => 
  array (
    0 => 'onlyoffice',
    1 => 'zimbradrive',
    2 => 'end_to_end_encryption',
    3 => 'documents',
  ),
  'user_backends' => 
  array (
    0 => 
    array (
      'class' => 'OCA\\ZimbraDrive\\Auth\\ZimbraUsersBackend',
      'arguments' => 
      array (
      ),
    ),
  ),
  'mysql.utf8mb4' => true,

);
1 Like

Are you sure that the Zimbra app supports Nexytcloud 18? Please read the following positing which can easily be found using the fantastic search function of this forum :wink:

That’s not a good news .
Sorry for the duplicated question but I didn’t find that post.
Is there a documentation for the changes needed for 3rd party app so I can try correct Zimbra Drive plugin ?
Thank you in advance
Regards

I’m only aware about the following information, which might help you getting the app working again: https://github.com/nextcloud/server/issues/17131

I’ve finally found the problem :
in file apps/zimbradrive/lib/auth/abstractzimbrausersbackend.php
There are some rows that must be comment. From row 64 to 73:

        if(class_exists('OC\Accounts\AccountManager')) //Nextcloud >= 11
        {
            $this->accountManager = new AccountManager(
                $server->getDatabaseConnection(),
                $server->getEventDispatcher(),
                $server->getJobList() //Nextcloud >= 12.0.1
            );
        }

And comment it like this :

/*
if(class_exists(‘OC\Accounts\AccountManager’)) //Nextcloud >= 11
{
$this->accountManager = new AccountManager(
$server->getDatabaseConnection(),
$server->getEventDispatcher(),
$server->getJobList() //Nextcloud >= 12.0.1
);
}
*/

That fixed my problem using NC 18.0.3 with Zimbra Drive 0.8.24 plugin

2 Likes

Super. It would be fine if you could create a pull request in the Zimbra drive repository so that other users could use your fix too.

I’ve done it! It is pending review.

3 Likes