Workspace not loading

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2):
Operating system and version (eg, Ubuntu 20.04):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1):

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

  1. Go to https://domain.org/apps/files/

The output of your Nextcloud log in Admin > Logging:

There is actually nothing logged here even with every option ticked

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'xyz',
  'passwordsalt' => 'xyz',
  'secret' => 'xyz',
  'trusted_domains' => 
  array (
    0 => 'domain.org',
  ),
  'datadirectory' => '/mnt/cloud/www/domain.org/data',
  'dbtype' => 'mysql',
  'version' => '18.0.4.2',
  'overwrite.cli.url' => 'https://domain.org',
  'overwriteprotocol' => 'https',
  'dbname' => 'databasename',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud_user',
  'dbpassword' => 'password',
  'installed' => true,
  'mysql.utf8mb4' => true,
  'maintenance' => false,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
  ),
  'theme' => '',
  'loglevel' => 2,
  'updater.secret' => 'xyz',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_sendmailmode' => 'smtp',
);

Didn’t see any matching lines in nginx error.log, the page just shows the loading icon indefinitely it seems.

Here is a console output from the browser:

**Content Security Policy: The page’s settings blocked the loading of a resource at eval (“script-src”).**
**Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”). common.js:2:319**
JQMIGRATE: Migrate is installed, version 1.4.1 main.js:566:531
Proxying an event bus of version 1.1.2 with 0.2.1 notifications.js:21:13435
Handlebars is deprecated: please ship your own, this will be removed in Nextcloud 20 main.js:1082:57
Notifications permissions granted notifications.js:21:52255
Handlebars is deprecated: please ship your own, this will be removed in Nextcloud 20 4 main.js:1082:57
OCA.Files.Sidebar initialized sidebar.js:299:364
Handlebars is deprecated: please ship your own, this will be removed in Nextcloud 20 main.js:1082:57
Proxying an event bus of version 1.1.2 with 0.2.1 files_sharing_tab.js:1303:9158
Proxying an event bus of version 1.1.2 with 0.2.1 files_sharing_tab.js:1310:10540
OCA.Sharing.ShareSearch initialized files_sharing_tab.js:1425:246
OCA.Sharing.ExternalLinkActions initialized files_sharing_tab.js:1447:246
OCA.Viewer initialized viewer.js:369:392
This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. main.js:230:11228
New search handler registered search.js:67:12
Clipboard is deprecated: please ship your own, this will be removed in Nextcloud 20 main.js:1082:57
registerDetailView is deprecated! It will be removed in nextcloud 20. merged-index.js:7522:12
registerTabView is deprecated! It will be removed in nextcloud 20. merged-index.js:7511:12
Legacy tabs are deprecated! They will be removed in nextcloud 20. sidebar.js:320:661
registerTabView is deprecated! It will be removed in nextcloud 20. merged-index.js:7511:12
Legacy tabs are deprecated! They will be removed in nextcloud 20. sidebar.js:320:661
registerTabView is deprecated! It will be removed in nextcloud 20. merged-index.js:7511:12
Legacy tabs are deprecated! They will be removed in nextcloud 20. sidebar.js:320:661
The humanFileSize library is deprecated! It will be removed in nextcloud 19. main.js:1082:57
The humanFileSize library is deprecated! It will be removed in nextcloud 19. main.js:1082:57
**TypeError: t.response.data.ocs is undefined**
**files.js:23:5890**
Source map error: Error: NetworkError when attempting to fetch resource.
Resource URL: https://domain.org/apps/files/js/dist/sidebar.js?v=3b9afa7b-1
Source Map URL: sidebar.js.map
[...] (lots of Source Map warnings afterwards)

And a screenshot:

Anybody already know this issue?

Thanks

Hello @daisho,

welcome to the user forums.

Have you tried different browsers? Disabled add-ons?

You did not filled the missing information in your first posting.

Right, sorry. Oversaw that one.

Nextcloud version : 18.0.4
Operating system and version : Ubuntu 18.04.4 LTS
Apache or nginx version : 1.14.0
PHP version : 7.3.14

I did several update steps today via console (think from version 15 > … > 18) but they all went fine.
I checked warnings in admin overview each time. Currently only X-Frame-Options" HTTP header is not set to “SAMEORIGIN” is remaining - but I don’t think that is an issue here?

There was at one step a warning that README.me file is inconsistent, so I removed that file from nextcloud\apps\files_rightclick folder and the warning was gone. I restored and CHOWN-ed it in the meantime but no change.

/Edit: Oh and I get the same behavior on FF, Chrome, Edge and old iexplore.exe …

Anyone has an idea?

Hello,

I noticed that "loading icon indefinitely " when updating from 18.01 -> 18.0.3 then 18.0.4.

This icon appears when the text app is activated.
And when active, I have this error in my console (same as you):

TypeError: t.response.data.ocs is undefined
[RichWorkspace.vue:139](webpack:///src/views/RichWorkspace.vue)

The app text was v2.0.0 in 18.0.1 and also v2.0.0 in 18.0.3 and 18.0.4

I also see lots of lines like this in the nextcloud log:

{"reqId":"EmUzwmJcN1L1iJzR0d","level":0,"time":"2020-05-04T16:31:35+02:00","remoteAddr":"xx.yyy.zzz.ddd","user":"admin","app":"no app in context","method":"GET","url":"/apps/files/","message":"Deprecated event type for OCA\\Files::loadAdditionalScripts: Symfony\\Component\\EventDispatcher\\GenericEvent","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0","version":"18.0.4.2"}

But these errors stay when I deactivate the text app, so not sure if they are related.

​Hope this help

I’m having the same issue on 18.0.4

1 Like

Same with 18.0.4 fresh installation

Robert