Workarounds for Same-Site-Cookie bug with Thunderbird

calendar

#1

Related to https://github.com/nextcloud/server/issues/10134

Workaround known to work:

(as described in Thunderbird’s release notes):

  • go to the config editor (Settings -> Advanced -> General -> Config Editor)
  • search for network.cookie.same-site.enabled
  • set it to false

For your own security you should set it back to true once this issue is resolved.\

Unconfirmed workaround by other users:

I have found a safer workaround: If you have changed it already set network.cookie.same-site.enabled to true again. Then set all third party cookies to be denied and add an exception for the domain your Nextcloud installation is running on.

Settings > Privacy > Web content > Exceptions > Enter https://your.domain.org [ /nextcloud ]


How-to/FAQ WIKI
#2

I have tried both of the workarounds listed above. I am not sure this this is related (beginner/sorry) but while my calendar is showing in Thunderbird (60.2.1), it will not allow me to choose or turn it on. Please see attached.