Why am I able to upload huge files?

I just set up Nextcloud yesterday and I’m still not quite sure which config files are actually relevant for my installation. This is what I’m using:

Nextcloud version (eg, 18.0.2): 19.0.0
Operating system and version: Raspbian 10
Apache or nginx version (eg, Apache 2.4.25): nginx 1.14.2
PHP version (eg, 7.1): 7.3

I’ve been uploading some files and one of which had a size of 1.5G. According to this documentation, that shouldn’t have been possible. I got a gateway timeout error message (the same one that was mentioned here) near the end, but the file was uploaded successfully anyway. How is this possible?

These are the settings that I am told are responsible for maximum upload sizes:

/etc/nginx/sites-enabled/default: client_max_body_size 512M
/etc/nginx/sites-enabled/default: fastcgi_request_buffering off
/etc/php/7.3/php.ini: upload_max_filesize = 2M
/etc/php/7.3/php.ini: post_max_size = 8M
/etc/nginx/conf.d is empty.


No real solution.

But test the app “Flow Upload”


Big files are uploaded in chunks for web, desktop and mobile. For 3rdparty clients you still need higher limits as they not support chunked uploads.