Unsolved "Error when assembling chunks, status code 504"


My problem ist precisly described in this thread:
and I have already written there, but since this is already marked as solved, I gave it another thought and decided that it is better to open a new one.

Uploading one large file results in the error message “Error when assembling chunks, status code 504”, but the file is available on the system afterwards.

I’m using Plesk, that’s why nginx is used on top of apache and
in the other thread raising timeout was the solution, that’s why I tried this:
First I set in php.ini

max_execution_time = 21600

Then in /etc/apache2/apache2.conf I set

Timeout 21600

Last thing I tried was adding

fastcgi_read_timeout 1d;
proxy_read_timeout 1d;

in the http section of /etc/nginx/nginx.conf

Nothing worked.
Can somebody tell what else I can try?

Nextcloud version: 16.0.3
Operating system and version : Ubuntu 16.04
Apache or nginx version: Apache/2.4.18 and nginx/1.14.2
PHP version: 7.3.7

Is this the first time you’ve seen this error?: Yes

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'id',
  'passwordsalt' => 'secret',
  'secret' => 'victoria',
  'trusted_domains' =>
  array (
    0 => 'nextcloud.my.domain',
  'datadirectory' => '/opt/nextcloud/data',
  'overwrite.cli.url' => 'https://nextcloud.my.domain',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'db',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'admin',
  'dbpassword' => 'admin',
  'installed' => true,
  'maintenance' => false,
  'mail_smtpmode' => 'sendmail',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'my',
  'mail_domain' => 'adress',
  'mail_smtpsecure' => 'tls',
  'mail_smtphost' => 'smtp',
  'mail_smtpport' => '587',
  'theme' => '',
  'loglevel' => 2,
  'mail_smtpauth' => 1,
  'app_install_overwrite' =>
  array (
    0 => 'calendar',
  'filelocking.ttl' => 21600,
  'updater.secret' => 'secret',

Nobody any ideas?

Did you find a solution? i am getting the same error

У меня такая же проблема. Не могу никак понять как исправить.
Есть идеи? у меня nginx 1.16.1+ php-fpm

I’m having the same issue. Already modified max execution time in php.ini for apache and it still happens all the time.


Any help please, the same problem


Same issue. Increased the PHP-fpm max_execution_time (to 3600) and post_max_size (to: 20G). Hack I even changed request_terminate_timeout from “off” (=0) to 3600 (seconds is default).

In Nextcloud’s Nginx configuration I increased the client_max_body_size (to: 20G). I added the line fastcgi_read_timeout 600; below the fastcgi_request_buffering off; line as well.

Come on… Don’t blame me. In fact, if I leave the page open. And just wait for a while the file will be present and I used md5sum to check if its valid (and it is).

Meaning, the upload went OK and the assembling as well, but for some reason this message just pop-ups way to soon.

Ps. I was uploading a 7.5GB file.