Where are the language settings for Collabora?

Hello, I have finally got Collabora working and it is great for editing documents already created. If I create a new document however, the default language is German. I do not know this until I edit the document in LibreOffice. Is there a configuration file anywhere where I can set the defaults for: language, margins, fonts, text size etc?

Thanks

The empty document templates are coming from Nextcloud core. (core/templates/filetemplates/) They happen to be German documents. You can replace these.

Better template management is planned for future Collabora Online versions.

Thanks timar, I was able to replace the template.odt file with a UK version.

i’ve also been trying to find plain english (either UK or US) templates to replace template.ods and template.odt.

could you give me some pointers on where to find them?

You can save an empty document from desktop LibreOffice.

1 Like

i did this but it doesn’t appear to be working as I expected.

i fired up desktop LibreOffice, set the default currency in Language to be AUD, launched LibreOffice Calc and confirmed it was still the same and saved a blank document called template.ods and placed this onto my nextcloud server in core/templates/filetemplates

i create a new spreadsheet, put some numbers in, highlight the column and click on the “$” button. the numbers appear with a pound sign.

i’ve unpacked the template to inspect inside. I can see the language set to GB which sounds correct, but I can’t see any reference to the currency setting.

i’m trying to get this running for Australian use, so we would use the UK dictionary with AUS currency.

in the desktop version of Calc, the currency and date format is working as expected. i know my template change must be partially working, since i now have “Sheet 1” at the bottom. With Nextcloud “out of the box” it was showing “Tabelle 1” at the bottom.

do you have any advice on what I might be doing wrong?

This fix used to work in older versions of Collabora, but seems to have stopped working. Does anyone know if there is an alternate location where the template files are being sourced from?

Hello @zeigerpuppy
For the past month or so, the Collabora app allows you to specify a folder where you want to store your templates (in settings). You can either set a global variable or the user can set their own.

Regards Dom

Thanks @dom134, I think that’s the feature I need. However, I am using the latest Collabora App (v3.2.4) and Nextcloud (v15.0.5) and the Collabora settings do not appear for admin users or normal users.

Is there a way to enable the template folder setting, or have I found a bug?
The collabora instance I am using is running from the latest version of the Docker container: collabora/code

I have a similar issue, using Collabora v.3.2.4 and nextcloud 15.0.4, running collabora from the latest collabora/code docker container.

Updating the templates in core/templates/filetemplates makes no difference, the default language is still German.

Collabora online settings page remains the same as the old one, there is no option to select the template directory.

Should I file a bugreport? What’s the appropriate place to do so?

@zeigerpuppy @therainingmonkey do you have any news regarding this issue?

1 Like

I definitely would love to know if there are any updates to this issue.

Opened a new topic on this issue.

Hi,

You will need to add this to your Apache config file if memory serves me correctly (it’s been a while since I did this) , this was used with the docker image):

Capabilities

ProxyPass /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0

ProxyPassReverse /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities

It works in conjunction I believe with the capabilities.json file which should be found at:

/data/appdata_*/richdocuments/richdocuments/

I hope that helps.

Make sure you test fully in a staging environment before applying to production to ensure it works as required and has no undesired consequences.

Cheers