Where are the language settings for Collabora?

i’ve also been trying to find plain english (either UK or US) templates to replace template.ods and template.odt.

could you give me some pointers on where to find them?

You can save an empty document from desktop LibreOffice.

1 Like

i did this but it doesn’t appear to be working as I expected.

i fired up desktop LibreOffice, set the default currency in Language to be AUD, launched LibreOffice Calc and confirmed it was still the same and saved a blank document called template.ods and placed this onto my nextcloud server in core/templates/filetemplates

i create a new spreadsheet, put some numbers in, highlight the column and click on the “$” button. the numbers appear with a pound sign.

i’ve unpacked the template to inspect inside. I can see the language set to GB which sounds correct, but I can’t see any reference to the currency setting.

i’m trying to get this running for Australian use, so we would use the UK dictionary with AUS currency.

in the desktop version of Calc, the currency and date format is working as expected. i know my template change must be partially working, since i now have “Sheet 1” at the bottom. With Nextcloud “out of the box” it was showing “Tabelle 1” at the bottom.

do you have any advice on what I might be doing wrong?

This fix used to work in older versions of Collabora, but seems to have stopped working. Does anyone know if there is an alternate location where the template files are being sourced from?

Hello @zeigerpuppy
For the past month or so, the Collabora app allows you to specify a folder where you want to store your templates (in settings). You can either set a global variable or the user can set their own.

Regards Dom

Thanks @dom134, I think that’s the feature I need. However, I am using the latest Collabora App (v3.2.4) and Nextcloud (v15.0.5) and the Collabora settings do not appear for admin users or normal users.

Is there a way to enable the template folder setting, or have I found a bug?
The collabora instance I am using is running from the latest version of the Docker container: collabora/code

I have a similar issue, using Collabora v.3.2.4 and nextcloud 15.0.4, running collabora from the latest collabora/code docker container.

Updating the templates in core/templates/filetemplates makes no difference, the default language is still German.

Collabora online settings page remains the same as the old one, there is no option to select the template directory.

Should I file a bugreport? What’s the appropriate place to do so?

@zeigerpuppy @therainingmonkey do you have any news regarding this issue?

1 Like

I definitely would love to know if there are any updates to this issue.

Opened a new topic on this issue.

1 Like


You will need to add this to your Apache config file if memory serves me correctly (it’s been a while since I did this) , this was used with the docker image):


ProxyPass /hosting/capabilities retry=0

ProxyPassReverse /hosting/capabilities

It works in conjunction I believe with the capabilities.json file which should be found at:


I hope that helps.

Make sure you test fully in a staging environment before applying to production to ensure it works as required and has no undesired consequences.


In new version of Collabora 4.2.0 and Nextcloud 17.0.2 i can not change the default template.
I Change templates in
But not working. Other solution?

Apologies, just seen your message as I’ve not been working on this recently.

When I do, which won’t be for a while, I’ll share my findings, though I’m not sure when that is .

Hi @dman, these lines are already in the apache2 conf file for collabora.

I found capabilities.json in /data/appdata_*/richdocuments/richdocuments/ containing:
{"convert-to":{"available":false},"hasMobileSupport":true,"hasTemplateSaveAs":false,"hasTemplateSource":true,"productName":"Collabora Online Development Edition"}

But still no way to set French (or whatever) as default language for odt, ods and odp new files…

I’m facing a language issue with the latest version of Collabora and I’m looking for any workarounds. Collabora.app ver.3.5.3 also doesn’t seem to refer to template.odt, ods, odp.
I’m installing Collabora as a package on my server instead of Docker. Where can I make adjustments in nginx?

Nextcloud 18.0.3, nginx 1.16.1, Collabora app 3.5.3, loolwsd 4.2.2, Collabora 6.2-10

I think I found some way to change the default settings, whatever they are, I mean document language but also default character style and so on.

It looks like the templates are stored in a data/appdata_something/richdocuments/empty_templates/ as of LOo templates, that is:

  • document.ott
  • presentation.otp
  • spreadsheet.ots

So you need to locate them, download them and modify them with your settings, save them as templates (ott, otp, ots) and upload them back to the same directory caring to let them to the directory owner (www-data:www-data for instance).


I have an external collabora server running. How can I add languages to collabora? The GUI is in german (as it should be) but I have to type “=today()” instead of “=heute()” in the calculator/excel. How can I change this to german?

I’m sorry I have to post to a topic that was started in 2016 (!)

I realize that for a lot of people these “default” settings are just fine:

  • currency: $ (dollar)
  • decimal separator: . (dot)
  • thousands separator: , (comma)

But I’m Dutch… so I’dd like to be able to alter them (per document…) to:

  • currency: € (euro)
  • decimal separator: , (comma)
  • thousands separator: . (dot)

This varies per country… It can’t be thàt hard to set this up?

I’dd love to be able to do this not only in settings (where I now can only set up a template directory) but also alter this via a setting somewhere after opening the document itself.

Hi, I have the same problem. Do you found a solution?

it can be setted by (Settings > Personal info > Language). After setting to ‘Nederlands’, it will as your expectation.
Similar to How to set the default length unit used in Collabora Online

1 Like