Web interface is loading very slowly

Nextcloud version (eg, 24.0.6): replace me
Operating system and version (eg, Fedora 36): replace me
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 7.4): replace me

The issue you are facing: The nextcloud website running very slow

Is this the first time you’ve seen this error? (Y/N): Y

every page I hit, it’s loading so slow. could someone please explain why it happens and how to fix it?

13 seconds

13 seconds

all js files are cached, but only those two are not.

Note, my server is remote, and I am on metered mobile connection.

Solution: Web interface is loading very slowly - #11 by denisp

Hi,

Maybe your server Nextcloud dosen’t have a server DNS register.

Can you try this in your server :

nslookup wikipedia.com

or nslookup other domaine.

You have a reply?

If server not resolve domaine name, try add a server dns (etc/network/interface?) and try to connect whit your browser ‘yournextcloud.tdl’.


I haved a long time reply whit my browser in nextcloud beacause my server dns no response… bref… My english bad :rofl:

1 Like

Hi @denisp
You are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Thanks.

I cannot see why it could be a domain issue. I serve other website (gitea) on the same domain and it works super fast.

Are you by chance using Nextcloud Office?

Yes I am. I mean it is installed among with collabora built-in server:

core-common.js
talk-files-sidebar.js

Everything is cached except of those two files? Why are they being downloaded on every click?

Maybe also for an experiment try to temporarily disable the collabora CODE and see if it makes a difference, this app has shown to cause performance problems on other instances

1 Like

I don’t think it is a problem (tried to disable office, same issue).

In my opinion those two js files are causing the issue. You can try to reproduce the same slowness if you switch the browser into throttling mode. See screen bellow:

So on every page hit it downloads those files. For the LTE 15mb is a lot.

1 Like

I don’t have dashboard enabled, so not exactly the same.
Reloading “Files” app loads the core-common.js as well but in may case it is cached (like everything else). I don’t see any difference for 3G/4G throttling (I think because of caching).

1 Like

Solution :star: :star: :star: :star: :star:

Ok. I think I have found the root of the problem. And it is not related to the server at all. I am using LibreWolf as my browser. So because it has very strict security policy and low memory usage, it does not cache files larger than 50kb.

I went to its settings about:config and filtered variables browser.cache and found it out.
After I changed those settings, those LARGE js files started being cached, and the web site works smoothly now.

Thanks everyone for any help and support. :fist:

3 Likes