Virtual files. Initial sync very slow

Hello,

I am using Nextcloud 19.0.2 on a docker container, in a machine that I use as a NAS. Most of the relevant folders are added using the External Storage plugin.

Today, I discovered that Virtual Files is a new feature and it’s available in the client. So I downloaded the last client available (3.2.1) and installed it, selecting the Virtual Files option.

I have a lot of information, around 3TB, more than what a single computer can handle, so until now I just synchronized a few directories. But with virtual files, in theory I could see all files and only download those that I want.

So, I started the client, started syncing, starting checking for changes for every folder… and it took several hours to do the initial sync. There were some errors related to the “placeholders”. In the Nextcloud folder, I could only see a few of the folders I sync.

I decided to restart the client. And it started checking for changes, folder by folders, from the beginning. I guess I will have to wait a few hours again. I don’t know if that initial sync started again because the previous scan could not finish, or if it will happen every time. If it’s the latter, it will be unusable.

Is this normal? Is it my fault for having so many files? Does it has anything to do with using External Storage?

Thanks for your time.

Edit: I just noticed. If it open one of the few files that seem to have been synced correctly, the initial scan starts all over again from the beginning.

Hi,

I’ve noticed this too, Nextcloud also consumes significant CPU resources in the background. I decided to delete all files and completely reinstall Nextcloud on my client computer. I selected “virtual files only” with the hope that no files will actually need to be downloaded, thus speeding up the initial sync.

However, it’s been stuck on "Preparing to Sync for 3 hours now. (~250GB of files, and internet speed is not an issue)

Is there a way to speed this up?

Thanks!

Edit: Nexcloud v20.0.10 and Windows Desktop Client v3.2.2

If anyone is interested, what I did is exclude the largest folders from the sync (editing the exclusion list from the gui), and waiting the sync to finish. When it finishes, one by one start adding the large folders, until it finishes syncing each time. It’s a very time consuming process, but it’s the only way I have found.

Any news on this? I’m running client version 3.3.5 Mac OS with “experimental” virtual files enabled.
I also noticed it checks recursively the entire folders I’m in.
I see no need to do that, just check the first level and start syncing that level only… what’s the point in checking the entire tree? That’s not a “lazy” operation at all :wink:

Regards,
Marco

Any news? I have the same issue with about 550k files on Windows 10 with virtual drive.