Users' email address cannot be set

nc12

#1

Hi all,

I’m not able to set user’s email address, neither in personal account settings nor in user management by nextcloud admin.

For the nexcloud admin (database user) I already set email address and email settings. I’m using SMTP, not PHP-mail. I’ve tested nextcloud admin email by using test email button in settings page. This works fine. I get the test email. But for all regular users I cannot set. I’m using Unix Authentication (pwauth).

In personal account settings there is no input field for email. I just see text “Keine Email-Adresse angegeben” (which means: no email address set), but cannot enter something. I tried to follow this thread: PLS HELP ! Setting new users e-mail address not working.. (Email address could not be changed!), but this did not solve my problem.

In user management I can enable email column and type email address, but on pressing enter I get message “Email-Adresse konnte nicht geändert werden” (which means: cannot change email address).

Nextcloud version (eg, 12.0.2): 12.0.4
Operating system and version (eg, Ubuntu 17.04): Ubuntu 16.04 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.18
PHP version (eg, 7.1): 7.0.22

Before I was running Nextcloud version 12.0.3 and observed this issue already. So I updated to version 12.0.4 but this did not solve it.

Does someone observed same issue? Is it related to pwauth?

Regards
afi


#2

Hi afi!,

Where are you hosting your service?
There are some ISP that block any email traffic also some VPS do.
Do you use firewall?

Maybe that could be the issue.


#3

Hi Luis,

thanks for your answer.
I’m hosting locally on my private NAS providing services through LANCOM router via NAT and port forwarding. Everything works fine, nothing blocked by ISP. I also tried to access my cloud locally (using local IP address), but same issue. Problem is not some blocked email. I can send/receive email using mail client and even the test mail of my Nextcloud admin user (triggered within the nextcloud preferences page) is perfectly sent and thus received by my mailbox. I’m just not able to enter email addresses in user settings and in user management.

I also installed the nextcloud mail app and I can access my mailbox directly from nextcloud.
In nextcloud log I don’t see any new message since updating from 12.0.3 to 12.0.4.

Regards,
afi


#4

Oh! sorry I guess i didn’t quite understood the issue.

Could you share your config.php seems to be an issue of backend configuration.
Cheers!


#5

Hello,

just had the same problem. solved by setting

'allow_user_to_change_display_name' => true,

in config.php. see https://github.com/nextcloud/server/issues/4370 for more details

Regards,

Carsten


#6

Hello,
I’m having the exact same issue. I’ve edited the config.php and I’m still unable to set a user email.
Thanks’
Walter


#7

I have been working on the same issue today and i did not have this issue prior to latest update release, e.g. I could add emails before.

I noticed that after reading threads on this and trying the allow_user…=>true (didn’t exist but created and nope, no change) that setting phone number wasn’t saving until I literally hammered the enter keyboard several times and it eventually saved with a checkmark.

Not so lucky on email or address or twitter handle, I had my hopes up when the popup asked for my password to authenticate but alas, that was a false positive.

I’ve disabled all plugins and still get the same issue. I’m new to nextcloud and this is a great product and hopefully this can be resolved, as I want to present to a client this week this solution for their business.


#8

HI! did you fix it? I can set email on profile and user magnament as admin… any idea?


#9

Hi,

for me (as the opener of this thread) the problem still exists. After “playing” a lot and updating to 12.0.5 I did not see any solution yet. And since I have only a very limited number of users for my nextcloud, I added the email addresses manually by modifying the mysql database.
I can confirm that the 'allow_user_to_change_display_name' => true, line in config.php does not help either.
And I can also confirm that (at least for me) it seems to be caused by the linux user backend “pwauth”. When I disable the pwauth and use the nextcloud database user backend I can change all user profile data as expected.
So for operators of bigger cloud systems it might be a solution to use LDAP instead of pwauth for managing linux and nextcloud users together.
I did not update to NC13 yet, since I’m on a big travelling and dont want risk my nextcloud has issues bc updating. So I cannot test yet if NC13 solves the problem or not.

Regards,
afi