Upload very slow and stucking every 10 MB

Nextcloud version (eg, 12.0.2): 18.0.0
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.29
PHP version (eg, 7.1): 7.2

The issue you are facing:

Uploading large Files ( > 10 MB) is very slow (~6 MB/s although the Networks speed is 2Gbit/s).
Nextcloud is reached from the Internal Network.
Every 10 MB of the File the upload stucks for one to three Seconds. After that the download resumes for 10 MB at the speed of 6 MB/s.
I’ve had the issue already in Verion 17 before updating to Version 18.

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Upload a big File (>10 MB)

The output of your Nextcloud log in Admin > Logging:

Nothing specific

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


$CONFIG = array (

  'passwordsalt' => *******************************************************************',

  'secret' => '*************************************************************************',

  'trusted_domains' =>

  array (

    0 => '**********',

    1 => '**********',


  'datadirectory' => '/***/***/***',

  'dbtype' => 'mysql',

  'version' => '',

  'overwrite.cli.url' => 'http://*********',

  'dbname' => '**********',

  'dbhost' => '**********',

  'dbport' => '',

  'dbtableprefix' => 'oc_',

  'dbuser' => '**********',

  'dbpassword' => '**********',

  'installed' => true,

  'htaccess.RewriteBase' => '/',

  'instanceid' => '*********',

  'memcache.local' => '\\OC\\Memcache\\APCu',

  'maintenance' => false,

  'theme' => '',

  'loglevel' => 2,

  'updater.release.channel' => 'stable',

  'twofactor_enforced' => 'true',

  'trusted_proxies' =>

  array (

    0 => '*********',


  'data-fingerprint' => '**********',

  'mysql.utf8mb4' => true,

  'defaultlocale' => 'enUS',

  'default_language' => 'en',

  'trashbinretentionobligation' => 'auto, 1',

'appdecodechecker' => true,

  'memcache.distributed' => '\\OC\\Memcache\\Redis',

  'redis' =>

  array (

    'host' => '/var/run/redis/redis.sock',

    'port' => 0,

    'password' => ''


  'memcache.locking' => '\\OC\\Memcache\\Redis',


The output of your Apache/nginx/system log in /var/log/____:

No Errors logged
1 Like

I have exact same issue. Did you found solution till now ?

I have tried everything with php, php-fpm, tuning nextcloud config and nginx config but wihtout success.

I am running php74 tho but I found that php version does not matter.

I have now new info on this.

I can upload fast as hell when nextcloud is accesed from lan IP and no stucking.
When I establish ssl on nginx and access nextcloud from domain, download is limited by my WAN speed BUT its now stucking every 10MB, uploading 1,5GB file tho.

Where’s the snag ?

This problem took me almost 2 days…and then I found din post…11 59 ![44|549x261]
Here are screen attached from my pfsense box.
Any help please?

The client split larger files into 10 MB chunks and uploads them. If you directly access via webdav (winscp can do this as well), you shouldn’t see this effect. However the initial connection seems to take some time, that’s something in your network

Sure nice feature that chunking, but nextcloud is fork of owncloud and yesterday I have confirmed that owncloud does not suffer with this stucking even with Gig file. Is something broken in code ?

I think that is the same problem that i posted here:

I solved it… installed the owncloud client instead of the nextcloud client. I think that there is an important bug in the application and they are ignoring it or they can’t solve it.

You should report such things to the bug tracker. The developers don’t check the forum very often for hints.

solution here in my post > https://help.nextcloud.com/t/nextcloud-18-uploading-1gb-file-stucking-every-10mb-please-help-i-am-already-hopeless/70719/6?u=oriann