Upgrade to 13.0.0.1 gives error: Failed opening required '\/appinfo\/v2\/remote.php'

i updated to 13.0.0.1 from latest 12.x version. First i got
"PHP Fatal error: Declaration of OCA\FilesAccessControl\StorageWrapper::copyFromStorage(OCP\Files\Storage $sourceStorage, $sourceInternalPath, $targetInternalPath) must be compatible with OCP\Files\Storage::copyFromStorage(OCP\Files\Storage\IStorage $sourceStorage, $sourceInternalPath, $targetInternalPath) in /home/www/datentausch/apps/files_accesscontrol/lib/StorageWrapper.php on line 628"

and so i removed all /apps like told in

after that update went on and updated some apps.

but now i get
"app":“core”,“method”:“GET”,“url”:"/index.php/apps/files/",“message”:“Could not resolve checkManager! Class checkManager does not exist”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36”,“version”:“13.0.1.1”}

and
,“message”:“require_once(): Failed opening required ‘/appinfo/v2/remote.php’ (include_path=’/var/www/nextcloud/3rdparty/pear/console_getopt:/var/www/nextcloud/3rdparty/pear/pear_exception:/var/www/nextcloud/3rdparty/pear/pear-core-minimal/src:/var/www/nextcloud/3rdparty/pear/archive_tar:/var/www/nextcloud/apps’) at /var/www/nextcloud/remote.php#164”,“userAgent”:“Mozilla/5.0 (Windows) mirall/2.3.2 (build 1) (Nextcloud)”,“version”:“13.0.1.1”}

in webbrowser i get the message “ERR_TOO_MANY_REDIRECTS”

Anyone an idea what i need to do to solve this?

problem solved. disable the /apps by the occ command and did a manual upgrade over the current (not working) installation ( move files away, unzip the latest release, move config.php (and possibly data) back over).

That did the trick, when i came back in web it asked to update the apps and after that i could login again. Not sure if it was really needed to disable all the apps first, but that way it worked for me at least.

2018/10/02 21:18:11 [error] 57172#0: *682 FastCGI sent in stderr: "PHP message: PHP Fatal error: require_once(): Failed opening required '/appinfo/v2/remote.php'

also seeing similar messages after upgrading to v14. When I installed the calendar app with occ, I could use it to access the admin interface but am unable to access files or do much of anything.

WebDAV doesn’t work so /index.php/apps/files/ returns the error above. I also get a lor of font errors.

2018/10/02 21:27:27 [error] 57206#0: *781 open() "/usr/local/www/nextcloud404" failed (2: No such file or directory), client: 192.168.0.1, server: cloud.paulbeard.org, request: "GET /core/doc/admin/fonts/glyphicons-halflings-regular.svg HTTP/2.0", host: "cloud.paulbeard.org"

I have a redirect in nginx that sends users from domain.com/nextcloud to cloud.domain.com. Not sure if that’s part of the problem. No idea how to test without it.

The version I installed also had 5900 extra files I had to remove during the security check.

Any idea how I can get this working again?