Upgrade from 20.0.8 to 20.0.9 just ran through to 21.0.1 (?)

Hello to all,
I was wondering if this has happened to anyone else. 3 weeks ago I only wanted to upgrade from version 20.0.8 to 20.0.9. But the upgrade simply ran through to version 21.0.1. This was not intended. I actually wanted to stay on 20.0.9 for at least another 2 months, as everything was working fine then.

My update channel was and still is set to stable and was not switched or tampered with.

I had deactivated all active apps. I was also only offered the update to 20.0.9 in the backend.

After all tasks in the backend were done, I chose the option via the command line, logged in via ssh and started the occ upgrade.

Everything went through flawlessly with no error messages. App updates were installed, with no error messages. When I went back to the backend I had 21.0.1. (??)

In the meantime I have done several upgrades in the same way… but something like this has never happened to me before. I’m a little disappointed because I still don’t think version 21.0.1 is ideal for a production environment. There are too many bugs and there are even new ones.

Can anyone tell me what went wrong here or has this also happened to someone?

1 Like

Hi Frank,

Yes, exactly the same thing happened to me and others.

See First 21 update is out, as are minor 20 and 19 releases - #9 by antoine and earlier messages in the thread.

This happens all the time. When using the web updater, you could have noticed as the package name is shown during download, revealing the actually downloaded version. Not sure if it shows during command line, probably not.

I think it is unexpected behaviour indeed, especially since Nextcloud is releasing new major versions often with a lot of initial bugs.

@memen45 @antoine Thank you for your hints. This really shouldn’t happen. I am now struggling with major bugs in a corporate environment and have to wait for the fixes. Something like this simply should not happen. This lowers the confidence of companies in NC. I hope that NC is aware of this and provides the fixes quickly.

2 Likes

Hi @frank.scheuer, I would recommend to restore a Backup that you have hopefully created before doing the update?

This also happened to me, but only in one of two (very similar) installations - the other updated fine to 20.0.9…

I performed the upgrade using the web updater, and while it offered 20.0.9 at the “Settings” page, the actual update page listed the actual version 21.0.1 it was trying to download. I could have aborted here.

However, you need to be careful to notice this, as everywhere else Nextcloud just stated that it was going to upgrade to 20.0.9, and I also agree that this should not happen in the first place, that Nextcloud says it offers an upgrade to version X, but then instead performs an upgrade to a different version Y.

Is there already an open GitHub bug regarding this? If not, could you open one and paste the ID here? I’d like to subscribe.

Thanks for your advice!
@szaimen Yes, I could instruct our hoster to install a backup. I only have limited access. In general, most things in 21.0.1 work quite well. But we keep running into minor and major bugs. We, that is 70 people in our education centre, are affected by the Fido2 bug and now for a few days by the Circle bug. I hope that there will be solutions relatively soon. In particular, 21.0.2 should be released quickly. In this post, I just wanted to know in general whether others were also affected by the upgrade process, so that 20.0.8 simply rushes through to 21.0.1. That’s all I wanted to know here. Because the upgrade process must be 100% trustworthy. If I select 20.0.9, then I must also get 20.0.9.

2 Likes

You can make a snapshot before each update. To be safe I also try the update on an experimental server first before the production server.

1 Like

This doesn’t help: It’s well possible the experimental server would correctly upgrade to 20.0.9 as expected. I had two basically identical installations of 20.0.8, which both offered an upgrade to 20.0.9, and one of these actually ended up upgrading to 21.0.1, while the other upgraded to 20.0.9, as announced.

So, even performing test upgrades would give no guarantees… :frowning:

2 Likes

I will have a look on Github…

Ok. But first trying experimental and if OK you take a snapshot on the production would decrease the risk.
I have so far not updated my production server because of these issues which happened on the experimental.

OK, I found a matching bug report on Github.

Please use the :+1: to show that you are affected by the same issue.

1 Like

This bug seems to be fixed now.

3 Likes

I don’t dare to update 20 anymore before upgrading to MySQL 8 because the same happened to me when I tried to upgrade to 19.x and suddenly I got 20.

Yes, i just tried it and i got the 20.0.9 update. I could update my 20.0.8 installation successfully.

OK, so as mentioned in #558 the bug is fixed

1 Like

Yes, this exactly happened to me a month ago. I did’nt found any posts in
the community for this behaviour and since there was no problem with this
new version i let it be. But it is really a strange issue.

Yes, you’re right, it’s a pity when this happens again and again. You lose confidence - from version 19 to 20, however, everything went as it should for me.

Hi there.
Just to let you know that I had the same problem.
I’m still using version 19.x since for me stability is more important than new options.
A couple of months ago I tried to update one of my servers to the latest 19.x version and instead it upgraded to 20.x.
Luckily I had a backup so it wasn’t that complicated to revert but since than I stop doing upgrades afraid it would happen again.
So basically I’m not using the latest 19.x bug fixes since I’m afraid that it would happen again.

Yes, this happened to me as well. It says it is upgrading to 20.0.9 but on the next screen after you press to upgrade it actually shows the upgrade is going to 21.0.1. By then, though, it is too late. And then, in 21.0.1 the index updates with occ (from the issues area of settings) didn’t work – they just hung.