Upgrade Apps to NC12 - Start Button not working


I updatet NC to version 12 (via updater and again manual) but I’m not able to complete it. I can open the site that says “These apps will be updated:” and when I click on the “Start update” button nothing happens (tried it with 3 different Browsers).
From the logfile I only see

{"reqId":"WS-VE8CoKOkAAAgCgL8AAABQ","level":3,"time":"2017-06-01T08:49:23+00:00","remoteAddr":"XXX.XXX.XXX.XXX","user":"--","app":"PHP","method":"GET","url":"\/index.php\/js\/core\/merged-template-prepend.js?v=1a5a8f2279c9e84d57d1b6c7a59a1522-3","message":"file_get_contents(\/mnt\/htdocs\/42\/data\/appdata_oc0drzaurh86\/js\/core\/merged-template-prepend.js.gzip): failed to open stream: No such file or directory at \/mnt\/htdocs\/42\/lib\/private\/Files\/Storage\/Local.php#209","userAgent":"Mozilla\/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/58.0.3029.110 Safari\/537.36","version":""}

As I’m running NC at a hoster I can’t run the upgrade via occ command.
The only Thread in this forum about this topic (Can’t “Start Update” NC 11.0.3) didn’t got a Solution (or I didn’t get it)
Anyone got an idea?

P.S.: I checked and the whole js folder in appdata_… is missing. Is this the problem?

I found one github issue with a similar error-log: https://github.com/nextcloud/server/issues/5003

Thanks for the Suggestion, so the solution could be a Regeneration auf the instance by commenting Out the instance ID? Would I lose data beside the installed Apps?

I did this the other day on an admittedly newish deployment with no data loss. Just backup before you do anything.

worked! Thanks to @tflidd.

@JasonBayton: Did you have the same problem, that part of the appdata was lost? Maybe it could be a bug…

Nevertheless, if this happens from time to time, maybe there should be a “appdata” recovery option. Something like a regeneration

Nothing I noticed @Eviubiu. Feel free to raise it on GitHub if you’re concerned: