Upgrade 25.0.0 to 25.0.1 - LDAP Error - Maybe the LDAP entry has no set display name attribute?


after updating NC 25.0.0 (stable) to 25.0.1 (stable) All LDAP connections have stopped working.

Error: Could not get user object for DN uid=XXXXX, ou=XXXXX=DOMAIN,dc=de. Maybe the LDAP entry has not set display name attribute?

Hi everyone,

as already mentioned after updating from NC 25.0.0 to NC 25.0.1 (stable) none of our LDAP connections worked anymore. We are using 15 different LDAP Servers on our Cloud instances. I have tested the update before on our Lab instance which is NC 25.0.1 (beta) and there the error does not appear.

We also have Enterprise on a third NC instance which is NC 24.0.7 and there the error also does not appear.

We are using the same 15 LDAP Servers on all 3 instances with basically the same LDAP configuration except for the groups the users are read from.

After rolling back to NC 25.0.0 (stable) the error is gone.

Question1: How can this happen on the the stable channel but not on the beta channel?

Question 2: What could cause the problem if there have not been made any changes to any of the 15 LDAP Servers?

It is almost impossible that 15 different LDAP Servers on 15 different locations in the whole country suddenly do not have a display name attribute set to any of 10K users :wink:

Nextcloud version 25.0.1 (stable)
Operating system Ubuntu 20.04 - all updates
PHP 7.4.3

The issue you are facing:

LDAP Login impossible after update from 25.0.0 (stable) to 25.0.1 (stable)vbut no changes have been made to any LDAP Server / Connection / UserObject / Group

Is this the first time you’ve seen this error? Y

Steps to replicate it:

  1. Update from 25.0.0 (stable) to 25.0.1 (stable)
  2. Try to login via LDAP authenticated user

I have same error…look at


1 Like

downgrading JUST the user_ldap app (from 25.0.0 package) fixed the issue for now.

Greeting from Germany

1 Like


ok - i will then just wait for another update hoping that LDAP will get fixed soon.


Hello Harzakc,

can you tell me where i can find the matching package?

Thanks in advance

You can download older version of Nextcloud here: https://nextcloud.com/changelog/

ok, but where to get the ldap package?

LDAP is part of Nextcloud and included in the zip archive. Download an older Version of Nextcloud as zip or tar. Extract the archive and compare the versions of user_ldap with the one on your server (appinfo).

Make a backup of your running Nextcloud instance!

After that replace apps/user_ldap with the one from the archive.

did the replacement, but did not help sadly.

did you compare the version of user_ldap/appinfo ?

i replaced it completely and the old version seems to be in charge (activated) but now

  • Nachricht: pageMode is not a valid attribute
  • Datei: /var/www/nextcloud/lib/public/AppFramework/Db/Entity.php
  • Zeile: 136


#0 /var/www/nextcloud/lib/public/AppFramework/Db/Entity.php(165): OCP\AppFramework\Db\Entity->setter() #1 /var/www/nextcloud/lib/public/AppFramework/Db/Entity.php(73): OCP\AppFramework\Db\Entity->__call() #2 /var/www/nextcloud/lib/public/AppFramework/Db/QBMapper.php(322): OCP\AppFramework\Db\Entity::fromRow() #3 /var/www/nextcloud/lib/public/AppFramework/Db/QBMapper.php(340): OCP\AppFramework\Db\QBMapper->mapRowToEntity() #4 /var/www/nextcloud/apps/collectives/lib/Db/CollectiveMapper.php(107): OCP\AppFramework\Db\QBMapper->findEntities() #5 /var/www/nextcloud/apps/collectives/lib/Service/CollectiveHelper.php(52): OCA\Collectives\Db\CollectiveMapper->findByCircleIds() #6 /var/www/nextcloud/apps/collectives/lib/Mount/MountProvider.php(75): OCA\Collectives\Service\CollectiveHelper->getCollectivesForUser() #7 /var/www/nextcloud/apps/collectives/lib/Mount/MountProvider.php(126): OCA\Collectives\Mount\MountProvider->getFoldersForUser() #8 /var/www/nextcloud/lib/private/Files/Config/MountProviderCollection.php(124): OCA\Collectives\Mount\MountProvider->getMountsForUser() #9 /var/www/nextcloud/lib/private/Files/SetupManager.php(225): OC\Files\Config\MountProviderCollection->addMountForUser() #10 /var/www/nextcloud/lib/private/Files/SetupManager.php(317): OC\Files\SetupManager->OC\Files{closure}() #11 /var/www/nextcloud/lib/private/Files/SetupManager.php(226): OC\Files\SetupManager->setupForUserWith() #12 /var/www/nextcloud/lib/private/legacy/OC_Util.php(111): OC\Files\SetupManager->setupForUser() #13 /var/www/nextcloud/apps/files/lib/Controller/ViewController.php(152): OC_Util::setupFS() #14 /var/www/nextcloud/apps/files/lib/Controller/ViewController.php(205): OCA\Files\Controller\ViewController->getStorageInfo() #15 /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php(225): OCA\Files\Controller\ViewController->index() #16 /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php(133): OC\AppFramework\Http\Dispatcher->executeController() #17 /var/www/nextcloud/lib/private/AppFramework/App.php(172): OC\AppFramework\Http\Dispatcher->dispatch() #18 /var/www/nextcloud/lib/private/Route/Router.php(298): OC\AppFramework\App::main() #19 /var/www/nextcloud/lib/base.php(1047): OC\Route\Router->match() #20 /var/www/nextcloud/index.php(36): OC::handleRequest() #21 {main}

This error (“pageMode is not a valid attribute”) comes from the collectives app and is going to be addressed in an upcoming release of the app. Disabling the app as mentioned in this answer will remove the error:

This answer in the same thread has a link to a temporary workaround so that the app can be activated again without waiting for the release containing the fix:

Same with 26.0.1. I had to replace ldap_user app to v1.15 from 25.0.6 and edit appinfo to enable 26 version.
After upgrading I got:

“message”:“LDAP Login: Could not get user object for DN cn=\u043f\u043e\u043b\u044f\u043d\u0441\u043a\u0438\u0439 \u0432\u043b\u0430\u0434\u0438\u043c\u0438\u0440 \u043d\u0438\u043a\u043e\u043b\u0430\u0435\u0432\u0438\u0447,ou=XXX,dc=domain. Maybe the LDAP entry has no set display name attribute?”
But users can be found via ldap configuration utility.
1.15 works fine.

I can confirm that 26.0.1 has the same issue. I gonna stay with 25.0.6 until next version in hope it may get fixed.

I’m still experiencing this issue in 28.0.1.
Are we sure this is a Nextcloud issue and not just a messed up config or something? It’s been three major versions how has this not been fixed?

same issue here,
NC27, ldap was working fine, then I raised the domain functionnal level of my windowsserver AD and the issue appeard.
Tried to setup a new nextcloud from scratch, connected the user_ldap to my AD and same behaviour.
All light are green, user_ldap can find AD users but they are unable to login.
here is the error:
“LDAP Login: Could not get user object for DN cn=administrateur,cn=users,dc=domain,dc=tld. Maybe the LDAP entry has no set display name attribute?”
Back to a 2K8 server with 2K8 domain functional level, everything runs ok
Anyone has a solution ?

any update on this issue?