Upgrade 12.0.5 workflow engine extra files

Nextcloud version: 12.0.5
Operating system and version: bhyve FreeBSD 11.0 VM on FreeBSD 11.0 host
Apache or nginx version: Apache 24
PHP version: 7.1.12

The issue you are facing:

  • Running system 12.0.2 manually upgraded to 12.0.5
  • Fetched NC 12.0.5, untar’ed, copied to NC main folder
  • Comparing backed-up apps with new unpacked ones, several were missing, including workflowengine
  • Copied from back-up to NC folder, started upgraded, and it completed successfully

Getting:

  • workflowengine
    • EXTRA_FILE
      • l10n/sr.json
      • l10n/sr.js
      • l10n/ka_GE.js
      • l10n/et_EE.js
      • l10n/ka_GE.json
      • l10n/et_EE.json

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Manual upgrade at: https://ramsdenj.com/2017/06/05/nextcloud-in-a-jail-on-freebsd.html#manual-upgrade

The output of your Nextcloud log in Admin > Logging:

|Error|PHP|Narrowing occurred during type inference. Please file a bug report on bugs.php.net at /usr/local/www/apache24/data/nextcloud/lib/composer/composer/ClassLoader.php#444|2018-01-24T22:44:32-0500|
|---|---|---|---|
|Error|PHP|Narrowing occurred during type inference. Please file a bug report on bugs.php.net at /usr/local/www/apache24/data/nextcloud/lib/composer/composer/ClassLoader.php#444|2018-01-24T22:44:32-0500|
|Error|PHP|Narrowing occurred during type inference. Please file a bug report on bugs.php.net at /usr/local/www/apache24/data/nextcloud/lib/composer/composer/ClassLoader.php#444|2018-01-24T22:14:35-0500|
|Error|PHP|Narrowing occurred during type inference. Please file a bug report on bugs.php.net at /usr/local/www/apache24/data/nextcloud/lib/composer/composer/ClassLoader.php#444|2018-01-24T22:14:35-0500|
 

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '**removed**',
  'passwordsalt' => '**removed**',
  'secret' => '**removed**',
  'trusted_domains' =>
  array (
    0 => 'nextcloud',
    1 => 'drive.whatever.com',
  ),
  'datadirectory' => '/mnt/ncdata',
  'overwrite.cli.url' => 'http://nextcloud/nextcloud',
  'dbtype' => 'mysql',
  'version' => '12.0.5.3',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud_admin',
  'dbpassword' => 'Ops5',
  'installed' => true,
  'mail_from_address' => 'My_Name',
  'mail_smtpmode' => 'php',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_domain' => 'mail.com',
  'maintenance' => false,
  'loglevel' => 3,
);

The output of your Apache/nginx/system log in /var/log/____:

[Wed Jan 24 22:14:14.173608 2018] [ssl:warn] [pid 1203] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Jan 24 22:14:14.220389 2018] [mpm_prefork:notice] [pid 1203] AH00163: Apache/2.4.27 (FreeBSD) OpenSSL/1.0.2k-freebsd PHP/7.1.12 configured -- resuming normal operations
[Wed Jan 24 22:14:14.220446 2018] [core:notice] [pid 1203] AH00094: Command line: '/usr/local/sbin/httpd -D NOHTTPACCEPT'
[Wed Jan 24 22:38:53.289309 2018] [core:notice] [pid 1203] AH00052: child pid 1241 exit signal Segmentation fault (11)
[Wed Jan 24 22:38:53.356239 2018] [mpm_prefork:notice] [pid 1203] AH00169: caught SIGTERM, shutting down
[Wed Jan 24 22:44:11.967186 2018] [ssl:warn] [pid 821] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Jan 24 22:44:12.123437 2018] [mpm_prefork:notice] [pid 821] AH00163: Apache/2.4.27 (FreeBSD) OpenSSL/1.0.2k-freebsd PHP/7.1.12 configured -- resuming normal operations
[Wed Jan 24 22:44:12.123513 2018] [core:notice] [pid 821] AH00094: Command line: '/usr/local/sbin/httpd -D NOHTTPACCEPT'

System is running and appears to be working well, but not sure impact from above error. Any help appreciated.

Thanks!

Hi,

These error messages:

come from PHP and are a bug in PHP 7.1.12. So these messages appear in every NC version as soon as you upgrade PHP to 7.1.12 and there is nothing Nextcloud can do about them. Just ignore them, they are benign.

Regarding workflow engine. I would delete that app and Enable it from the App Store again.
Probably the result of copying the app folder from the backup folder of the older NC version.

What was the source where you downloaded the tar archive of Nextcloud from?

Thanks for your reply.

I’ve fetched the tar ball from download.nextcloud.com/server/releases.

Regarding workflow engine … I might have gone blind as I can’t see in in the applications list any where … checked all just to be sure.

Don’t want to remove the folder and cause a crash. Any suggestions?

image

Did you check under “Your Apps” where you see all apps - enabled and disabled.

Yes, I did…

I should call myself Sherlock Holmes :smiley:
I got really confused when I couldn’t find the app “workflowengine” on my server neither, but then I noticed the icons:

Search for the app “Collaborative tags” :wink:

Holmes … Sherlock Holmes, to paraphrase 007 :wink:

  • Disabled Collaborative tags and re-scan -> same
  • Removed workflowengine directory, re-scan -> error gone
  • Re-enabled Collaborative tags, it shows enabled, but workflowengine directory is gone

Either that directory isn’t needed anymore or I need to do some thing different to re-install… do you have any idea what maybe the case?

So far the system seems to be OK, but I only use it to upload phone photos and videos/load files I want to have access on the Go, so not sure the above would impact any other use.

Just trying to get to a workable/reproducible solution, so others with same issue will be able to fix it.

As always, @Schmu, thanks for all your help and sorry to keep disturbing.

Hi @melloa

I just had a look at my server. I have a folder workflowengine. So it seems this folder needs to be there, to have this app working.
Could you check under your admin settings if you still have the part “Workflow”, can access it and are actually able to setup a Collaborative tag?

When you run:
sudo -u www-data php /var/www/nextcloud/occ app:list | grep workflow

Do you get the app listed?

Maybe following helps:

  • sudo -u http php /var/www/nextcloud/occ app:disable workflowengine
  • download and unpack the app from github OR (second choice) copy backup of folder workflowengine into the nextcloud app folder
  • sudo -u http php /var/www/nextcloud/occ app:enable workflowengine
  • sudo -u http php /var/www/nextcloud/occ app:check-code workflowengine
  • sudo -u http php /var/www/nextcloud/occ integrity:check-app workflowengine

Morning @Schmu,

No, can’t see workflow under my admin settings.

That grep did’nt find anything:

root@nextcloud:/usr/home/mello # sudo -u www php /usr/local/www/apache24/data/nextcloud/occ app:list | grep workflow
root@nextcloud:/usr/home/mello #

The application can’t be disabled …

root@nextcloud:/usr/home/mello # sudo -u www php /usr/local/www/apache24/data/nextcloud/occ app:disable workflowengine
workflowengine can’t be disabled.

Sorry, feeling stupid here … I want to download from github as the problem could be the saved directory and/or files from the old install, but can’t figure out from where to download the workflow engine. Could you please direct me to it’s link?

Once download I’ll continue and report back.

Thanks,
Al

:smiley: Don’t worry!

https://github.com/nextcloud/server/archive/v12.0.5.zip

In this archive you find the apps folder and the subfolder workflowengine. Just copy that folder into your apps folder on your server, make sure to set the correct ownership and permissions and then run
sudo -u www php /usr/local/www/apache24/data/nextcloud/occ app:enable workflowengine
login and check again if the app is available online.

@Schmu,

Here’s the latest:

root@nextcloud:/usr/local/www/apache24/data/nextcloud/apps # cp -R /tmp/workflowengine ./
root@nextcloud:/usr/local/www/apache24/data/nextcloud/apps # chown -R www:www /usr/local/www/apache24/data/nextcloud
root@nextcloud:/usr/local/www/apache24/data/nextcloud/apps # sudo -u www php /usr/local/www/apache24/data/nextcloud/occ app:enable workflowengine
workflowengine enabled

Downloaded from git, unpacked, moved to my /tmp folder, copied to the apps directory, set permission, and enabled fine.

It also shows Enabled in the web gui as has the disable option in it.

root@nextcloud:/usr/local/www/apache24/data/nextcloud/apps # sudo -u www php /usr/local/www/apache24/data/nextcloud/occ app:check-code workflowengine
Error: Call to undefined function PhpParser\token_name() in /usr/local/www/apache24/data/nextcloud/3rdparty/nikic/php-parser/lib/PhpParser/Lexer.php:264
Stack trace:
#0 /usr/local/www/apache24/data/nextcloud/3rdparty/nikic/php-parser/lib/PhpParser/Lexer.php(29): PhpParser\Lexer->createTokenMap()
#1 /usr/local/www/apache24/data/nextcloud/lib/private/App/CodeChecker/CodeChecker.php(56): PhpParser\Lexer->__construct()
#2 /usr/local/www/apache24/data/nextcloud/core/Command/App/CheckCode.php(100): OC\App\CodeChecker\CodeChecker->__construct(Object(OC\App\CodeChecker\StrongComparisonCheck))
#3 /usr/local/www/apache24/data/nextcloud/3rdparty/symfony/console/Command/Command.php(256): OC\Core\Command\App\CheckCode->execute(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#4 /usr/local/www/apache24/data/nextcloud/3rdparty/symfony/console/Application.php(818): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#5 /usr/local/www/apache24/data/nextcloud/3rdparty/symfony/console/Application.php(186): Symfony\Component\Console\Application->doRunCommand(Object(OC\Core\Command\App\CheckCode), Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#6 /usr/local/www/apache24/data/nextcloud/3rdparty/symfony/console/Application.php(117): Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#7 /usr/local/www/apache24/data/nextcloud/lib/private/Console/Application.php(170): Symfony\Component\Console\Application->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#8 /usr/local/www/apache24/data/nextcloud/console.php(100): OC\Console\Application->run()
#9 /usr/local/www/apache24/data/nextcloud/occ(11): require_once(’/usr/local/www/…’)
#10 {main}

Can’t check code though.

That’s strange. If you picked the archive from https://download.nextcloud.com/server/releases/ everything should actually work flawless.
I had similar issues when I accidentally downloaded the archive from github (https://github.com/nextcloud/server/archive/v12.0.5.zip). Different folders (apps and 3rdParty-subfolders) were missing in that archive. I had to download the archive from the upper link to solve all these issues.

In your php.ini did you set short_open_tag = On or Off? I’m asking because I just read that some users (not Nextcloud related) experienced issues with short_open_tag activated.

I clicked on the link from the previous reply that pointed to https://github.com/nextcloud/server/archive/v12.0.5.zip, not https://download.nextcloud.com/server/releases/.

I had similar issues when I accidentally downloaded the archive from github (https://github.com/nextcloud/server/archive/v12.0.5.zip).

So, should I try from the server/releases?

[]'s,
Al

Actually not, that caused me some trouble :wink:
In server/releases not all files were included.

Ok …

My short_open_tag = Off