12.0.5 and 11.0.7 are out - time to upgrade!

I saw, that some people have/had problems updating

but fortunately the update via updater worked without any errors for me and everything works like expected!

1 Like

Update 12.05
SMB Share in extern hosts is not working anymore after update.

Log shows this error:
Error PHP Call to undefined function Icewind\SMB\smbclient_option_set() at /var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/NativeState.php#76


Same for me. 12.0.5 RPMs for OpenSuse (42.3) have been available more or less at the same time, and update from 12.0.4 worked perfectly fine.

So many thanks to the Nextcloud team, and also the OpenSuse repository maintainers!!!


I’ve upgrade 2 VM’s on Ubuntu 16.0.4. Both no issues upgrading, nor after the upgrade, other than:

  • being unable to upgrade via the CLI (wasn’t possible as it said I already had the latest version installed).
  • the (just annoying) need to adjust the maximum file upload again.

Worked for me

Add me to this list.

Working, but with errors: https://help.nextcloud.com/t/upgrade-12-0-5-workflow-engine-extra-files/26357

Waiting to find a solution or will reinstall someday.

My upgrade experience is usually terrible, and often results in loss of data.

I have used the webgui admin updater. Softaculaous, and occ from command line. All have resulted in problems for me.

What is the fool-proof method of upgrading nextcloud?

I’m on a shared hosting service, currently with NextCloud 12.0.4. Running in the webgui gives a “Cant handle ZIP file. Error code is: 5” error at a certain point. The occ update success without error, but then the nextcloud url is a 500 error when I go to the url.

Also is there a way of reconnecting to an encrypted data directory if you need to reinstall?

Update from 12.0.4 to 12.0.5 on f27 worked like a charm. Be aware of the php-7.1.13 upgrade package. Last known working version php-7.1.10!

Hm, I fear the upgrade to 12.0.5 didn’t work as well as I thought earlier. I just noticed that about 80% of my contacts are missing now :frowning:
Did somebody else check if contacts are still there?

Just checked: mine are all there.

EDIT: I did a manual upgrade on the command line (sudo -u www-data php occ upgrade)

1 Like

Mine as well.

Had no Problems upgrading Nextcloud to 12.0.5
All Contacts are there, however, some of them were marked “This card is corrupted and has been fixed. Please check the data and trigger a save to make the changes permanent.”. I counted 78 repaired of 443 total. But this could stem from my different Clients (Thunderbird with cardbook, Android, …)

Also check my Clients, … all 443 Kontakts are there even with a full resync

Hi @ProfDrJones

Can you explain where you saw the contacts marked with “This card is corrupted and has been fixed."?

How can I check the contacts and how can I fix contacts?

To make things easier, … here a Screenshot

I covered all personal data with green, so this is not a bug, …
Also the screenshot is in German, as my System is too, …

You simply need to save the contact again, and the repaired version gets synced, …

Have you checked the database, … and if the contacts are missing there as well? If they are not missing, have you checked the vcard-version of the contacts that are not displayed? I know, its a long shot, there was an issue and it should be fixed by now, but I had problems with older v-card formats a while ago and fixed it by converting them manually, …


Thank you very much!

I had a look into the database, but was not sure which table actually stores the contacts. A select on oc_cards and I get a lot of this:


Then, for users on my server:

PRODID:-//Sabre//Sabre VObject 4.1.2//EN

And very much of this:

@Schmu: lets move to private messages, … I’m not sure if posting about this specific Problem in this thread is rigth.


Got several bugs in IE11! Will try to make issues this week.

For me update worked like a charm (Server: Ubuntu, Clients: macOS, iOS, Ubuntu)

Works fine with PHP 7.1.13 (from remi) at the latest CentOS 7.