Updater from 12.05 to 13 doesn't finish and now my server is unavailable. Please help!

Nextcloud version (eg, 12.0.5):
Operating system and version Rasparian Stretch 9
PHP version 7

The issue you are facing:

I’m on 12.05 and all is fine. I did not see the new version message so per your website, I switched to the beta channel and refreshed the page. I then see 13.0 available. I run the updater and all goes well and it finishes normally. Then asks me if I want to keep it in some mode ( sorry I can’t remember now ) and I answer Yes for Web and click the Update button.
It now hangs and I cannot get to my server. It’s in a dead state. Note, I have updated multiple times and never had this issue. Please help. Unsure what to do. I can no longer access my server. In the browser I type my url and the page is blank.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Switch to beta channel and refresh page
  2. Run web updater to update to 13 from 12.05
  3. Script runs normally and gets to a point where it asks me whether to answer no for command line or yes for web. I choose yes for web and then I can no longer connect to my server. I have updated in the past. It should bring me to a page with an update button.

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:


the same issue as here

I ended up doing a manual update via this link https://docs.nextcloud.com/server/13/admin_manual/maintenance/manual_upgrade.html

and it worked. It’s showing Current Version as, but I’m having a few other issues. File Access Control and 2FA apps were disabled during the update as not being compatible with Ver 13 and I’m unable to activate them in the apps store. I get this error when activating:

App “Two Factor TOTP Provider” cannot be installed because it is not compatible with this version of the server.

App “File access control” cannot be installed because it is not compatible with this version of the server.

That basically answers your own question though. Reach out to the devs via topics in their categories.

For the Future


Then why this bullet point? …“can be combined with our File Access Control feature so administrator can enforce aspects of End-to-end Encryption”

This seems to indicate File Access Control works with 13.

From this official page: https://nextcloud.com/blog/nextcloud-13-brings-secure-file-sync-and-collaboration-to-the-next-level/

Is there a list of apps and features that have been removed from 13?

Thank you!

How do I install the caniupdate app? Thanks

From the the app store. Or manually


So, something went wrong with my update to 13 because the 2FA and the File Access Control app will not update. They won’t work with 13, yet the CanIUpdate app says they will before the update. So I restored back to 12.05. I installed the CanIUpdate app. I then changed to the beta channel and refreshed page to get the 13 update to show. The CanIUpdate app shows all green and good to go. I run the updater and again, all good on the first part. I then get a prompt asking whether to turn off maintenance mode for command mode or keep it on for web mode. I click keep it on for web mode. Same issue as before. When I click finish in web UI, I get a blank white page and my entire server is unreachable. There was no way to get back so I once again restore back to 12.0.5 from a backup. This update will not work. Do you think the issue has to do with using the beta channel? I’m simply baffled.

I love NC and am an unofficial NC evangelist with my friends. However, this latest issue is really frustrating and disappointing.

I would super appreciate any and all help resolving this update issue.
Thank you

What if you disable File Access Control before the update?

Do you think the FAC app is the cause of the hang? Or perhaps the 2FA app? Why would having these enabled cause the hang?

I had no problem updating to 12.04 and then to 12.05. Is it because the jump to 13 is a much bigger update?


I don’t know … Sorry.

Only wrote what I would try. Disable these apps and update :slight_smile:

Nextcloud to block when updating the database and now I have a blank page.

What should I do ?

I wonder why you keep the maintenance mode on. From the two options for leaving the maint mode on, it says:
No (recommended for web updater)

Or something like this.
For me both apps had the same issue, but after deactivating the maint mode, I was redirected and got the chance to finish the update itself and most importantly these apps among others were updated by Nextcloud itself (with a message “these apps need to be updated to run with NC13”).

same problem here: UI broken after Upgrade to Nextcloud 13

My recollection is the choice is to keep it on and proceed to Web UI to complete the update. The other choice is to turn it off and complete using the command line. I just know I choose to complete with Web UI and then it goes to a blank page and nothing happens. The server is unreachable. I have updated a few times before to 12.04 and 12.05 same way with no issues so I know how to do it. Something is broken in the update to 13. The most frustrating thing is that the page is just blank and it’s scary because the server is unreachable.

I would strongly advise to not update to 13 unless you know you have a good and reliable backup as you may need it.

I really hope someone from the dev team can step in and help resolve this issue.

It annoys me like a blank page.

Did you manage to update your database ?

I am self hosting so I was able to ssh to my server and finish via the command line via a manual update. However, it broke 2 apps. File Access Control and 2FA. Both are incompatible with 13. I understand there are 13 compatible apps for these, yet my system simply won’t let me install them. I need these apps so I ended up doing an entire restore back to 12.05. I believe there is an issue with the web update from 12.05 to 13 and will wait for the devs to address the issue before trying again. Perhaps the issue is with the update via the beta channel. I really don’t know.

OK, thanks.
What is the command to update the database?

The DB updated as part of the update automatically. I didn’t run a command.