Updater button redirects to dashboard

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version : 21.0.1 -
Operating system and version : Linux 4.19.0-17-amd64 #1 SMP Debian 4.19.194-3 (2021-07-18) x86_64
Apache or nginx version : Apache/2.4.38 (Debian)
PHP version : 7.3.29-1

I have the problem that the updater button immediately redirects to the dashboard. I know that this is a problem with docker installations - but this is not docker. Disabling the dashboard app does not help: Updater button redirects to files instead. I have done many successful updates before, this problem is new since version 21.0
I checked the “update.log” file - no error messages in it. It ends with

2021-09-03T08:06:27+0200 TFf45Sa8WF [info] end of checkForUpdate() Update to Nextcloud 21.0.4 available. (channel: "stable")<br /><span class="light">Following file will be downloaded automatically:</span> <code class="light">https://download.nextcloud.com/server/releases/nextcloud-21.0.4.zip</code><br /><a class="external_link" href="https://nextcloud.com/changelog/#21-0-4" target="_blank" rel="noreferrer noopener">Open changelog </a>

My config.php file

    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "user_backends": "***REMOVED***",
    "loglevel": 2,
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "overwrite.cli.url": "https:\/\/nextcloud.free.de\/",
    "htaccess.RewriteBase": "\/",
    "dbtype": "mysql",
    "version": "",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpmode": "smtp",
    "mail_smtpauthtype": "LOGIN",
    "mail_from_address": "***REMOVED SENSITIVE VALUE***",
    "mail_domain": "***REMOVED SENSITIVE VALUE***",
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "25",
    "ldapIgnoreNamingRules": false,
    "ldapProviderFactory": "\\OCA\\User_LDAP\\LDAPProviderFactory",
    "theme": "",
    "logtimezone": "Europe\/Berlin",
    "maintenance": false,
    "default_language": "de",
    "log_rotate_size": 104857600,
    "skeletondirectory": "\/var\/www\/nextcloud\/data\/skeleton",
    "memcache.local": "\\OC\\Memcache\\APCu",
    "auth.bruteforce.protection.enabled": true,
    "updater.release.channel": "stable",
    "mysql.utf8mb4": true,
    "activity_expire_days": 90,
    "encryption.legacy_format_support": false,
    "encryption.key_storage_migrated": false,
    "default_phone_region": "DE",
    "app_install_overwrite": [
    "updater.secret": "***REMOVED SENSITIVE VALUE***"

Any ideas? I did not yet try manual update procedure.

Same here with a Docker installation… What’s the link with Docker installations?
Thanks in advance for any clue!

Please have a look at Open Updater”-Button is redirecting to dashboard

Thanks @manwir for the link!

It seems indeed that updating my Nextcloud instance cannot be done through the web updater. Instead, as I have used Portainer to install the instance, I’ll perform:

  • Stopping then removing the Nextcloud container,
  • Updating the stack (a.k.a. dockerc-ompose file) if needed
  • Restarting the stack to recreate the Nextcloud instance

Will this process keep all plugins and apps installed as well?

Thanks again for your help!

Sorry, but I am not using a docker installation. Therefore I cannot help you.

Thanks anyway!

By the way, I’ve tried the simple way: “entering the container” and launching a manual upgrade using occ (php occ upgrade) which returned Nextcloud is already latest version!

Therefore, I don’t understand why the web GUI is displaying that a new version is available… :thinking:

Thanks to anyone who can provide a clue!

Hi all!

I finally manage to perform the upgrade, which was way simpler than expected: as I’m using Portainer to manage the Docker containers (much simpler for a newbie like me :wink:), I just had to head to the Nextcloud container and ask Portainer to “Recreate” it, just ticking the box “Pull new image first” and this did the trick!

Nextcloud now displays the correct version number and the information message “a new version is available” has vanished…

Thanks to all for your help!

I am not quite sure if this is the solution but after adding


to the php configuration


the last update of nextcloud worked perfectly using the the web updater.