"Open Updater"-Button is redirecting to dashboard?

Nextcloud version : 20.0.4
Operating system: Ubuntu 20.04
Apache or nginx version: nginx 1.19.3
PHP version: 7.4.14

The issue you are facing:

Hello,

I am still very green about nextcloud and try to open the Web-Updater to update to 20.06. When I click on the “Open updater” button instead of opening the updater I am redirected to the dashboard site (https://-----.-----.de/apps/dashboard/).

In settings->logging nothing is shown about the updater. I am using the Docker-Image behind an nginx reverse proxy with letsencrypt companion.

Regards, Stefan

The output of your config.php file:

<?php
$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'instanceid' => '----------',
  'passwordsalt' => '----------------------------',
  'secret' => '----------------------------------------',
  'trusted_domains' =>
  array (
    0 => '----.-------.de',
  ),
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'mysql',
  'version' => '20.0.4.0',
  'overwrite.cli.url' => 'http://----.------.de',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.-----:3307',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '---',
  'dbpassword' => '-------',
  'installed' => true,
  'mail_from_address' => 'cloud',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '-----.de',
  'mail_smtphost' => '192.168.----',
  'mail_smtpport' => '2525',
  'updater.secret' => '--------------------------------------',
);

Sorry no real idea. But perhaps you can temporary deactivate the app dashboard in your app menu.

I tried it, now it redirects to the Files: https://-----.-----.de/apps/files/?dir=/&fileid=893

Very strange. Is there may be another logfile to look into?

Please use another browser or delete all cookies and data or use an anonymous tab. Perhaps it helps you.

Thanks for your help, but sorry again no change. I tried it with Chrome, Edge and Firefox. Same behaviour on all of them.

I did a “docker-compose logs -f” into the docker container to watch what the webserver is doing when I click on “Open Updater” and received the following output (I removed IP’s, Date and the useragent string to make it shorter and better readable):

[15:47:50] "GET /apps/updatenotification/credentials HTTP/1.1" 200 855 "-" 
[15:47:50] "POST /updater/ HTTP/1.1" 302 917 "-" 
[15:47:50] "GET /apps/files/ HTTP/1.1" 200 10785 "-" 
[15:47:50] "GET /ocs/v2.php/apps/notifications/api/v2/notifications HTTP/1.1" 200 1647 "-" 
[15:47:50] "PUT /apps/user_status/heartbeat HTTP/1.1" 204 686 "-" 
[15:47:51] "GET /ocs/v2.php/search/providers?from=%2Fapps%2Ffiles%2F HTTP/1.1" 200 1020 "-" 
[15:47:51] "GET /apps/systemtags/lastused HTTP/1.1" 200 791 "-" 
[15:47:51] "GET /ocs/v2.php/apps/text/workspace?path=%2F HTTP/1.1" 404 895 "-" 
[15:47:51] "GET /ocs/v2.php/apps/user_status/api/v1/user_status HTTP/1.1" 200 921 "-" 
[15:47:51] "PROPFIND /remote.php/dav/files/XXXXXX/ HTTP/1.1" 207 1603 "-" 
[15:47:51] "GET /index.php/apps/files/ajax/getstoragestats.php?dir=%2F HTTP/1.1" 200 983 "-" 
[15:47:53] "GET /apps/photos/service-worker.js HTTP/1.1" 200 5152 "https://XXXXX.XXXXXX.de/apps/photos/service-worker.js" 
[15:47:51] "GET /cron.php HTTP/1.1" 200 895 "-"

Guess the log also doesn’t help much so more ideas welcome :slight_smile:

I did some further research:

Whatever folder I enter behind our Nextcloud domainname, for example https://cloud.domain.com/bla it is always redirecting to https://cloud.domain.com/apps/files/?dir=/&fileid=893 so the files seems to be the default folder where it redirects if the requested URL isn’t found.

The following volumes are connected into the docker container:

      volumes:
        - ./data:/var/www/html
        - ./app/config:/var/www/html/config
        - ./app/custom_apps:/var/www/html/custom_apps
        - ./app/data:/var/www/html/data
        - ./app/themes:/var/www/html/themes

If I have a look into ./app/ folder should I find anything having to do with the updater in some of the sub-folders? Maybe something is missing there?

//Edit: I found the requested folder (first line in the log above) /apps/updatenotification/ but not /apps/updatenotification/credentials. Could this be the cause? If yes, any ideas how to resolve without reinstalling?

It is recommended to update the docker container, not web-based.

Follow the instruction to upgrade:

Actually, they removed entire updater/ folder by design, making response 404 or redirect to index.php, depending on your configuration.

1 Like

Thank you very much - that makes much sense.

Haha. “makes sense”? … “makes sense”?!!

They removed the function of a button but left the button … “by design”. 404 by design … Haha, that’s rich.

1 Like

Hi,
So every time we have to wait for Docker container version to get updated although we get notification ?

Yes, or build the image yourself :slight_smile: