Update to Nextcloud 17 not available

Hi,

what can I do?

user@nc:/# sudo -u www-data php /var/www/nextcloud/updater/updater.phar
Nextcloud Updater - version: v16.0.3-3-ga0c2b25 dirty

Current version is 16.0.5.

No update available.

Nothing to do.

Thanks!

wait, it will available in waves to prevent high impact at the downloadserver

Hallo @jakob1!
Wenn Du in der Einstellung von “Stabil” auf “Beta” umschaltest -> dann kurz rausgehst und anschließend wieder auf die Update-Seite gehst, zeigt es dir die Version 17.0.0 an, die Du dann problemlos installieren kannst. So brauchst Du nicht länger warten!
Vergesse aber anschlieĂźend nicht, von Beta wieder auf Stabil umzustellen!
Viel Erfolg!
Findulin

You could temporarily switch to the beta channel and recheck for updates, then switch back after upgrading.

Thanks, that’s working :slight_smile:

1 Like

yay.

and please… for the next thread… try doing some searching through the forum first… :wink:

1 Like

I’m not sure whether it is appropriate to post my question in this thread, since the OP’s problem seems to have been solved, but I’m afraid I have the exact same problem - except that I already tried the suggested solution (setting update channel to “Beta” and then logging out and back in), and it did not help. It still says “” Nextcloud 16.0.5 Your version is up to date". FWIW, I upgraded from SQLite to MySQL today and also upgraded the db to support 4-byte characters. Could this have anything to do with it? Or maybe someone has another idea?

You could set it to the beta channel, then in the terminal try running updater.phar as your web user. This would typically look like

sudo -u www-data php /var/www/nextcloud/updater/updater.phar

And see if that gives you the option or says no updates available. Next steps would be checking if your instance is actually able to reach the update server .

Thanks for the reply!

I can’t run sudo. My hosting provider doesn’t allow it on shared hosting. But I should be able to do everything else.

By the way, I just logged into my Nextcloud admin panel and I see an update available for Bookmarks and Custom CSS apps. That means i can connect to the update server, doesn’t it?

Ok. Do you have any way to run terminal commands? You just need to run as the web user, not necessarily using sudo.
Yea I guess if it’s getting app updates there’s no reason it shouldn’t be able to reach the server to check for a new nextcloud version. I’m out of ideas :thinking:

So I switched to beta channel in the UI, then opened up PuTTY and ran updater.phar, and now it’s showing 17 available in both the UI and PuTTY. Thanks! :grinning:

1 Like

I had the same issue too, but even setting beta channel in UI, and runnig updater.phar over ssh did not help. I used to be on 16.0.5, but because I set beta channel I am now on version 16.0.6 RC1… before I go on and update manually, is there anything else I can try?

I’m having the same problem as you. I waited a month for 17 to show and then followed the advice to switch to beta. Now with 16.0.6 RC1 installed it’s saying I’m up to date.

I have tried using
sudo -u www-data php /usr/share/nginx/nextcloud/updater/updater.phar

and get the message
“Current version is 16.0.6 RC1
No update available”

I also tried
sudo …/updater/occ upgrade
and get
“Nextcloud is already the latest version”

I do not have the Group Folder app installed and its folder is not present

How can I get my system to upgrade to 17?

1 Like

A while ago I wrote a bash script that I use for upgrading my testing and live instances of Nextcloud. First it creates a backup of the current instance (including the data-directory) and after that it upgrades the installation.
The script follows strictly the official Nextcloud documentation for creating backups and performing a manual upgrade (the only difference from the documentation is the naming of the backup files).

If you have shell access (looks like you do), you could use that script to upgrade your installation to NC17: https://github.com/BernieO/ncupgrade

1 Like

I came here to report exactly the same issue with all of my NC installations - upgrade to v17 is not displayed.

In the past, I promptly received upgrade notifications and updates worked fine. Until version 16.0.5. I’m stuck in this version for months and updater always claims it’s the latest available version. I searched the forum and applied all the suggestions without any luck:

  1. Running updater.phar via command line manually also claims I have the latest version.
  2. Switching to Beta channel displays only version 16.0.6 RC available to download.

According to forum search, option #2 worked in the past, but stopped working recently, and many users can’t upgrade to v17 now because they seem to be stuck on 16.0.5.

I see @Bernie_O wrote some script and greatly appreciate it, but I would prefer an “official” solution or fix for this major problem.

P.S. I realize devs make software in their free time and don’t ask us to pay for it, so please be sure I do NOT blame or criticize someone. S**t happens even for best devs, but I hope that they can fix it soon.

1 Like

Yes, I have the same issue as toxpal and cmcloughlin. NC 17 update is not shown in Nextcloud updater.

EDIT: I created an issue: https://github.com/nextcloud/updater/issues/250

If this is a major problem for you, you could follow the official documentation and perform a manual upgrade:
https://docs.nextcloud.com/server/17/admin_manual/maintenance/manual_upgrade.html

Yes, I’m perfectly aware of manual update option, which is very complex and might cause lots of issues for majority of users. That’s why I hope devs will address this issue sooner or later.

have you guys ever heard that there are several possibilities why it won’t show up?
like

  1. too many requests at once and so it comes in waves
  2. too many bugs and so it was withdrawn
  3. your instance doesn’t meet all requirements
  4. own misconfiguration
    etc…

other than that…

this is always possible and valid.

Are these facts or speculations? They look like totally random speculations to me, because:

1. too many requests at once and so it comes in waves
It’s about 40 days after NC 17 was released. It’s understandable if NC uses some mirrors to reduce load and/or serve updates in different time intervals for each mirror, but 40 days have passed already. It never happened before, and somehow, it only happens when trying to upgrade from 16.0.5 to 17, which means it has nothing to do with too many requests.

2. too many bugs and so it was withdrawn
You can always see the official NC page and/or announcements and/or other posts, which say NC17 is the latest stable and recommended release. So speculation “it was withdrawn” is absolutely not true and doesn’t make sense at all.

3. your instance doesn’t meet all requirements
Yet again, it somehow magically happens only when running 16.0.5, and upgrading to 17 manually magically makes your instance to meet all requirements again?

4. own misconfiguration
Some magic again? Could you elaborate how it’s possible that dozens of users somehow mis-configured their installations by making exactly the same change overnight and started reporting exactly the same issue all together? And the “fact” that only users running 16.05 misconfigured their installations.

I believe users who experience this issue (and there are many of them) would appreciate some fact, not a random speculation.