Following my system configuration:
I’m running a VS with Centos 6.9 and Plesk ONYX 17.0.17 with PHP 7.1.15 running as FASTCGI application within the Plesk subscription (PHP 5.3.3 within Centos 6.9)
Root cause for my problems is probably the upgrade from PHP 5.6.34 to Plesk 7.1.15 prior to my Nextcloud update, as former updates were accomplished without any problems.
In my case the problems occured when updating my Nectcloud version 13.0.0.14 to 13.0.1.1 using the webupdater within Nextcloud administration.
Please always ensure to have a backup of your nextcloud install before updating!!!
Following my resolution to the problem as it worked out for me:
1. Step - Resolution of the Step 4 “Parsing response failed. 500 Internal Server Error” in web updater
In my case it turned out to be a PHP read buffer timeout which caused “a website is not loading and 500 internal server error” to be shown shown after ~30-60 seconds.
Cause
The [ FcgidIOTimeout ] value - the maximum period of time the module will wait while trying to read from or write to a FastCGI application - has been exceeded. You can solve this by increasing the standard buffer timeout time.
Resolution
Increase the parameter value or optimize FastCGI application.
FcgidIOTimeout
parameter for a domain is set to the same value as max_execution_time
PHP parameter.
- Set “max_execution_time” to “1200” in Plesk >> Domains >> YOURDOMAIN >> PHP settings
- Increase “FastCGI” timeout by adding the following Apache dirctives in Plesk >> Domains >> YOURDOMAIN >> Apache & Nginx settings >> Additional Apache directives :
< IfModule mod_fcgid.c >
FcgidIOTimeout 1200
< /IfModule >
After completion go to your web updater and push the retry update button or delete the “.step” file under /data/updater-ocxxxxxxxxxx in your nextcloud installation, change maintenenace to false in config.php and restart the web updater.
In my case the update went fine until step 9 of the web updater which is “Move files in place”, where the updater exits with a “Parsing response error”.
2. Step - Resolution of Stop after Step 8 with “Parsing response Error” in Step 9 in web updater
In my case the delete old files went through without error, so only the swap of the new nextcloud files from the download folder to my nextcloud installation wasn’t completed. However, I was not able to clearly isolate the root cause for this error. Nevertheless, subsequent workaround worked for me:
Ensure to save your .htaccess and .user.ini files in your nextcloud root directory as well as your config.php file and settings!
Go then to your /data/updater-ocxxxxxxxxx/download folder and copy all therein existing folders and files into your /nextcloud root location. (All folders should be copied on the same hierarchy level as /app and /data.)
Allow for overwriting, as the copy will complement or overwrite exiting folders. 11 files in your nextcloud root are going to be overwritten and the two files in the updater folder. Copy your saved config .php, .htaccess and .user.ini back to their locations in case they had been overwritten.
After this has been accomplished delete “.step” file in the /data/updater-ocxxxxxxxx folder of your nextcloud installation and set maintenance to false in config.php.
Once your start nextcloud it states that it has to finalize the update. Confirm and that’s it!
Worked like a charm and Nextcloud was updated to version 13.0.1.1 and running stable without any errors!