Update to Nextcloud from fails

I have been installing and working with nextcloud from the early days of its existence.
Update & upgrade always went fine and I had no issue fixing occuring problems. However this time I am not getting any further while trying to update from version to
It’s a minor upgrade and should be smoothly going forward. However I am stuck at step 4 (Backup) and always receiving an error, whether by going through webupdate or using updater.phar at the command line level.

Error appearing when using the webupdater is one already mentioned in prior comms of this forum:

“Parsing response failed. 500 Internal Server Error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.”

Using updater.phar immediately stops with a parsing error:

“PHP Parse error: syntax error, unexpected ‘[’ in phar:///var/www/vhosts/…/httpdocs/nextcloud/updater/updater.phar/lib/UpdateCommand.php on line 41”

However all contributions to the resolution of this problem in this forum, did not help me any further until now. Does anyone have any idea what this error is caused by.
I am running PHP version 7.1.15

Thanks in advance!

Nobody with any idea how to proceed??!

Deleting “.step”, reseting maintenance mode from “true” to “false” and retrying the install doesn’t work.
It’s also not a rights issue. The log only indicates that the “backup folder already exists”. However deleting it and repeating leads to the same error and doesn’t resolve the problem either. The server also does not indicate any trouble in the logs and Nextcloud currently works without any problems .

What is strange is that updater.phar complains about a parsing error which I can not yet identify. Could this relate to changing from PHP 5.6.34 to 7.1.15 prior update? Although I find this strange to be causing the backup interruption.

Truly appreciate some thoughts from the Nextcloud developers.

That file in your error is not working because:

  • you are running php 5.3
  • you manually edited/copied something broken
  • the file is broken to begin with

If the latter applies, please file an issue

3 slashes? really?

Not running PHP 5.3 for a long time now. I was running 5.6.34 before updating to 7.1.15.
That can’t be it!

Hmmmm … believe it or not … copied the line various time for analysis … really have overseen this one … can’t truly see the trees in the forrest :wink:

I assume it’s an open_basedir problem … will immediately check
Thanks a million JimmyKater!

But why does the web updater exit with step 4? You think this is related!

Hi Bernhard,

your comment made me rethink after stating that "this couldn’t be it!"
And yes you are right. When running on the command line I am running php v 5.3.3.

The nextcloud instance runs on my VS in a PLESK PHP 7.1.15 environment, so I have no chance running the updater on the command line. However I identified the problem in the webupdater being a php read timeout so I increased FcgidIOTimeout from 45 to 120 in the Apache settings, which made the updater work fine. However, I am stuck in the last step “Move files in place” where the updater exits with a “Parsing response failed” error.

The updater.log file does not indicate any error. It just ends with correct completion of the “Delete old files” step. Also the error log does not show any information!

Any idea how this can be resolved. Would be much appreciated!

Can I manually copy the files back by copying from the new download directory everything to my nextcloud install directory?

Solved the problem after some investigations. Finally!!!

Will file my solution, so others can benefit if encounterung the same failures.
Thanks for your direction with regard to the PHP version. It helped me moving into the right direction and identifying, that the problem could be tackled from a different angle.

1 Like

Following my system configuration:
I’m running a VS with Centos 6.9 and Plesk ONYX 17.0.17 with PHP 7.1.15 running as FASTCGI application within the Plesk subscription (PHP 5.3.3 within Centos 6.9)

Root cause for my problems is probably the upgrade from PHP 5.6.34 to Plesk 7.1.15 prior to my Nextcloud update, as former updates were accomplished without any problems.

In my case the problems occured when updating my Nectcloud version to using the webupdater within Nextcloud administration.
Please always ensure to have a backup of your nextcloud install before updating!!!

Following my resolution to the problem as it worked out for me:

1. Step - Resolution of the Step 4 “Parsing response failed. 500 Internal Server Error” in web updater
In my case it turned out to be a PHP read buffer timeout which caused “a website is not loading and 500 internal server error” to be shown shown after ~30-60 seconds.


The [ FcgidIOTimeout ] value - the maximum period of time the module will wait while trying to read from or write to a FastCGI application - has been exceeded. You can solve this by increasing the standard buffer timeout time.


Increase the parameter value or optimize FastCGI application.

FcgidIOTimeout parameter for a domain is set to the same value as max_execution_time PHP parameter.

  1. Set “max_execution_time” to “1200” in Plesk >> Domains >> YOURDOMAIN >> PHP settings
  2. Increase “FastCGI” timeout by adding the following Apache dirctives in Plesk >> Domains >> YOURDOMAIN >> Apache & Nginx settings >> Additional Apache directives :

< IfModule mod_fcgid.c >
FcgidIOTimeout 1200
< /IfModule >

After completion go to your web updater and push the retry update button or delete the “.step” file under /data/updater-ocxxxxxxxxxx in your nextcloud installation, change maintenenace to false in config.php and restart the web updater.

In my case the update went fine until step 9 of the web updater which is “Move files in place”, where the updater exits with a “Parsing response error”.

2. Step - Resolution of Stop after Step 8 with “Parsing response Error” in Step 9 in web updater
In my case the delete old files went through without error, so only the swap of the new nextcloud files from the download folder to my nextcloud installation wasn’t completed. However, I was not able to clearly isolate the root cause for this error. Nevertheless, subsequent workaround worked for me:

Ensure to save your .htaccess and .user.ini files in your nextcloud root directory as well as your config.php file and settings!
Go then to your /data/updater-ocxxxxxxxxx/download folder and copy all therein existing folders and files into your /nextcloud root location. (All folders should be copied on the same hierarchy level as /app and /data.)
Allow for overwriting, as the copy will complement or overwrite exiting folders. 11 files in your nextcloud root are going to be overwritten and the two files in the updater folder. Copy your saved config .php, .htaccess and .user.ini back to their locations in case they had been overwritten.

After this has been accomplished delete “.step” file in the /data/updater-ocxxxxxxxx folder of your nextcloud installation and set maintenance to false in config.php.

Once your start nextcloud it states that it has to finalize the update. Confirm and that’s it!
Worked like a charm and Nextcloud was updated to version and running stable without any errors!

1 Like

This answer by @hishthehush just solved it for me too. I got stuck on step 3 going from version 13.0.6 to Nextcloud 14.0.3 (channel: “stable”).
I’m in Ubuntu server 16.04.3 and manage with Virtualmin 6.04. It was the same routine to fix it for me. Open the virtual domain for my Nextcloud, open the PHP file, alter the timeout, and then alter my Apache file for the virtual host.

Thanks so much.