Unable to Update from

Please follow my exact instructions. I don’t want to confuse you. This is the ncp process now that you are behind. Please backup, follow it exactly, and all should be fine.

ok, thanks

1 Like

Sure thing. You can also update the nextcloudpi utility to the current version, which is 1.46.* iirc

Yes, that I did already.
When SSH on server, the notification of update is promptly there.

<maybe the following is for a different post?>
It went all fine update successful and all the process without error but at the end I had:
All tables already up to date!
Error: Could not download app notify_push
Clean up…
Rolling back to backup /var/www/nextcloud-bkp_20220207_1644270919-…
check free space…
extracting backup file /var/www/nextcloud-bkp_20220207_1644270919-…
Is anything that I did wrong?
(used ncp-config)
Any suggestion is welcome.
Will read more tomorrow, is late in this part of the world… good night

At this moment NCP is at v1.46.7, NC 22.2.2 and Debian 10 (Buster)

NCP is still at version 22.2.2 due to stability issues with versions 22.2.3 and 22.2.4. It has already been discussed somewhere in this forum.
I think it was related to Nextcloud’s slowness and the @kattivius is looking for official NCP updates.

1 Like

Thanks, they can update to 21 and then switch back up 0 to avoid that confusion when updating to 22. Updated the instructions. Unsure of the best way to sort out notify_push so asking the chat.

Maybe the notify_push app is only 64-bit.
The installation is old, a 32-bit image must have been used.
I have not found any information about this in the app store or on Github.
I think it is better to wait until the installation is completely up-to-date and go from there.

Its morning, about 7h after your last message, my NCP is still scanning for users.
About the 32-bit vs 64-bit, it can be the case.
The original installation was done in 2019.
Mean while I upgraded the hardware on a rpi 4B but I did not make a fresh instal. I migrate the all thing.
If this is the case, does it means I will never be able to upgrade NCP unless I reinstall it all NCP freshly?

The server is still working the update or restoring the back up, not clear. But looks like super slow and some warnings already came out…
I fear this update did not go well!
Lets see…
Errors start from here:

Exception during scan: An exception occurred while executing ‘SELECT fileid FROM oc_filecache WHERE (storage = ?) AND (path_hash = ?)’ with params [4, “12e47f1d49dddeeeae97a0a4557860f7”]:

SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

Pls, run ncp-report from the terminal and post the report in pastbin and the link here

going to…
this is the final message f the upgrade:
Rollback successful. Nothing was updated
NCP configuration page on system info page is now blank!
going to post the report soon…

Hi @vascocb ,
here is the pastebin link.
Thanks for the help
Nextcloud installation Issue ncp-report

I can’t help with this problem, maybe someone in the forum can.

This is not the most elegant solution, but you can install the latest NextCloudPi image and then restore the backups you have.

Make a full backup (nc-backup)
Intstall the image
Run ncp-update (ncp-update)
Restore the backup (nc-restore)
Update NCP as @just said (nc-update-nextcloud)

I understand.
Will my external HD be recognize?
My data is in an external disk.
Basically, is there a procedure to make a new installation and retain your external disk?
Isn’t a bit strange that someone with old installation has issue to keep up with upgrades if the original image is older?
That would affect a lot of users.
But I cant read many with this issue…
is it possible a different solution?

Read docs.nextcloudpi.com or search the forum to learn how to setup an external drive. Restore process is detailed as well. Linking the 32 to 64bit migration below.

Moving away from 32bit has been an on-going process the last couple years. A lot has change since version 20, much of it under the hood. And I guess no one has asked about this migration in a while. So, we are happy to help you.

We’ve done our best to help the user base with documentation and guidance. You can find all of the past questions and topics about this within the forum. Here are some relevant ones…

Does my device support 64 bit?

Why am I stuck on armhf and not on arm64?

How to migrate from armhf to 64-bit


@just Apreciate it.
Dont get me wrong, please. I highly appreciate all the work is done on NCP.
Sometimes I get frustrated when I have to re-start major work on it with annexed fear of loosing data (and time).
But eventually I will be happy again.
When I start the migration I will be picking this thread again and ask for help and guidance if and when needed (most probably I will :sweat_smile:)

Hi @just ,
I am here to report…
First of all thank for the procedure and help.
I decided to move the cloud to a better Pi: Rpi 4B with 8gb (moved from 4GB).
I followed all the How to move from armhf 32bit to arm64 pi 4
all worked smoothly.
I than started to upgrade as you suggested: moving first to 21.0.8 and than using 0 (in nc-update-nextcloud) to install latest version.
After upgrading to 21.0.8, I tried to upgrade with 0.
However I had the same issue:
Running nc-update-nextcloud
Upgrade cannot skip major versions. Please upgrade one major version at a time
Done. Press any key…
However, when I manually choose to install version 22.2.2, it worked!
I found this quite odd…
After be on 22.2.2, 0 started to work.
I realized that since the time you suggested how to upgrade, a new major varsion came out and therefore I could not use 0 from 21.x
I would consider this problem solved.
I am installing version 23.x as I am writing to you.
Than you all for helping and guide me to a smooth transition to arm64 pi 4

Glad to help.

Nextcloud only allows you to update major version to the next major version. It is a strange quirk, but you always have to upgrade 21.x to 22.x, etc. You ran into this issue because Nextcloudpi is now on 23.x

Cheers! Be sure to always keep automatic backups and you should be good for switching on automatic updates. :slight_smile:

1 Like