Unable to run legacy Nextcloud client on MacOS Catalina 10.15.7

Nextcloud client installed from package Nextcloud-2.6.5.20200710-legacy.pkg doesn’t run. It gives a notification of Update Check: New Nextcloud version 3.1.3 is available. Please click <a href='https://nextcloud.com/install'>here</a> to download the update.

The only versions available are the legacy package above and version 3.11.0 which doesn’t run on macOS Catalina. Version 3 used to run on macOS Catalina.

You might check this discussion:

That discussion was a lifesaver. Thank you!