Unable to Log in

Nextcloud version (eg, 20.0.5): 23.0.2
Operating system and version (eg, Ubuntu 20.04): debian 11 from the offical nextcloud docker image
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.52
PHP version (eg, 7.4): PHP/8.0.16

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  • trying to log into NextCloud Cookbook by Teifun2 using either an app password or my admin credentials.

The output of your Nextcloud log in Admin > Logging:

Nothing is logged even when I intentionally log in with wrong credentials. 

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    1 =>
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
  'instanceid' => '',
  'passwordsalt' => ''
  'secret' => '',
  'trusted_domains' =>
  array (
    0 => 'localhost:8080',
    1 => '',
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'sqlite3',
  'version' => '',
  'overwrite.cli.url' => 'http://localhost:8080',
  'installed' => true,
  'maintenance' => false,
  'updater.secret' => '',

I’m fairly new to NextCloud. I recently discovered this add on and it has a lot of potential. i tried to download the Nexcloud Cookbook app by Teifun2 but i can’t log in. i see the error in the screen shot provided. I did follow the steps to create an app password and used it to try and log in. Is it still user error?
messages_0 (2)

it looks like you directly tried to download the cookbook app from the app store or play store, but I think you might first have to check if the app is installed when you login to your nextcloud through your browser as an admin

So i did install the app on the server first and played with it there before downloading the app. i even copy and pasted the app password so i didn’t mistype it. i try to go to the logs and don’t see anything. i still use my username as the username here and not the device name correct?

Try reading the documentation for that app.

Hi @Liketheyogurt,
You are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Thanks.

yes, it should be your regular user name and password. Can you login to other clients on your phone like the files app with the same username and password?
The docs of the app say “It works best with an Nextcloud installation >= 19 and a Cookbook plugin version 0.7.9”, which version of the cookbook plugin are you using?

i’m using Nextcloud v23.0.2 and Cookbook v 0.9.11

what’s this? A windows-app for NC-Cookbook? Pls re-link here.

it is an android app recommended by the developer of cookbook:

awww I see. I was just wondering because of

so to make sure: you have nc-cookbook-app installed correctly to your nc-server (hopefully NOT running on windows), right?

and then you installed NC-Cookbook (by Teifun2), filled out your server-URL (https://cloud.your.domain) and your credentials (credentials of user who is using cookbook)?

I just did that and it worked like a charm!

Looking at your config.php… are there further setupmessages under your admin-account/setup/general which needs to be solved, still?

sorry. it is a docker image on windows 10 but the docker image is the official docker image for nextcloud.

Afaik NC isn’t really tested nor certified to run on such an evironment. Plus I dunno how compatible a dockercontainer would run on a windows system…

So I suggest to at least spin up a VM running a linuxsystem… or even better: spinning up official VM or VM of nextcloudpi (which is as well official nc-versum)… Both of them would help you setting up your instance sanely and safe. And could be transferred to other hardware later on, if neccessary.

I do not know exactly where the problem lies, but I suggest doing the following:

  • Inform the developer, that is, go to the repo site and open an issue.
  • You can reach him directly in the Matrix chat system. If you are part there, I suggest you post your account here.

Do you have any special configuration regarding your HTTPS server? This seems (from the error messageand without further knowledge) to be an incompatibility of your mobile’s operating system and the server.
Are you using https (also in the Server URL field)?

To check your security settings:
Go to the server in your desktop browser (I use Firefox, Chrome should be similar). Next to the address, there is a small lock. (Sorry, currently I cannot upload a screenshot) There is a message like The connection is secure or similar. Click on it and then on Further information.
In a popup, you can navigate to the tab Security and see some technical details. What encryption settings are configured/used?