Unable to find TOTP app

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version : 20.0.5
Operating system and version: Raspberry OS
Apache: Apache 2.4.38
PHP version: 7.3.19-1

I’m unable to find the TOTP app when I search for it in NextCloud.
I’d like to enable 2FA but without this app I can’t.

Is this the first time you’ve seen this error? Y

Steps to replicate it:

  1. Login into NextCloud with admin
  2. Go to Applications
  3. Search for “TOTP”
  4. No app found

Thanks for any help

For TOTP you need the app Two-Factor TOTP Provider . Search in the app part “security”.

Here a video sorry in german.
Cloud richtig absichern! Zwei-Faktor-Authentifizierung für Nextcloud - YouTube

Please see the image… It reads (no results for totp).
I don’t know what to do…

Please do not search. Scroll through all apps in “security”.

I’s not there

Perhaps you can change the language to “english”. Also perhaps you can post a screenshot with the list of the apps in security. I also use Nextcloud 20.0.5 and with search “totp” i find the app and i also see the app in the overview.

I switched the language to english.
I post here the list of apps in security section


I tried to install manually issuing this command
sudo -u www-data php occ app:install --keep-disabled twofactor_totp
but it returns with this error
Error: Could not download app twofactor_totp

Can you install other apps. Perhaps you have from your server no access to the app server from Nextcloud GmbH.

Yes, I can. I just installed “Antivirus for files”

I solved doing it manually.
I downloaded the tar.gz file of the app, I moved to apps folder on nextcloud and enabled it using occ.
Strange i didn’t find it through the web interface.

Perhaps an url filter or adblock. You can use network analysis (F12 or right click firefox menu) to analyse it.

Me and another tester ran into the same issue when testing the upgrade to NC20.0.5.

Many apps were disabled and had to be force-enabled and others completely disappeared from the app store, such as TOTP and News.

@DavideAccogli are you using NCP or plain NC on your Raspberry Pi?

1 Like

I’m trying to make a list of the apps with problems

This is what I found after upgrade to 20.0.5. Can be more. At this moment is not easy to replicate all the instalation This is on Nextcloudpi Debian 10 x86_64 (curl instalation) and Nextcloudpi on raspberrypi 4 (nextcloudpi image).
There are no differences betwin the two.
In 20.0.4 all apps are working as expected.

Marked as untested and disabled by the upgrade:
Two-Factor Admin Support

Apps that disappeared from the app store/my installation:
Collaborative tags
Two-Factor U2F

1 Like

Bello, I’m using NC on Raspberry PI 4.
I downloaded version 18 at https://download.nextcloud.com/server/releases and upgraded stabile releases as they were available.

So I’m not mad. TOTP disappeared.
I manager to install it manually and it works, but that it’s not the way it should be.

Please read this. Perhaps it is a solution for you.

Whi don’t you try the last Nextcloudpi image?
Is working well in version 20.0.4 and is optimized for raspberrypi.

Thanks, but my instance is in production and I prefer to maintan the main line.