Trying to upgrade 14.03 to 14.04 - I get: The following extra files have been found * .rnd

update_problems
integrity-check
nc14

#1

trying to upgrade 14.0.3 to 14.0.4 - I get: The following extra files have been found * .rnd

can’t do the upgrade. How do I fix this - need detailed steps please
it is great - just delete it. what commands do I use to delete such a file


I get the notification "Check for expected files"
#2

Same here. Please for help.


#3

This gives a good explanation of what this .rnd file is: https://askubuntu.com/questions/379943/what-is-the-rnd-binary-in-my-folder
It has to do with OpenSSL and it should be safe to delete it.

I also ran into this problem and after deleting it, the updater could continue normally. It’s in the directory where you unpacked Nextcloud, so something like /var/www/nextcloud/.rnd (depends on your setup though).

I’m not sure why this .rnd file showed up in the Nextcloud site directory specifically, maybe someone else can explain what recent developments might have led to this.


#4

I found that file showed up after I used the Audio Player app. But that might have been a coincidence.


#5

Terminal: sudo -i nautilus (be very careful) browsed to nextcloud installation,
view: show hidden files, selected .rnd and moved to trash
update now installs just fine.


#6

Today I updated to 14.0.4. I hoped the issues would have been solved. Unfortunately I also got the “The following extra files have been found * .rnd”. I deleted the .md file in de /var/www/nextcloud directory and restarted the update. Now the updated installed okay.

Now I get the warning " De “Referrer-Policy” HTTP header is niet ingesteld op “no-referrer”, “no-referrer-when-downgrade”, “strict-origin”, “strict-origin-when-cross-origin” of “same-origin”. Hierdoor kan verwijzingsinformatie uitlekken. Zie de W3C aanbeveling :arrow_upper_right:." again. This also happened when updating to 14.0.3. I already edited the “/etc/apache2/sites-available/nextcloud-le-ssl.conf” to have the extra lines as follows:

<IfModule mod_headers.c>
Header always set Strict-Transport-Security "max-age=15552000; includeSubDo$
Header always set Referrer-Policy no-referrer
</IfModule>

I am wondering what to change now.

In the overview, logged in as administrator I now see that the update is done but still requires update:

NextCloud: 14.0.4
Er is een nieuwe versie beschikbaar: Nextcloud 14.0.4
Alle apps hebben een update voor deze versie beschikbaar

I have updated my Ubuntu 18.04.01 LTS installation on my home server and reboot ofcourse. There is no extra software on the server, I only run Samba on it. This is the first time I have issues with updating. Is it possible to get some help with this?
Thanks, Cees

I am not sure what to do now.


#7

Issues solved:
Login logout updated the version indocator
With 14.0.3 the last sebtence was as mentioned. The correct sentence now for referrer:
Header set Referrer-Policy “no-referrer”


#8

Hello,
AP does not use any random number creation. I would not know how the .rnd should be created by AP in this case