Trying to update from 27.1.4 to 27.1.5 resulted in webpage telling "Update in process."

Nextcloud version (eg, 20.0.5): 27.1.4
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
PHP version (eg, 7.4): 8.1

I tried to update from 27.1.4 to 27.1.5 with web-updater but I had some issues.
There were a few timeouts and I retried several times.
Last thing was: “Removing old files” failed.
I was a little bit pissed off so I went to bed. Now I wanted to retry it and reloaded the page.
Webpage tells me “Update in process.”, that’s why I landed here

I tried php /var/www/nextcloud/updater/updater.phar which gave me

Nextcloud Updater - version: v27.1.0rc3-15-gfa7af53

Step 6 is currently in process. Please call this command later.

Then I wanted to try out php occ maintenance:repair but apparently file occ is missing now.

While updating there is always the step “Creating Backup”, how can I restore this backup?

Best regards

Try this:
Delete (or move) your $datadirectory/updater-$instanceid/.step* file(s) and start update again.

Much and good luck,

Seems like I’m out of luck

user@domain  ~  /opt/plesk/php/8.1/bin/php /var/www/vhosts/
Nextcloud Updater - version: v27.1.0rc3-15-gfa7af53

Current version is 27.1.4.

Update to Nextcloud 27.1.5 available. (channel: "stable")
Following file will be downloaded automatically:
Open changelog ↗

Steps that will be executed:
[ ] Check for expected files
[ ] Check for write permissions
[ ] Create backup
[ ] Downloading
[ ] Verify integrity
[ ] Extracting
[ ] Enable maintenance mode
[ ] Replace entry points
[ ] Delete old files
[ ] Move new files in place
[ ] Done

Start update? [y/N] y

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[✔] Check for expected files
[✔] Check for write permissions
[✔] Create backup
[✔] Downloading
[✔] Verify integrity
[ ] Extracting ...PHP Warning:  require(/var/www/vhosts/ Failed to open stream: No such file or directory in phar:///var/www/vhosts/ on line 677
PHP Fatal error:  Uncaught Error: Failed opening required '/var/www/vhosts/' (include_path='.:/opt/plesk/php/8.1/share/pear') in phar:///var/www/vhosts/
Stack trace:
#0 phar:///var/www/vhosts/ NC\Updater\Updater->getVersionByVersionFile()
#1 phar:///var/www/vhosts/ NC\Updater\Updater->extractDownload()
#2 phar:///var/www/vhosts/ NC\Updater\UpdateCommand->executeStep()
#3 phar:///var/www/vhosts/ NC\Updater\UpdateCommand->execute()
#4 phar:///var/www/vhosts/ Symfony\Component\Console\Command\Command->run()
#5 phar:///var/www/vhosts/ Symfony\Component\Console\Application->doRunCommand()
#6 phar:///var/www/vhosts/ Symfony\Component\Console\Application->doRun()
#7 phar:///var/www/vhosts/ Symfony\Component\Console\Application->run()
#8 /var/www/vhosts/ require('...')
#9 {main}
  thrown in phar:///var/www/vhosts/ on line 677

Is there anything else I can try?

I copied back all files from $datadirectory/updater-$instanceid/backups/nextcloud- to /var/www/vhosts/ and started the update again and it seems like it worked but how can I make sure everything is as it should be?

That is good, because it was searching for your version.php!

If the update has been completed and the upgrade worked, you can assume that everything worked. If anything went wrong, you’ll be the first to notice it :wink:


Sadly it does not look good. All apps don’t start

They are installed but this also does not look right.

Same here

Is this even repairable?

Yes, if you made a full backup before you started your update, then revert everything back to that backup.

Please don’t tell that you did an update attempt without creating a full backup first! Then this will be the lesson you have to learn.

Look, if all apps are still in the apps folder.

Much and good luck,

Config was saved and data folder is outside of installation directory.
My problem is, my database backup stopped working several weeks ago and I did not notice.

Assuming that the database is not corrupted, can’t I reinstall the latest version?
If the db is corrupted, I’m screwed, I know.

Best regards

I kept only the config folder and used the latest version I installed.
After that I had to deactivate every app (because they weren’t there anymore) and had to reinstall them.
It seems like the instance is now working properly again.

Thanks for the help!

Best regards

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.