Translation of e.g. "New document" and "New spreadsheet"-entries are not translated

Nextcloud version: 24.0.4
Operating system and version: Debian 11.4
Nginx version: 1.18.0
PHP version: 7.4

The issue I’m facing is that the entries dropped down from the plus sign button displayed under the files tab, are only partly translated. While the “New folder” and “New text file” entries are correctly translated, the following entries are not.

Steps to replicate it:

  • Setup Nextcloud 24.0.4 with PHP 7.4 and Nginx
  • Set up an external server running CODE for Nextcloud to use, with only the Danish directory available for spellchecking.
  • Set force_language and force_locale to da and DK respectively.
  • Install the Nextcloud Office app (richdocuments) and set it up to use external CODE server.
  • Press the plus sign button under files tab.


I’m not sure whether it has something to do with it, but I’ve located danish translations [1] [2] in the source code of the richdocuments app. Here, it appears that the entries are translated correctly. My initial thought of why it may be caused by the richdocuments app, is because “New document, New spreadsheet etc.”-entries are added to the menu after installing the app.

I’ve consulted the richdocuments documentation without luck. I’ve investigated whether there is an app setting to be configured though occ. Searched the web without luck and trawled the administration settings panel.

I don’t know whether this function is supported, but if it is, I’d appreciate if someone could point me in the right direction. Maybe I’m overlooking something simple?

Thank you.

My config.php:

$CONFIG = array (
  'instanceid' => 'redacted',
  'passwordsalt' => 'redacted',
  'secret' => 'redacted',
  'trusted_domains' =>
  array (
    0 => '',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'redacted',
  'dbhost' => 'redacted:redacted',
  'dbport' => '',
  'dbtableprefix' => 'redacted',
  'mysql.utf8mb4' => true,
  'dbuser' => 'redacted',
  'dbpassword' => 'redacted',
  'installed' => true,
  'mail_from_address' => 'redacted',
  'mail_smtpmode' => 'redacted',
  'mail_sendmailmode' => 'redacted',
  'mail_domain' => 'redacted',
  'mail_smtphost' => 'redacted',
  'mail_smtpport' => 'redacted',
  'default_phone_region' => 'DK',
  'force_language' => 'da',
  'force_locale' => 'DK',
  'profile.enabled' => false,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'redacted',
    'port' => redacted,
    'timeout' => redacted,
  'enabledPreviewProviders' =>
  array (
    0 => 'OC\\Preview\\PNG',
    1 => 'OC\\Preview\\JPEG',
    2 => 'OC\\Preview\\GIF',
  'maintenance' => false,

Hello @augke ,

the answer here is very simple: These strings are untranslated to danish.

We use Transifex for translation and I just did a global search.
The links you provided are not the strings of the menu because they contain “odt”. There are strings at Transifex without the extension and they belong to the menu.

You can easily join us at Transifex and add the missing translations. Therefor please read Translation knowledge (valid for the entire Nextcloud project) - Wiki