Timeout while trying to connect to Nextcloud

Hello everyone,

I installed Nextcloud for the first time, the installation process has been successful and I’m able to access to the GUI thru my browser. Now I’m using the Windows Nextcloud Connection Wizard and I’m getting a timeout error (see screenshot). Does anybody know what could be the reason of this error? I already added my IP to the config.php file, under trusted domains but I’m still having the same issue.

Thanks in advance,

Are you using http or https. Only the former worked for me.

I have the same problem. My Nextcloud installation is https-only so no luck on the http path. Incidentally, the Owncloud client works fine. I’m at 10.0.5, so will try the client again when MIAB upgrades.

Nextcloud responds fine to the request when you point a browser at it, so something must be broken in the client…

{“installed”:true,“maintenance”:false,“version”:“9.1.5.2”,“versionstring”:“10.0.5”,“edition”:""}

i’m using the https also and can’t connect in window 10. Any idea or suggestion? and how the code to implement it? please advice

mine status.php is:

{“installed”:true,“maintenance”:false,“needsDbUpgrade”:false,“version”:“12.0.3.3”,“versionstring”:“12.0.3”,“edition”:"",“productname”:“VCLOUD Services - MyCloud Storage”}

I am having the exact same problem, even with http.

I run Nextcloud 12 on a raspberry pi in my wifi network, and I can access it via browser just fine. But the desktop client fails with the timeout message. I’m on Ubuntu 17.0.4 Gnome. The client is netxtcloudclient version 2.2.4.5 from Snapcraft.

The Nextcloud client on my Mac OS X on the other hand works fine with the same Nextcloud instance.

I filed a bug report: https://github.com/nextcloud/client/issues/12

Update from my side: I just found that while entering the internal hostname, in my case “raspberrypi2”, does not work, as shown in my comment above, the IP address (IPv4) instead (in my case 192.168.178.39) works just fine.

When I do a “ping raspberrypi2” from my machine, I get this:

PING raspberrypi2(2003:c1:13cb:4c00:e41d:2f49:2c72:e8a8 (2003:c1:13cb:4c00:e41d:2f49:2c72:e8a8)) 56 data bytes

Maybe it’s a problem with the IPv6 and that it’s resolved like that.

On the other hand, when I use the external hostname (like www.mydomain.com) that points to the very same raspberry pi via DynDNS, the connection works fine with the sync client as well. When I ping that domain, I get an IPv4 address back.

FYI

Make ‘timeout for http requests’ a configurable item #18103

:nerd_face:

Happy hacking.
:sunflower: