This Nextcloud instance is currently in maintenance mode

I’m running the Nextcloud Box with the Raspberry Pi in it. My guess is the update to 15 is being pushed out because today I found my desktop client greyed out and going to the web page I see:

This Nextcloud instance is currently in maintenance mode, which may take a while.

That was about 4 hours ago. I’m not sure how long I ought to wait before doing something like rebooting the system. I have to look at the actual system so seldom I’ll have to look up my password I think.

I haven’t seen a reply yet so I’ve been trying things.

One was running the command “sudo nextcloud.occ maintenance:mode --off”

This echoes a warning that comes up in red when I type “sudo nextcloud.occ upgrade” concerning updatenotification. I now see this message when I go to the web interface:

“The files of the app (updatenotification) were not replaced correctly. Make sure it is a version compatible with the server.”

I have no idea what I ought to be doing at this point.

Me too, same thing on RPi Box
Haven’t tried anything yet

The message in red that comes up when I try command line upgrade is:

“UnexpectedValueException: The files of the app “updatenotification” were not correctly replaced before running the update
Update failed”

Well, I may have messed up big time here. I tried “sudo snap revert nextcloud”

This has a good result, which is the desktop sync clients are working again, because I just got files that I dropped into a folder a work on my home machine.

This has a bad result, the web interface is totally messed up.

Yep, files I put in a sync folder on one computer are showing up on my other machine.

Totally hosed the web interface though.

I updated Rpi via SSH and rebooted - no change

Then I did “sudo nextcloud.occ maintenance:mode --off”
Got same error in browser," Error The files of the app (updatenotification) were not replaced correctly. Make sure it is a version compatible with the server."
Edit: also returned the following in SSH terminal:
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Maintenance mode disabled

Tried, “sudo snap refresh nextcloud” but got “snap “nextcloud” has no updates available”

There is a message on RPi CLI, “New release ‘18.04.1 LTS’ available. Run ‘do-release-upgrade’ to upgrade to it.” but not sure how that could be relevant.

Now pausing for thought :slight_smile:

Interesting, I tried that snap refresh command and I’m back to maintenance mode and no client response.

The revert command that messed up my web interface reported it had gone back to version 13. The refresh command says I’m a “nextcloud 14.0.5snap1”

Not sure which I prefer, partly working, or back to my original issue.

1 Like

Same issue here on Nextcloud Box. Standing By. Only interesting thing discovered is the result of running:
sudo nextcloud.occ status

Produced:
ERROR: ld.so: object ‘/usr/lib/arm-linux-gnueabihf/libarmmem.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
The current PHP memory limit is below the recommended value of 512MB.
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade

  • installed: true
  • version: 14.0.5.2
  • versionstring: 14.0.5
  • edition:

Anybody had luck backing up Nextcloud Box…

Solved ? Here is what I just tried and it seems to be working…

=> Turned off maintenance mode.
sudo nextcloud.occ maintenance:mode --off

=> Reloaded Nextcloud Web Interface, recieved the following.
The files of the app (updatenotification) were not replaced correctly. Make sure it is a version compatible with the server.

=> Disabled updatenotification app
sudo nextcloud.occ app:disable updatenotification

=> Reloaded Web page. It reloaded with the following -
Nextcloud will be updated to version 14.0.5
These apps will be updated:

Activity (activity)
Auditing / Logging (admin_audit)
Comments (comments)
WebDAV (dav)
Default encryption module (encryption)
Federated file sharing (federatedfilesharing)
Federation (federation)
Files (files)
External storage support (files_external)
PDF viewer (files_pdfviewer)
File sharing (files_sharing)
Text editor (files_texteditor)
Deleted files (files_trashbin)
Versions (files_versions)
Video player (files_videoplayer)
First run wizard (firstrunwizard)
Gallery (gallery)
Lookup Server Connector (lookup_server_connector)
Notifications (notifications)
OAuth 2.0 (oauth2)
Password policy (password_policy)
Provisioning API (provisioning_api)
Monitoring (serverinfo)
Share by mail (sharebymail)
Usage survey (survey_client)
Collaborative tags (systemtags)
Theming (theming)
Two factor backup codes (twofactor_backupcodes)
Files workflow engine (workflowengine)

Please make sure that the database, the config folder and the data folder have been backed up before proceeding.
To avoid timeouts with larger installations, you can instead run the following command from your installation directory:

./occ upgrade

=> Hit the Start update Button
It updated

Desktop sync Icon greened up

Logged in on Web page

I have 2FA activated it did not ask for 2FA code.

Everything seems to work.

Yes!
Dez, Thank you!
Followed your instructions, and exactly the same happened for meat all stages.
All working on the web interface now :smile:
I havent set up the client yet, but will report back in a mo to confirm if that works too - I’m sure it will

Updated 2FA (and other) app. Also had to enable it after update. It now works.

client works :slight_smile:

Yes, that procedure seems to work. Both the desktop clients and web interface are working.

2 posts were split to a new topic: Forgot password to login via SSH