[There is no plugin available to display this file type] after click [edit]

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 29.0.5): Nextcloud Hub 8 (29.0.1)
Operating system and version (eg, Ubuntu 29.04): Ubuntu 22.04.4 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.52 (Ubuntu)
PHP version (eg, 8.3): PHP 8.1.2

The issue you are facing:

Hello, I set up Nextcloud for the first time.
I downloaded setup-nextcloud.php(Nextcloud Setup) and installed.
I was able to upload images, and it seems to be working fine, but I can’t edit the images.
When I click(enlarge) an image and click [edit], it returns to the image list page. At this point, if I click on the image, it says [There is no plugin available to display this file type].

Steps to replicate it:

  1. Access All files > Photos
    URL: https://mysitename/index.php/apps/files/files/12?dir=/Photos

  2. Click an image and click edit
    URL: https://mysitename/index.php/apps/files/files/608?dir=/Photos&openfile=true

  3. It returns to the image list page without anything happening
    URL: https://mysitename/index.php/apps/files/files/608?dir=/Photos&openfile=true

  4. Click an image, it says [There is no plugin available to display this file type]

  5. If I reload the page, this error is resolved.

I tried setting the logs of Apache2, PHP-FPM, and Nextcloud to debug mode, but nothing is being output.
If you have any information, please let me know. Thank you.

Just to be on the safe side: Have you looked at Nextcloud’s own log? It is called nextcloud.log and is located in the data folder. If you do not know where this folder is located: See datadirectory in your config.php.

Another thought: According to the source code, this error message appears if no compatible MIME type is sent. This may indicate an incorrect web server configuration.

1 Like

The OP is not alone.

I encountered this error after upgrading (via the web updater) from 29.0.1 to 29.0.2. Running on Debian Bookworm. Accessing the server via a web browser.

I experience the exact same problem the original poster has described. When I open an image and select the edit button the server returns to the list of images. At this time if I click on any image I will see this error pop up. After I refresh the page via the browser (FF) refresh button I can click on any image and it will show without any error pop up.

This cycle can be repeated to no end.

I checked my nextcloud log, set to INFO, the log is empty. If I set the log to show DEBUG I get a couple of pages.

Could you expand on your idea that this is could be an incorrect web server configuration? I don’t see anything in the apache logs that is new.

Does nextcloud need additional software that wouldn’t normally be installed?

TIA

1 Like

Other post on this board about this same bug which you could have find with the search option:

There is already an Issue:


Much and good luck,
ernolf

1 Like

Thank you, mritzmann.
I tried performing operations while running ‘tail -f data/nextcloud.log’, but nothing was logged.

Thank you for the information, henrythemouse.

Thank you for the information, ernolf.
I will keep an eye on this issue.