The new standard in on-premises team collaboration: Nextcloud Hub

No you must confuse.
@frank and @jospoortvliet and @camila stopped about speaking Virtual Drive Client because…

well. after 15 minutes clicking around i still didn’t found the “build in” onlyoffice.

where is it hidden?

The name of the App is
But it’s very buggy for the moment.

I can’t personally tell you i’m not yet on NC18.

that’s the easy part. start up a virtualbox and

curl -s | /bin/bash
git clone --branch nextcloud-reloaded
cd nextcloud
./nextcloud.yml -e "nextcloud_fqdn=example.domain.tld nextcloud_webserver_type=nginx nextcloud_certificate_type=''"

i installed it. but nothing happend. maybe i f*cked up the system because i enabled the onlyoffice app before.

maybe tomorrow i give it a try again.

For OnlyOffice:

  1. Install and enable latest OnlyOffice app
  2. Install and enable document server app

That’s it.

Upgraded to official 18.0.0RC2-apache docker image, installed Community Document Server app successfully, but on trying to open a file I get:

Community document server is not supported for this instance, please setup and configure an external document server

… because what?

If I’m not mistaken if you use the OnlyOffice Document Server Community Edition the simultaneous connections is only 20 vs to you will put up your own OnlyOffice Document Server and the simultaneous connections is base on your server hardware

OnlyOffice Document Server

OnlyOffice Docement Server Community Edition

Thank You

1 Like

That’s a mystery.
That’s why i put a …
they don’t speak about that it’s very unclear.
Users are left in the Unknown with nothing.
In order to survive here, we have to become like Animals. And we have to forgot all our senses of understanding and love…
Werner Herzog.

There’s already an issue for this on Github:

After i applied the fix OnlyOffice works mostly fine on my test instance.

1 Like

Very cool to have OnlyOffice (and later hopefully LibreOffice) available by one click. Could the fulltext search become also easier to install? e.g. NC 17 need php 7.3 and Elastic Search 7.4 so it’s not so easy to install.

Same here, even with the workaround documents aren’t created, but not opened… Alas, the fix did well on the permission issue, but that’s it so far.

Undefined variable: error at /var/www/nextcloud/apps/onlyoffice/controller/settingscontroller.php#178

…very useful in my opinion.

Fulltext Search should become as easy to implement as other Apps.

It’s still not working. After changing the permission of the x2t file, there is a OCA\DocumentServer\Document\DocumentConversionException: Couldn’t create temp folder entry outputted to the error log. Opening documents with OnyOffice gets stuck at the spinning wheel with “document loading” message.

Just a BIG question: why chose OnlyOffice instead of LibreOffice?
the second supports more languages, has a cloud installation, has more features and much more installations.
Would be very glad to read the reasoning behind such basilar choice.

itˋs OnlyOffice, not OpenOffice.

Completely different thing-

I tried to install from scratch the latest version but I’m getting this error:
so I can’t make OnlyOffice work… What can I do?

tnks @anon99283430, I changed my comment

is there more information in the protocol?