The Great Nextcloud Box Topic

Do you get this?

$ netstat -a | grep 4200
tcp6       0      0 [::]:4200               [::]:*                  LISTEN

No, it returns nothing.

I’ve tried to run the snap manually, and this is what I see:

ubuntu@ubuntu-standard:~$ sudo snap run snapweb                                                                       
runtime: this CPU has no floating point hardware, so it cannot run
this GOARM=6 binary. Recompile using GOARM=5.

Aargh… yes. I did completely forget about that. Thanks for the shell output.

Snapd is broken on ARM since last week. I wasted hours trying to figure out why and trying to find a workaround and that’s one reason I didn’t push any new snaps or releases.
Any snap you install will not run.

There is a workaround if you’re interested. It works because we’re not on Ubuntu Core yet.

I logged off for a bit, sorry @oparoz

I’m not fully with you on this. If snaps don’t run then why does NC work?

Yes, a workaround would be lovely.

What?!? You’re not allowed :smiley:

It’s only new snaps that you install which gets affected, existing ones are fine.

OK, try

$ wget
$ sudo dpkg -i snap-confine_1.0.42-0ubuntu3_armhf.deb

That will replace your snap-confine with the latest version from yakkety


That did the trick. Wonderful!

1 Like

Awesome news! :slight_smile:
It’s just a shame that it affects all users who will get their box delivered today…

Sticky that bad-boy with immediate effect!

Well, I’m not sure it’s that safe to tell everyone to follow these steps. I’m hoping to get a better answer from Canonical, but it may be that we simply have to wait for the fixes to get pushed.
Trying to install new snaps is not going to break anything, but it will be frustrating for new users since new snap installation on the Box has been promoted a lot by Canonical.

Always the way :slight_smile: well it’s got me up and running for now… so I can carry on writing about it!

This is what I needed! Thank you for the help.

I’m glad it all worked out, sorry it took so long to figure it out.

oh wow, I now know why stuff started breaking on reinstalling snaps, any word on having images to reflash the card, I’ve been waiting for a reliable start over point before doing any messing around with the device, oh wait just saw your github link - so you can do a clean install with the SD card? nice!

Is anyone else suffering with a super slow interface? I’ve uploaded now around 17GB of data, 16 of that images and I could brew a tea between clicking on an image and waiting for it to load up.

Similarly log in and general navigation seems so slow. Coming from a hex-core 3.5GHz-backed container I was expecting a less snappy (see what I did there? Snappy? Har har) system, but this is like watching paint dry.

Thumbnails are also taking forever to generate.

Just followed link from website, and it drops you at Western Digitals Home Page. How does one order this ?

Thanks for bringing this to our attention! The new website shop went live and apparently there are some issues…
Will post here once the store is back online.

Yep, that’s one of the biggest problem with the Pi2 I think. Things should be much better on NC11 because thumbnails should be shared among all users of an instance.

If anybody with the a broken Box could type this and give me the results, that would help:

$ sudo journalctl -r -u snap.nextcloud.apache.service --no-pager


Never mind, I found a way to break mine :slight_smile:

Hello Olivier,
but if you are not on Ubuntu Core, what are you running ???