Task APP : hw to get my tasks on iPhone?

Hi everybody
I’m using the Task app , faboulous !! But, I’ve got an iPhone and when I use the native Iphone app Reminder to open my tasks I just see the main ones and … loose the sub tasks in nextcloud during the sync.

Does anybody know an iphone app I can use ???
Thanks a lot

well, no answer …
I tried many app but none could keep my sub tasks …
If someone , somewhere does know a app :wink:
Thanks :wink:

This post could help you finding the right iOS app:

thanks fr the answer ! I’m going there right now :slight_smile:
oups , I read it : I tried to use that GoodTask 3 app few days and it didn’t work that fine. I didn’t get my subtask as they say in the post.

Well, thanks again, and if I find st , I’ll you know !

Same problem for me.
Did anyone found a solution?

Reviving this… I recently installed NextcloudPi and was happy to find my current task manager app 2Do (for iOS) syncs well with NC, to include subtasks, start date, due date, priority, completion percentage, and even an extended “notes” field. I was already very impressed by the 2Do app, but now more so that it integrates so well with NC.

1 Like

Hi . Haven’t be there for a while … I Tried 2Do : my sub tasks appear but without hierarchical aspect … something I did wrong ?

@Lautre would be interested to hear if you found anything that works for you in the meanwhile. Not having proper subtasks on MacOS and iOS is the main reason for me not to use Tasks now…
I hope this could change…

HI
Still the same … when I’m using tasks on nextcloud, all my tasks and sub tasks are at the same level on my apps mac os and ios.

For a while, I’m using Joplin that works fine.

Not the Joplin app on nextcloud (doesn’t work … ), just Joplin Mac OS app and JOplin IOS app : on the syncho parameter , I choose Webdav , then “https://mynextcloud.com/remote.php/webdav/Jopjop” :
that creates a Jopjop folder in nextcloud and everything synchronize …

Only bad think is that I can’t get my tasks using a browser …

I just change to Monterey few days ago and no changes on MacOs tasks … :frowning: I

Jopling is really a good app to my opinion :ok_hand: https://joplinapp.org/

I’m not sure that Apple will one day make a change … and didn’t find another app (but commercial ones that for most of them, ask you to sign in … )

I know Joplin yes, but now it primarily as a note taking app. Not so much as a tasks app… Maybe I should give it a try…

For notes I rely on markdown files and obsedian

I have this same issue. 2Do app works, but subtasks are “flattened”.
I talked to the 2Do developers and accoring to them it’s an issue with the caldav implementation in nextcloud (using sabre/dav). It doesn’t saeem like something they’re expecting to fix.