Sync client cancelling operations when trying to sync a folder

Nextcloud version : 12.0.3
OS - Debian 4.9.51-1
Nginx version: nginx/1.10.3
PHP version : 5.6

Client version: Mac Nextcloud client -

The issue you are facing:
For a specific folder - I get a bunch of error (here some of the error messages were in french, I translated them back to english)

28/02/2018 12:53:09,   Notes/#twitter .txt,      Nextcloud, Operation is cancelled 
28/02/2018 12:53:09,   Notes/#twitter - decentralisation.txt,   Nextcloud, Operation is cancelled
28/02/2018 12:53:09,   Notes/#heb.txt,       Nextcloud, Error transferring https://[URL]/remote.php/dav/files/[user]/Notes/%23heb.txt - server replied: Service Temporarily Unavailable

In nginx log - no error but in nextcloud.log I get

{"reqId":"4dfKUdzw2N19O9Aopo1l","level":3,"time":"2018-02-28T11:49:06+00:00","remoteAddr":"IPREDACTED","user":"USER","app":"PHP","method":"GET","url":"\/nextcloud\/remote.php\/dav\/files\/USER\/Notes\/%23heb.txt","message":"fopen(PATHTOFILE): failed to open stream: No such file or directory at PATHTO\/nextcloud\/lib\/private\/Files\/Storage\/Local.php#277","userAgent":"Mozilla\/5.0 (Macintosh) mirall\/2.3.3 (build 84) (Nextcloud)","version":""}
{"reqId":"4dfKUdzw2N19O9Aopo1l","level":4,"time":"2018-02-28T11:49:06+00:00","remoteAddr":"IPREDACTED","user":"USER","app":"webdav","method":"GET","url":"\/nextcloud\/remote.php\/dav\/files\/USER\/Notes\/%23heb.txt","message":"Exception: {\"Exception\":\"Sabre\\\\DAV\\\\Exception\\\\ServiceUnavailable\",\"Message\":\"Could not open file\",\"Code\":0,\"Trace\":\"#0 WEBPATH\\\/nextcloud\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/CorePlugin.php(85): OCA\\\\DAV\\\\Connector\\\\Sabre\\\\File->get()\\n#1 [internal function]: Sabre\\\\DAV\\\\CorePlugin->httpGet(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#2 \\\/vWEBPATHT\\\/nextcloud\\\/3rdparty\\\/sabre\\\/event\\\/lib\\\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\\n#3 ... (Nextcloud)","version":""}

so it seems like webdav server cannot find the files but on the web view I can see them, I can download them and all seems to be good.

Also I downloaded the whole content of this directory and copied it locally then resynchronized it and it worked like a charm.

So I dunno what is the problem but I’d love some insights…

Hi jsavalle

It could be the brute-force feature, that blocks your client from syncing with the server. Maybe you should try this: How can i unblock an IP (blocked through brute force detection)?

Or it could also be a file lock or cache problem, if this is the case try this: File is locked - how to unlock

I also faced several sync problems, I could always fix them with a manual workaround:

  1. occ ‘files:scan --all’
  2. occ ‘files:cleanup’
  3. if already solved stop where, if not proceed with step 4
  4. occ ‘maintenance:mode --on’
  5. sign in to your mysql db and run: “delete from oc_file_locks where 1;”
  6. occ ‘maintenance:mode --off’

Good luck, Cheers zisuu

1 Like