Stuck on update process. Step 5 is currently in process. Please reload this page later

Thank you! My NextCloud is hosted at all-inkl, too. I did:

  1. set php memory limit to 512M by adding to .htaccess file:
    'php_value memory_limit 512M`
  2. delete file .step in data/updater-…
  3. retry update => everything was fine

When running updater via CLI, you can raise the PHP Memory limit by setting a CLI Parameter like this:

php -d memory_limit=512M upgrader.phar

Hello Gentlemen,
I have web based nextcloud and I can’t increase memory in my hosting panel, what then?

I’m on a synology bare metal installation (php-7.2)
I’m trying to update 19.0.6 ->20.0.4
Deleting the folder nxtcld/data/updater-oco7ek3xolkq at least makes the stuck on step 5 -error go away and let’s me restart the update-process. The process then still always stucks on step 5:


  • Verifying integrity

Parsing response failed.
Show detailed response


However, after editing the “.htcaccess” file below the “DO NOT CHANGE ANYTHING ABOVE THIS LINE” -line the instance crashes with failure 500 and nextcloud is no longer accessible.
Removing the php_value memory_limit 512M-line makes it accessible again.
Are there other measures to raise the PHP-limit (I’ve also edited the @appstore/PHP7.2/usr/local/etc/php72/cli/php.ini but to no avail).

Today I got stuck on the #5 issues as well when trying to update from version 19 to 20.
I got it to work with a combinations of the suggestions in this thread:

  • Removed the .step file in the data/updater-xxxxxx folder

This got me able to retry the update, but kept giving the #5 error. Then I:

  • Removed the old V20 download in the data directory

  • Changed the php-memory limit to 512M under resource limits in /etc/php/7.2/cli/php.ini

  • Changed the php-memory limit to 512M under resource limits in /etc/php/7.2/fpm/php.ini

  • Added the php_value memory_limit 512M`in the .htaccess file in the nextcloud installation folder (/var/www/html/nextcloud for me):

  • On the command line restarted service: systemctl restart php7.2-fpm

With these changes also the error nextcloud threw regarding my memory limit was gone. I’ m not completely sure which of the last steps did the trick for me, my best guess is that is was the fpm setting. Setting the cli/php/ini setting back to -1 did not bring back the php memory error.

Hope this helps to those who did not yet managed to get the update running

Hi,
I have a similar issue, stuck of the step 5 of the upgrade…
I can not change toe mem limit of php, since it is only a rented webspace.
I don’t have any .step files in any nexcloud directories.

Any other suggestions please?
Thx!

Thanks for your proposal, was the only way to leave the blocking state. :+1: Top

I have the same situation as @Darkluke, one nextcloud instance is running at a rented webspace.
The maxiumum available php-memory limit is there 128M.
The web updater is downloading the nextcloud *.zip file.
If this zip file is larger than the php-memory limit (in my case > 128M) the verify process will fail and the installer stops and hang in step 5.
e.g. nextcloud-20.0.7.zip = 123MB filesize -> working :heavy_check_mark:
e.g. nextcloud-20.0.4.zip = 136MB filesize ->not working :x:

If failing you should verify the zip download yourself and then use this workaround:

@NextcloudDevelopers: If you switch from zip to tar.bz2 we will have a longer time nextcloud fun with our rented webspaces and 128M memory limit :pray:

1 Like

Thank you. Deleting the updater-xxxxx directory form the data directory did the trick. Once again, many thanks.

1 Like

This worked for me. Renaming the .step file did it. I renamed mine to “.step_old”

I did both steps and the update went well.
After that I realized that the entry in .htaccess is gone. The file seems to have been rewritten by the updater.

Regards,
Thomas

Thanks, Danfro, for your mod of the suggestion by @dshirk . Renaming the .step file worked for me on 2021-05-06 for the upgrade to 20.0.9. Replying with this in case anyone else needs it!

1 Like

Great. Glad I could help. :+1:

For everyone still stuck at this step, one more addition from my recent experience:

The update seems to stuck on the validation process of the downloaded file. Although php memory may seem to cause this failure if set too low, this is not the only cause.

I recently had this with the memory limit set to 1 GB. I tried deleting the .step file several times - without success.

What did finally work? Just waiting a day. :wink: The next day, after deleting the .step file, it went through without errors.

So my guess is, the validation process might fail because the server can not cope with the data load at certain times. Waiting some time for a less busy time can be all it needs. This would also explain why this error keeps coming up throughout releases. So the next time you are stuck there, get yourself a cup of coffee, relax and come back later. :slight_smile:

Renaming the .step to .step_old did the trick for me, I was able to update from ver 21.0.0 to 21.0.1 thank so much guys!

None of the things above helped me so here is my solution:

go into the file /var/www/nextcloud/updater/index.php and comment the lines:

    if($stepState === 'start') {
            die(
            sprintf(
                    'Step %s is currently in process. Please reload this page later.',
                    $stepNumber
                    )
            );
    }

with “//” at the beginning out.

Reload your Update-Page - done!