Stuck on Step 3 when updating from 18.0.6 to 19.0.1

I’m trying to up 19.0.1 from 18.0.6 (running in unraid) and I get presented with this screen when I click on the open updater button. I’ve waited and tried to refresh the screen multiple times but it’s been stuck at this point for the last 3 days now. Any ideas what I can do?

Many thanks as always guys.


step 3 screen

Hi @Ray_Fielding

do you have access (on file level) to your installation? If yes, please check if there is a file at /path/to/nextcloud/data/updater-<randomstring>/.step. Here, <randomstring> is a random combination of numbers and characters.

If you find this .step file, delete it and open your updater page again.



Thanks simonpsa - it worked a treat!

Same here, but in version 20. I dnt have this .step into www/nextcloud/data
Any solution?
Thanks in advance!

.step file is a hidden file, so just go to
then remove the .step file
rm .step

if the data folder is symbolic link to another location, we need to go to the symbolic link location to delete this file