Update stuck: Step 3 is currently in process. Please reload this page later

I have a Nextcloud installation on shared hosting.
I have never had any problems updating (from v10 up to v18.0.7)
Now when trying to update to 19.0.1 I have got stuck at step 3 with the following message:

Step 3 is currently in process. Please reload this page later.

Any help resolving this issue would be much appreciated.

hey @duncanmid

sometimes it’s a great idea to first searching the forum before posting…
as there are several solutions for your problem.

like this one

if this one won’t help pls use the built-in search function yourself with keywords like update step 3or such

and don’t forget to re-link the solution that worked for you as an answer to this thread.

thanks and good luck

1 Like

Hi @JimmyKater thanks this solution worked: Stuck on Step 3 when updating from 18.0.6 to 19.0.1

1 Like

Hello @JimmyKater again,

I’ve an other issue have during the 19.0.2 to 19.0.3 update. I’m blocked since hours in the step 3 also.
I’ve cheked the file .step you mention but I don’t have it.
In nextcloud/data I don’t have the updater folder. It is in nextcloud directly but it contains only 2 files: index.php & updater.phar

Many thanks for your help and patience. I’m quite new on Nextcloud and linux environement.

PS: Nextcloud is installed on my own Synology NAS 918+

your NC is in maintenance mode still? try diabling it via the commandline.

the download the referring file directly from nextcloud and run it via the commandline as well. manual would know how to do that, exactly :slight_smile:


Before reinstalling in manual mode, i would like to do it automatically. What is the commandline to stop the current maintenance ?

oh come on, @PascalB the forum is packed full with that command. And the manual knows it as well…

sudo -u www-data php occ maintenance:mode --off

or find the referring line in config.php and set it to false

1 Like

OK. At the end I did everything manualy and it is running smothly. Thinks are little bit different on Synology NAS but I succeed. :ok_hand:
Many thanks for your patience @JimmyKater :pray:

1 Like

On my system deleting the .step file was the solution. Thanks for the tip.

1 Like

Thank you. This has helped me a lot!