STRATO Server Nextcloud 17 Konfig anpassen nach Update

Hallo, wer hat Erfahrungen mit der Konfiguration der Einstellungen auf einem Strato-Managed-Server?
Die Installation und das automatische Update waren kein Problem. Nun geht es fĂŒr mich an die Grenze.
Es gibt da eine Liste die ich abarbeiten sollte. Leider fehlt mir eine Idee wie ich die Anpassungen machen soll.

  • Die PHP-Speichergrenze liegt unterhalb des empfohlenen Wertes von 512MB.

  • MySQL wird als Datenbank verwendet, unterstĂŒtzt jedoch keine 4-Byte-Zeichen. Um beispielsweise 4-Byte-Zeichen (wie Emojis) ohne Probleme mit Dateinamen oder Kommentaren verarbeiten zu können, wird empfohlen, die 4-Byte-UnterstĂŒtzung in MySQL zu aktivieren. FĂŒr weitere Details lesen bitte die Dokumentationsseite hierzu.

  • Der „X-Frame-Options“-HTTP-Header ist nicht so konfiguriert, dass er „SAMEORIGIN“ entspricht. Dies ist ein potentielles Sicherheitsrisiko und es wird empfohlen, diese Einstellung zu Ă€ndern.

  • Der “Strict-Transport-Security” HTTP-Header ist nicht auf mindestens “15552000” Sekunden eingestellt. FĂŒr mehr Sicherheit wird das Aktivieren von HSTS empfohlen

  • Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der LeistungsfĂ€higkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen findest Du in der Dokumentation.

  • In der Datenbank fehlen einige Indizes. Auf Grund der Tatsache, dass das HinzufĂŒgen von Indizes in großen Tabellen einige Zeit in Anspruch nehmen kann, wurden diese nicht automatisch erzeugt. Durch das AusfĂŒhren von “occ db:add-missing-indices” können die fehlenden Indizes manuell hinzugefĂŒgt werden, wĂ€hrend die Instanz weiter lĂ€uft. Nachdem die Indizes hinzugefĂŒgt wurden, sind Anfragen auf die Tabellen normalerweise schneller.

    • Fehlender Index “share_with_index” in der Tabelle “oc_share”.
    • Fehlender Index “parent_index” in der Tabelle “oc_share”.
    • Fehlender Index “owner_index” in der Tabelle “oc_share”.
    • Fehlender Index “initiator_index” in der Tabelle “oc_share”.
    • Fehlender Index “fs_mtime” in der Tabelle “oc_filecache”.
    • Fehlender Index “twofactor_providers_uid” in der Tabelle “oc_twofactor_providers”.
    • Fehlender Index “version” in der Tabelle “oc_whats_new”.
    • Fehlender Index “cards_abid” in der Tabelle “oc_cards”.
    • Fehlender Index “cards_prop_abid” in der Tabelle “oc_cards_properties”.
  • Dieser Installation fehlen einige empfohlene PHP-Module. FĂŒr bessere Leistung und bessere KompatibilitĂ€t wird dringend empfohlen, diese zu installieren.
    intlimagick

  • Bei einigen Spalten in der Datenbank fehlt eine Konvertierung in big int. Aufgrund der Tatsache, dass das Ändern von Spaltentypen bei großen Tabellen einige Zeit dauern kann, wurden sie nicht automatisch geĂ€ndert. Durch AusfĂŒhren von “occ db:convert-filecache-bigint” können diese ausstehenden Änderungen manuell ĂŒbernommen werden. Diese Operation muss ausgefĂŒhrt werden, wĂ€hrend die Instanz offline ist. Weitere Einzelheiten findest Du auf der zugehörigen Dokumentationsseite.

    • activity.activity_id
    • activity.object_id
    • activity_mq.mail_id
    • filecache.fileid
    • filecache.storage
    • filecache.parent
    • filecache.mimetype
    • filecache.mimepart
    • filecache.mtime
    • filecache.storage_mtime
    • mimetypes.id
    • storages.numeric_id

<<<<<

Hi, hast Du root-Zugriff auf den managed server bei Strato? Also, die Frage, ob Du die mysql- und PHP-Version und Konfiguration frei wÀhlen, Àndern und beeinflussen kannst. Ich habe dort nur meinen Dyndns-Eintrag auf meine Domain gelegt.

Wenn Du vollen Zugriff hast, kann ich Dir mit den genannten Punkten helfen, denn die habe ich in den letzten Monaten auch alle abgearbeitet. Wenn Du keinen vollen Zugriff auf php und mysql hast, wird es bei Strato schwierig.

Beste GrĂŒĂŸe
DD

Hallo, Rootzugriff hat man da nicht. Die Einstellung >>> Die PHP-Speichergrenze liegt unterhalb des empfohlenen Wertes von 512MB. <<< konnte ich anpassen. Ich habe mit einem Strato-Mitarbeiter gesprochen, aber individuelle Konfigurationen im Rootbereich sind, laut seiner Aussage, nicht möglich.

Dann kannst Du leider nicht viel machen und mĂŒsstest Dich auf Strato verlassen.
Du kannst immer nur die PHP-Version hochziehen und die Datenbank in eine aktuellere Version kopieren.

Und natĂŒrlich alles, was Du an den Config- und PHP-Dateien in NC anpassen kannst.
Da bleibt dann leider nicht mehr allzu viel auf Deiner Liste ĂŒbrig.

Auch ĂŒbrigens ein Grund, warum ich zwar meine Homepages mit WordPress bei Strato liegen habe, aber die NextCloud bei mir zuhause auf einem Server beheimatet habe.

Wie Du das Problem “Strict-Transport-Security” HTTP-Header beheben kannst, habe ich hier aufgeschrieben: https://help.nextcloud.com/t/der-strict-transport-security-http-header-ist-nicht-auf-mindestens-15552000-sekunden-eingestellt/62408/9?u=doctordre.

Ich hoffe, es hilft Dir trotzdem weiter.

Hallo doctordre,

das habe ich befĂŒrchtet Da werde ich mir mit einer anderen Lösung wohl behelfen mĂŒssen.

Danke fĂŒr den Link.

Mit bestem Gruß J_K

Spannend - genau die von Dir gelöste PHP-Speichergrenze ist der Punkt, an dem ich immer noch scheitere. Ich habe meine NC auch bei Strato auf Hosted Webspace, aber genau das Problem PHP-Speichergrenze bekomme ich nicht gelöst. Hast Du das selber einstellen können (wie?) oder hat das der Support gemacht?

Die HTTP-Header Probleme liegen nicht daran, dass sie fehlen, sondern dass sie gedoppelt sind. Habe ich auch erst eben gerade gefunden, nachdem ich das monatelang immer wieder gesucht habe. Identische EintrĂ€ge stehen wohl in der Regel auch in der htaccess des Webservers, so dass die nochmalige AuffĂŒhrung in der htacces im Nextcloud-Verzeichnis eine Dopplung bewirkt und dadurch den Fehler anzeigt. Ich habe die betreffenden Zeilen nun in der Nextcloud-htaccess auskommentiert (# an den Zeilenanfang gesetzt), und schwupp, Fehler weg.

Bei Strato haben wir zwar keinen Root-Zugriff, aber alle Dinge, die mit occ-Befehlen gesteuert werden können, sind auch in der Nextcloud direkt möglich, wenn man die App occweb in der Nextcloud installiert (zu finden eben bei den Apps). Damit lasen sich die dann die occ-Befehle problemlos und ohne root ausfĂŒhren


“occ db:convert-filecache-bigint” können diese ausstehenden Änderungen manuell ĂŒbernommen werden. Diese Operation muss ausgefĂŒhrt werden, wĂ€hrend die Instanz offline ist.
Das ist etwas trickreicher. An die occweb App kommt man offline ja nicht ran, daher: den Befehl in occweb starten und dann die Instanz in der Config auf maintance=true setzen (natĂŒrlich auch speichern
). Alles natĂŒrlich auf eigenes Risiko, lange genug warten (hĂ€ngt halt von der Datenmenge in der Cloud ab), und dann nach Wartezeit maintance wieder auf true setzen, damit die Nextcloud wieder erreichbar ist. Hat bei mir eben so funktioniert


PHP-OPcache, PHP-OPcache und imagick sind ja nur Hinweise und damit vernachlÀssigbar


Aber die Lösung fĂŒr “Die PHP-Speichergrenze liegt unterhalb des empfohlenen Wertes von 512MB.” wĂŒrde mich echt interessieren


Ich hab es geschafft, alle Fehlermeldungen, außer:
Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der LeistungsfÀhigkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen findest Du in der Dokumentation.
gelöst zu bekommen.

Einfach eine php.ini im Nextcloud-Verzeichnis erstellen. Strato schreibt in der Hilfe leider, dass wenn der PHP-Booster aktiviert ist, nur die php.ini im obersten Verzeichnis gelesen wird und die Einstellungen dann fĂŒr alle Unterverzeichnisse gelten. Das stimmt aber wohl nicht.

Bei mir steht nun folgendes in der php.ini:

memory_limit=512M
upload_max_filesize = 200M
opcache.enable=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

“upload_max_filesize” kannst du anpassen, wie du das brauchst.

Hier wird noch eine Möglichkeit beschrieben, die occ Befehle per SSH auszufĂŒhren:

Wie hast Du die Speichergrenze angepasst? WÀre nett wenn Du Deine Erfahrungen in einer Weise teilen könntest, dass man sie nachvollziehen kann. Schön, dass Du mitteilst, was jetzt in der php.ini steht, wo aber finde ich die php.ini? Habe per filzilla das ganze nextcloud Installationsverzeichnis durchsucht - nada