Static IP funktioniert nicht (dhcpcd.conf)

Ich habe ein “jungräuliches” NextcloudPi auf meinem Raspberry 3B aufgesetzt (aktueller Download von https://ownyourbits.com/downloads) und möchte dieses mit einer statischen IP betreiben. Nach Eintrag in die dhcpcd.conf ist die eth0 nicht mehr da (nur noch der lo-Eintrag bei ifconfig). In der dhcpcd habe ich (wie in diversen Fohren beschrieben) folgende Zeilen ergänzt:

interface eth0
static ip_address=192.168.2.34/24
static routers=192.168.2.1
static domain_name_servers=192.168.2.1

Leider auch nach Reboot kein Erfolg

moin @Seiler1983

ich glaube nicht, dass das ein nc-problem ist sondern ein setupproblem mit deinem betriebssystem.

das sieht mir zb seltsam aus. versuchs doch bitte mal ohne die /24 hintendran

Die /24 ist die neuere Schreibweise für die Subnetmask und laut diverser anderer Foren hier so gefordert. Die 24 entspricht der “alten” 255.255.255.0

Einen identischen Eintrag in die dhcpcd.conf kann ich auch durch da ncp web-gui machen lassen:
Menüpunkt nc-static-ip
Macht keinen Unterschied.

Da ich ein fertiges Image verwende sehe ich das sehr wohl als nc Problem, besser gesagt als ncp Problem.
Ich habe auch einen Pi mit “normalem” Stretch laufen, da klappt die Config problemlos.

hmja, wusste ich nicht.

nun… bietet nicht ncp eine möglichkeit, eine feste interne ip zu vergeben? mir war fast so… hast du das auch probiert?

vlg
jimmy

Hb ich über die weboberfläche mal probiert und damit meinem Pi3b+ zerschossen

Hab mich nochmal mit der Thematik auseinandergesetzt und die Lösung gefunden:

  • mit sudo service dhcpcd status nochmal alles anzeigen lassen. Hier kam auch schon der Hinweis dass etwas nicht passt und die Aufforderung zu sudo systemctl daemon-reload
  • reload ausgeführt und nochmal den status angeschaut: siehe da - Fehler weg
  • jetzt in der dhcpcd.conf wie beschrieben die daten für static eingetragen. Danach reboot und es läuft mit der statischen IP