Standalone Collabora Configuration problem with Nextcloud Office

I have nextcloud and collabora installed using docker compose with the popular nginx proxy in front of boat.

I am pretty sure I have the collabora server (not the built in app - it is in seperate container with cloud.domain) working and can access the admin page, the /hosting/discovery end point and so on.

In Nextcloud, I install NextCloud Office app and go to the settings page and select to use my own server. Here, I would expect to put my collabora domain name into the URL setting and save. If I do that, I get a green message that the server is reachable and to values:

URL used by the browser:
Nextcloud URL used by Collabora: *

Even if I have clicked save, if I navigate away from the page and then come back, the setting is not saved.

If I try to open a document it does not load and just spins. Looking at the request, I am seeing a 404 on this url:

I think the problem is not with collabora - but with the nextcloud office failing to save settings and perhaps retaining something from a previous install of the app version of Collabora.

Any ideas why I cannot set and save the correct location of Collabora?

Many thanks

hi @richp10 welcome to the forum :handshake:

Please use the search - lot of issues have been discussed already.

  1. Start with Collabora integration guide Describe the issues you see there.
  2. the URL you mentioned ../custom_apps/richdocumentscode/proxy.php?req= belongs to the built-in CODE, stand-alone component usually use a public hostname.

If there are specific issues or error please describe what you tried so far and which problems you hit!

Hi there - many thanks for that. I had spent ages searching already, but had not seen your excellent wiki, within which was the solution.

The problem was that the Next Office configuration page is not working correctly - it simply does not save and sticks on the wrong values (pointing to the server as if the app is installed, not stand alone).

So the solution was your suggestion of configuring using the command line - this worked first time and perfectly.

So I either have a problem with the configuration of my next cloud itself - messing up it’s ability to save settings (maybe cache issue, I should have tried restarting cache) - or there is a bug in the latest release.

Not sure which, but command line fixed the issue for me at this point.

Thanks again for the pointer to your guide - best source of information I have seen.



somebody reported an issue WOPI setting didn’t apply from WebUI - there was permissions issue with config files - take a look at collabora-online and maybe docker topic from last weeks…