Speichern auf externen Speicher nicht möglich

Hallo liebes Forum und liebe Spezialisten und natĂŒrlich innen :slight_smile:

Ich habe ein Problem und zwar.
Ich habe auf meinem Ubuntu Server meine Nextcloud laufen, und eine smb Freigabe
dauerhaft ĂŒber fstab gemounted. Dieses Mountpoint habe ich in meiner Nextcloud als externen Speicher eingebunden. Ich kann daten ĂŒber Windows auf die Freigabe kopieren und dann ĂŒber meine Nextcloud abspielen bzw. abrufen aber allerdings NICHT teilen, kopieren oder verschieben. Im Linux selbst habe ich zugriff auf den Ordner via Konsole und kann auch Ordner erstellen oder löschen und hab auf den Ordner dem Benutzer www-data alle rechte gegeben und den chmod auf 777 gestellt.
In der Nextcloud selbst hab ich bei der Freigabe meinen Benutzer auch unter “verfĂŒgbar fĂŒr” eingerichtet allerdings steht bei “authentifizierung” → “Keine” und ich kann dort auch nichts eintragen. Die Windows Freigabe ist eingerichtet mit "Zugriff jeder, schreiben, lesen, verĂ€ndern)
In meiner Nextcloud erscheint der externe Speicher als “Lokal” ich kann darauf zugreifen aber auch keine Daten hochladen.
Finde leider auch im Netz keine Lösung, vielleicht könnt ihr mir helfen.
verzweifelte GrĂŒĂŸe
Renate

Eigentlich benutzt du somit ja gar nicht SMB/CIFS sondern local wenn ich es richtig verstanden habe.

Hast du denn den Haken gesetzt:

Verwaltung → Externer Speicher → die drei Punkte bei deiner Freigabe (
) und dort
Teilen aktivieren

Ich nutze auf einem System auch “local”.

Authentifizierung: Keine → steht bei mir auch
VerfĂŒgbar fĂŒr: da steht bei mir eine Gruppe, ordne mal eine Gruppe wie admin zu.

Wird das denn auch im persönlichen Profil unter Externer Speicher aufgefĂŒhrt? Dort wird es bei mir aufgefĂŒhrt. Aber eine Änderung ist nicht möglich.

ok jetzt hab ich es aktiviert, jetzt geht das teilen
wow echt jetzt ein haken :), Danke
Aber hochladen kann ich immer noch nichts
da scheint dann “forbidden” auf

und ja es wird beim persönlichen Profil auch aufgefĂŒhrt. was mir jetzt nur auffĂ€llt wenn ich in diesem profil auf das hĂ€ckchen rechts klicke kommt links ein rotes symbol, wenn ich aufs rote symbol klicke wird ein grĂŒner haken draus.

Gruppe Admin habe ich von haus aus schon zugeordnet. Meinen Benutzer und Admin

aja und im Logfile unter www/nextcloud/data/nextclous.log ist der letzte Eintrag von vor 4 monaten

Letzter Logeintrag von vor 4 Monaten? Entweder ein Fehler oder mal den Loglevel hochsetzen.
Logging

Teste zudem mal auf der Konsole, ob der Benutzer www-data wirklich auf den Mountpoint was speichern kann.

sudo -u www-data cp /etc/passwd /pfad/zu/mountpoint/smbcifs

oder sowas

sudo -u www-data touch /pfad/zu/mountpoint/smbcifs/leeredatei.txt

Wenn das nicht geht, dann schau dir mal den Eintrag aus /etc/fstab an.

interessant, er schreibt beim touch befehl Permission denied

Das hatte ich erwartet. :wink: Aber ich hoffe “cp” ging dann auch nicht. :wink:
Poste mal den Eintrag deiner /etc/fstab.

Mein FSTAB eintrag
//192.168.1.2/nextcloud/ /media/nextcloud cifs username=meinbenutzer,password=meinpasswort 0 0

Der Benutzer ist der von der Windows freigabe

cp hab ich nicht probiert, dafĂŒr mkdir und das geht auch nicht

Leider kenne ich mich mit SMB/CIFS gar nicht aus. Aber vielleicht in diese Richtung mal versuchen.

//192.168.1.2/nextcloud /media/nextcloud cifs username=meinbenutzer,password=meinpasswort,iocharset=utf8,file_mode=0777,dir_mode=0777

Wichtig:
Es muss alles erst auf der Konsole funktionieren. Vorher brauchst du es mit Nextcloud gar nicht versuchen.

hab jetzt das in der fstab ergÀnzt, sudo mount -a und dann schreibt er aber beim ordner erstellen in der konsole wieder permission denied mit dem user www-data

Am besten du liest auch noch mal diesen Beitrag. Vielleicht musst du auch mehr in diese Richtung denken.

Data Ordner auf Netzlaufwerk

Daraus ergibt sich dann eher:

//192.168.1.2/nextcloud /media/nextcloud cifs username=meinbenutzer,password=meinpasswort,iocharset=utf8,
uid=www-data,gid=www-data,file_mode=0777,dir_mode=0777 0 0

/mnt/.smbcredentials
mit dem hab ich es auch schon probiert das geht genau so wenig

Die Inhalte der Datei kannst du auch direkt einbauen. Schau meinen vorherigen Eintrag, den ich editiert habe. In dem Post waren die Benutzerrechte jedoch anders. Versuche aber erst mal 0777.

nachdem ich dann deinen oberen Beitrag (uid und gid)
hinzugefĂŒgt habe reicht mir dann ein sudo mount -a das er das ĂŒbernimmt? sollte er eigentlich bei mount -a irgendwas auswerfen?

Naja. Du mountest es dann nur noch ĂŒber den Namen (/media/nextcloud) und wenn du
mount /media/nextcloud (Parameter -a sagt mir gerade nichts)
eingibst, solltest du den Share ja auch sehen. Vorher musst du den alten Share natĂŒrlich unmounten.
umount /media/nextcloud
(wenn das aus irgendwelchen GrĂŒnden nicht mehr geht: booten)

Falls es immer noch nicht geht, kannst du noch mal die Zusatzoption ,rw probieren wo die ganzen Parameter mit Komma stehen.

bei sudo umount /media/nextcloud meint er target is busy
ich könnte stattdessen rebooten? Übernimmt er dann den neuen eintrag in der fstab?

Also unmount und mount neu durchgefĂŒhrt, zur sicherheit einen reboot ausgefĂŒhrt, “,rw” in der fstab zum schluss vor 0 0 ergĂ€nzt
leider noch immer “permission denied” wenn ich mit dem user www-data einen ordner erstellen möchte.

Problem gelöst, hab im Windows einen User www-data erstellt und diesem Zugriff auf den Ordner gewĂ€hrt
ob das jetzt die elegante Lösung ist weiß ich nicht aber sie funktioniert.
Vielen herzlichen Dank fĂŒr deine Hilfe

1 Like

Ist vielleicht eine Übergangslösung. Irgendwie scheint wohl mit der alten Konfiguration das Mapping zwischen deinem Benutzer und www-data nicht zu funktionieren. Ob es am Ende an Linux oder Windows lag weiß ich nicht. Vielleicht war auch nur die definierten Rechte 0777 usw. falsch.

hat mich schon viel Zeit und vorallem Nerven gekostet, solange es so funktioniert werd ich mal nicht weiter dran herumdoktorn und es mal so lassen.
Danke fĂŒr deine Geduld

1 Like