Solved: Zugriff ĂŒber einen Reverse Proxy

Nexcloud: Nextcloud Hub II (23.0.3)

Hallo,

in der Suchfunktionbin ich auf diesen Beitrag gestoßen, der einen Zugriff via Reverse-Proxy behandelt. Dennoch werde ich nicht so recht schlau aus den Hinweisen:

Zum System:
Nextcloud lĂ€uft in einem Docker Container. Es steht nur ein http-Zugang (Port 80) zur VerfĂŒgung.
Im Reverse-Proxy werden alle https-Zugriff auf die internet IP-Adresse vom Nextcloud-System mit dem Protokoll http weitergeleitet.

In Nextcloud wird folgende Warnung angezeigt:

  • Du greifst ĂŒber eine sichere Verbindung auf Deine Instanz zu, Deine Instanz generiert jedoch unsichere URLs. Dies bedeutet höchstwahrscheinlich, dass Du Dich hinter einem Reverse-Proxy befindest und die Konfigurationsvariablen zum Überschreiben nicht richtig eingestellt sind. Bitte lese die Dokumentation hierzu :arrow_upper_right:.

Auf der angegebenen Webseite werde ich nicht so ganz schlau, was nun gemacht werden soll:
Unter ‘trusted_domains’ wurde bereits die IP-Adresse des Reverse-Proxy hinzugesetzt.
ZusĂ€tzlich wurde unter ‘trusted_proxies’ die IP-Adresse des Proxys ebenfalls angegeben.

Denoch wird die Warnung unverÀndert angezeigt.

Weiß jemand, welche Angaben noch angegeben werden mĂŒssen?

Nachtrag:

Zwischenzeitlich wurde die Lösung gefunden:

In der Config.php fehlte nur ein Eintrag:

‘overwriteprotocol’ => ‘https’,

Durch diesen Eintrag wird das Protokol von http auf https ĂŒberschrieren.

Hintergrund: Im Docker Container steht nur ein http-Zugang zur VerfĂŒgung.

Hallo Ben-2003,

dass ist einer der Standardfehler die man bei der Installation noch mitmachen muss, sobald die Nextcloud im Browser aufrufbar ist. Ich bin zu faul das jetzt im Detail zu erklÀren und paste dir einfach nur das hier rein, was in meiner Dokumentation steht :slight_smile: :
Aus SicherheitsgrĂŒnden mĂŒssen Sie die Proxyserver, denen Nextcloud vertrauen soll, explizit definieren. Verbindungen von vertrauenswĂŒrdigen Proxys werden speziell behandelt, um die tatsĂ€chlichen Clientinformationen fĂŒr die Zugriffskontrolle und Protokollierung abzurufen. Parameter werden konfiguriert in:
/var/www/html/nextcloud/config/config.php
‘trusted_domains’ =>
array (
0 => ‘10.0.20.11’,
1 => ‘nc-subdomain.eigeneDomain.de’,
2 => ‘nc-subdomain’
),

In meinem Fall habe ich fĂŒr meine Domain Wildcard-Zertifikate. Das bedeutet, dass ich die Zertifikate auch fĂŒr Subdomains nutzen kann. Die IP-Adresse ist im Grunde nicht nötig anzugeben, aber wenn Du ĂŒber das Internet auf deine Nextcloud willst, dann fragst Du im Browser ja auch nicht die interne IP-Adresse an sondern sub.domain.de und diese solltest Du dann eben eintragen.

Ich hoffe, ich konnte auch mal helfen :blush:

Viel Erfolg. Bitte um RĂŒckmeldung ob es geklappt hat.

Hallo Freigeist,

vielen Dank fĂŒr die RĂŒckmeldung :slight_smile:

Diese Angaben habe ich schon ergÀnzt.

ZusÀtzlich war noch wichtig 


‘trusted_proxies’ => [‘192.168.1.32’],


 anzugeben.

GlĂŒckwunsch @Ben-2003
Ich hatte mal die nginx-Dokumentation durchgearbeitet, dort findet man keine Informationen wie “overwriteprotocol”.
Wo finde ich denn eine vollstĂ€ndige Dokumentation ĂŒber die Möglichkeiten der Variablen, welche man nutzen kann?