[solved] Internal Server Error after 16.0.1 Update

Nextcloud version: 16.0.1
Operating system and version: not sure, hostet on all-inkl.com
Apache or nginx version: same
PHP version: tried 7.1, 7.2 & 7.3

The issue I am facing:
I updated (from 15.0.7) to 16.0.1 with the updater and everything went smooth as usual. However, since then I can no longer access the Settings of my installation … all I get is an internal server error (see below for the logs):

The log suggests, that it has something to do with the Mail Template Editor (which I never knowingly used) so I deactivated it - now, when I want to access the “Settings” I get this:

Is this the first time I’ve seen this error? Yes

Steps to replicate it:

  1. Whenever I try to access: /index.php/settings/user

The output of my Nextcloud log:

  • From the /data/nextcloud.log I get the error-message:
    Class ‘OC_L10N’ not found
    (the whole thing https://pastebin.com/7QZgBszZ)
  • There I found out it had to have something to do with the templateeditor app so when I deactivate the Mail Template Editor app, the error message changes (see image above) and I get this in the log:
    Call to undefined method OCP\Util::linkTo()
    (the whole thing https://pastebin.com/nk010YsM)

The output of my config.php file in /path/to/nextcloud/config/:

Thank you for any suggestions. =)

Looks like an old bug in the updater.

I would disable app for app with the occ command and try again.

Okay, cool - that worked. Thank you for that tip. =)

With the Mail Template Editor deactivated I also had to deactivate the Updater app to regain full access to all settings.
Is this Updater app crucial? What does it update? I could not find it in the app store. o_O

I always disable third party apps BEFORE updating Nextcloud.

IMHO the updater should check before updating but it does not :frowning:

I think I saw cases where the app-manager stated, that apps are not tested or might cause issues with a newer version and disabled them. Therefore, I figured the installation has everything under control - but apparently I was wrong. :grin:

Thank you again for your help - I will incorporate this manual step in my update schedule.

1 Like

Hi. I have the same problem
I updated (from 15.0.4) to and everything went smooth but now i get an internal server error.
i have php 7.2.15
my sql 10.2.12
on qnap with qts 4.3.6
i don’t now what to do because there are no errors in my nextcloud.log
please help