[SOLVED] Es ist ein Fehler aufgetreten | An error has occurred

After updating from NextCloud to 14.0 i got this Error:
Update vorbereiten
Log-Level auf “debug” gesetzt
Wartungsmodus eingeschaltet
Das Datenbankschema wird aktualisiert
Datenbank aktualisiert
Suche nach einer Aktualisierung für die App “activity” im App-Store
Es ist ein Fehler aufgetreten.

in english:
Prepare Update
Log level set to "debug
Maintenance mode switched on
The database schema is updated.
Database updated
Search for an update for the app “activity” in the App-Store
An error has occurred.

Now I can’t use my NextCloud anymore.

Ubuntu 16.04 LTS
Webserver: nginx
php: 7.1.21

The error has already occurred once, but the solution can no longer be used because the data no longer exists.


1 Like

Hallo Hoerli,

terminal login to your server

cd /var/www/nextcloud/updater

sudo -u www-data php updater.phar

check in the dialog - to restart next steps

its helps by interrupts in the update, if the problem is “web-based”

do you can continue the update ?

Not working.
I got this Log:

Current version is 14.0.0.

Update to Nextcloud 14.0.0 available. (channel: “stable”)
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-14.0.0.zip

Steps that will be executed:
[ ] Check for expected files
[ ] Check for write permissions
[ ] Create backup
[ ] Downloading
[ ] Verify integrity
[ ] Extracting
[ ] Enable maintenance mode
[ ] Replace entry points
[ ] Delete old files
[ ] Move new files in place
[ ] Done

Start update? [y/N] y

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[:heavy_check_mark:] Check for expected files
[:heavy_check_mark:] Check for write permissions
[:heavy_check_mark:] Create backup
[:heavy_check_mark:] Downloading
[:heavy_check_mark:] Verify integrity
[:heavy_check_mark:] Extracting
[:heavy_check_mark:] Enable maintenance mode
[:heavy_check_mark:] Replace entry points
[:heavy_check_mark:] Delete old files
[:heavy_check_mark:] Move new files in place
[:heavy_check_mark:] Done

Update of code successful.

Should the “occ upgrade” command be executed? [Y/n] y
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Set log level to debug
Turned on maintenance mode
Updating database schema
Updated database
Checking for update of app activity in appstore
An unhandled exception has been thrown:
Error: Call to undefined method GuzzleHttp\Client::request() in /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/Http/Client/Client.php:161
Stack trace:
#0 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/App/AppStore/Fetcher/Fetcher.php(106): OC\Http\Client\Client->get(‘https://apps.ne…’, Array)
#1 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/App/AppStore/Fetcher/AppFetcher.php(80): OC\App\AppStore\Fetcher\Fetcher->fetch(’’, ‘’)
#2 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/App/AppStore/Fetcher/Fetcher.php(170): OC\App\AppStore\Fetcher\AppFetcher->fetch(’’, ‘’)
#3 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/Installer.php(385): OC\App\AppStore\Fetcher\Fetcher->get()
#4 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/Updater.php(445): OC\Installer->isUpdateAvailable(‘activity’)
#5 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/Updater.php(256): OC\Updater->upgradeAppStoreApps(Array)
#6 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/Updater.php(126): OC\Updater->doUpgrade(‘’, ‘’)
#7 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/core/Command/Upgrade.php(262): OC\Updater->upgrade()
#8 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/3rdparty/symfony/console/Command/Command.php(251): OC\Core\Command\Upgrade->execute(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#9 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/3rdparty/symfony/console/Application.php(946): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#10 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/3rdparty/symfony/console/Application.php(248): Symfony\Component\Console\Application->doRunCommand(Object(OC\Core\Command\Upgrade), Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#11 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/3rdparty/symfony/console/Application.php(148): Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#12 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/lib/private/Console/Application.php(213): Symfony\Component\Console\Application->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#13 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/console.php(96): OC\Console\Application->run()
#14 /storage/Plesk/MyCloudDomain.com/MyCloudDomain.com/occ(11): require_once(’/storage/Plesk/…’)
#15 {main}
Keep maintenance mode active? [y/N] n

Maintenance mode is disabled

Still not woring.
After i start ./occ upgrade i got the same error

1 Like

If someone has a simple solution to transfer contacts, calendars and encrypted data from accounts to a new NextCloud installation, it would also help me.
My family and some friends are waiting for the Cloud :expressionless:

Disable apps “bookmarks” or “files_external_gdrive” if they are in use before upgrading nextcloud.
These apps ship an incompatible version of guzzle.
You may identify other apps with incompatible guzzle by using following command:
find /<path_to_nextcloud>/apps -iname "guzzle*"


Gdrive-App was the trigger! I removed the folder and was able to install the update correctly.


Had the same issue, with me it was files_external_dropbox. Thanks @timm2k :tada:

Thank you had the same problem!!