Fehler nach Update auf 12.0.1

Moin,

habe grad über den Webupdater das Update auf 12.0.1. eingespielt. Dabei gabs einen Fehler.

Update vorbereiten
Log-Level auf “debug” gesetzt
Wartungsmodus eingeschaltet
Das Datenbankschema wird aktualisiert
Datenbank aktualisiert
Suche nach einer Aktualisierung für die App “activity” im App-Store
Es ist ein Fehler aufgetreten.

Der letzte Eintrag in der nextcloud.log zeigt:

{“reqId”:“WYl7FVUNnJYAACxcif8AAAAN”,“level”:3,“time”:“2017-08-08T10:49:26+02:00”,“remoteAddr”:“84.182.179.49”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/core/ajax/update.php?requesttoken=UVwmx6vdjuHdyjhAGm9reqhidAlOPi53ucOMYwWzHCY%3D%3ABWUW9Min2YCqmFsYdyJSI88zBVw0DHgFjPr8NUuGN2s%3D",“message”:“Error: Cannot access private property OCA\Files_Trashbin\Storage::$mountPoint at /www/htdocs/apps/files_accesscontrol/lib/Operation.php#85”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0”,“version”:“12.0.0.29”}

Nextcloud läuft auf einem Account bei All-Inkl.com mit PHP7.1 und MySQL. Konsolenzugriff habe ich leider nicht.

Hat jemand eine Idee, wie man das Problem lösen kann?

Danke

1 Like

Ich hatte einen ähnlichen / den gleichen Fehler. Kann ich grad nicht nachsehen.
Habe leider als mögliche Ursachen ein “Gemisch” von mehreren Änderungen.

  • Installation Videomodul
  • Aktivierung opcache gemäß Performance Hinweis in Grundeinstellungen
  • eben das Update auf 12.01

Ich habe als Gegenmaßnahmen letztlich opcache wieder deaktiviert und das Video Modul deaktiviert und Apache/PHP sowie vserver neu gestartet. Wie das ohne console geht, weiß ich nicht.

Da mein Server nur 2gb RAM hat, gehe ich davon aus, dass hier irgendwo die Ursache liegt. Ich kann den zeitlichen Ablauf / Ursache Wirkung leider nicht wirklich eingrenzen. Muss die Schritte noch mal einzeln durchspielen.

Nach ein wenig Sucherei…

scheint ein ähnliches Problem zu sein, wie hier (Nextcloud 12.0.1RC4 - HELP TEST!) beschrieben.

Leider weiß ich immer noch nicht, wie in das Problem behebe…

Exakt gleiches Problem auch bei mir (bin auch bei All-Inkl.com)

Hab das Problem nicht wirklich lösen können. Alle Ansätze hätten einen SSH-Zugang benötigt mit weiteren Konfigurationsmöglichkeiten.

Hab jetzt eine Neu-Installation gemacht und werde erstmal mit dem Update warten.

Die Performance bei All-Inkl ist jetzt aber mehr als bescheiden. Login dauert teilweise > 15 Sekunden.

Ich bin leider auch betroffen und hoffe, dass das Problem auch ohne Neuinstallation lösbar ist.

Gibt es schon Lösungsansätze?

Die Lösung steht hier: Nextcloud 12.0.1 stable Error: Cannot access private property
Ich habe via Web-FTP in der Datei /nextcloud/apps/files_accesscontrol/lib/Operation.php die Zeilen 84 und 85 gelöscht und mit dem empfohlenen Fix überschrieben:

        $hasMountPoint = $storage instanceof StorageWrapper;
  	if (!$hasMountPoint) {
  		$ref = new \ReflectionClass($storage);
  		$prop = $ref->getProperty('mountPoint');
  		$hasMountPoint = $prop->isPublic();
  	}
  	if ($hasMountPoint) {
  		/** @var StorageWrapper $storage */
  		$fullPath = $storage->mountPoint . $path;
  	} else {
  		$fullPath = $path;
  	}

Nun noch vor dem Neuladen der Nextcloud-Webseite in der Datei /nextcloud/config/config.php den Parameter ‘maintenance’ auf ‘false’ zu setzen.
Danach lief es bei mir.


Wenn es euch geholfen hat, dann bitte diesen Beitrag als Lösung markieren, Danke!

5 Likes

Vielen Dank! Das hat geholfen! Ich dachte schon, ich müsste die Nextcloud neu aufsetzen. :relaxed:

Vielen Dank, nach Stunden der Suche war das hier die Lösung.

Dieser Fix hat bei mir auch vom Update auf 12.0.2 geholfen. Hatte den gleichen Fehler.