[SOLVED] Error update from 28.0.1 to 28.0.2 move new files in place

hey Folks,

this time it seems the updater hits me, hfter several years of stable usage

OS: Runs within Freebsd jail
PHP 8.2

any idea?

Repeat it with the command line updater. It is ALL explained → here ←

Much and good luck,

root@nextcloud:/usr/local/www/nextcloud/updater # sudo -u www php /usr/local/www/nextcloud/updater/updater.phar
PHP Warning:  PHP Startup: Invalid date.timezone value 'Germany/Berlin', using 'UTC' instead in Unknown on line 0
PHP Fatal error:  Uncaught Error: Class "Phar" not found in /usr/local/www/nextcloud/updater/updater.phar:10
Stack trace:
#0 {main}
  thrown in /usr/local/www/nextcloud/updater/updater.phar on line 10
pkg install php82-phar

was just not installed…
most likely thats the reason the browser update was not going thru

I was just answering that.

No, that was not the reason. The webupdater does not make use of the phar extension.

Came here to say that I had this same issue. Even the command line updater gave me the same error. So I updated manually following these instructions. It seemed to work, but the web UI still says I’m at 28.0.1 and there’s an update available to 28.0.2.

However, I tried updating via the command line and I get:

# sudo -u www-data php /var/www/nextcloud/updater/updater.phar
Nextcloud Updater - version: v28.0.2rc2-1-gba2e50f dirty

Current version is 28.0.2.

No update available.

Nothing to do.

I’m also getting errors in my logs:

Could not find resource core/js/global-search.js to load

So I just rebooted the machine and now the web UI shows the proper version, but it still says there’s an update available.


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.