[SOLVED] Another "Failed to load Collabora Online - please try again later" problem

Oh my god you are a life saver

you saved my day

I’m sure they’ve created a frustrating confusing disaster for many people because who thinks to look at a working reverse proxy configuration? I don’t know why they didn’t just do a symlink in the container instead of wasting hours of people’s time trying to hunt down the problem but oh well. :slight_smile:

Yeah, I first noticed the issue with the beta versions, but thought, eh maybe it’s an issue they will fix. Then they rolled out the stable and it was still happening, and I was thinking… crap…

I happened to be digging in the docker container, cause I had scripts that deployed the container with additional fonts. That portion suddenly wouldn’t work, which I found was because of the folder change. Then I was eventually able to put two and two together. But still, that was an hour and half I’d like back…

oh trust me im okay with wasting my time reading the official docs but the thing is, official docs are old even (uses the old lool) This is why it was super confusing like i followed the docs and yet can’t do it


to be honest nextcloud community support is fucking bad. I feel devs are here to just help companies and not us in the forums

So literally it was only YOU who linked to the new nginx configuration so really thank you <3

an hour? i spent day and half just to know it was cool now instead of lool :joy:

Yeah…I got lucky, no doubt about it.

Slightly off topic - but docker collabora version
confirmed working. I’m aware a lot of the other posts above were in relation to non-docker version, however sometimes its good to find information in general on what versions work, and what do not.

I think most know newer versions of docker work fine. The issue was the surprise, not really announced, extra reconfiguration of the reverse proxy server for those upgrading from versions earlier than 21

@jshpettus – Hey thanks for that information. Really good. Mine was running fine but after reading your response – I thought to myself – what the heck?? My configuration should be blowing up just like everybody elses. But it wasn’t. So I had to investigate.

So my setup is a traefik reverse proxy (communicates via https with nextcloud) that proxies over http to the collabora docker container listening on port 9980.

I looked at the documentation and all I saw mentioned was either Apache or Nginx for the reverse proxy – nothing about traefik. I see where the developers switched the loolwsd directory to coolwsd (which honestly imo very dick move but whatever). Traefik since it was tied to exact directly structure that was modified continued to reverse proxy as normal. Weird. I guess truly dumb look on this one.

Thanks for update.

Thanks this fixed the problem for the built-in Collabora Online Development Edition (CODE) server app. The error appeared after after app updates.

It works for me! - Thank you, you are my hero :+1:.
Nextcloud 24.0.4-0
Collabora CODE
on an Univention 4.4-9 Server

I was searching more than 6 months for this solution, so I used the “Nextcloud Office”-app as a replacement while that time.

I made an account on these forums just to post and tell you that this also solved my problem. Praises be.

For the record for future users. This error can also be a result of security changes they made I think a year ago.

With newer versions of the container they have gotten rid of the old “domain” flag and replaced it with the optional aliasgroup# which lets you specify even multiple domains if needed.

Now the default, with no flag set, is collabora server will bind to the first connection of the MAC address of the Nextcloud server that connects to it. It will then not allow anything else to connect (and you will get that error). That’s fine for most, but depending on your set up, you may need to specify that aliasgroup1 flag so it can go by domain instead.